Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-06-2003, 09:07 AM   #1
robvas
Scooby Newbie
 
Member#: 17466
Join Date: Apr 2002
Location: Saginaw, MI
Default Stock STi 1/4 mile times

Is there a page with them, or another thread? Maybe everyone could list them here.
* Registered users of the site do not see these ads.
robvas is offline   Reply With Quote
Old 10-06-2003, 09:52 AM   #2
Wombat North
Scooby Specialist
 
Member#: 21267
Join Date: Jul 2002
Location: Eats, roots and then leaves
Vehicle:
STI, EWG 8cm Green
UTEC/ECUtek/WI & SD tune

Default

Wombat North is offline   Reply With Quote
Old 10-06-2003, 11:53 AM   #3
dsmperformance
Scooby Specialist
 
Member#: 15059
Join Date: Feb 2002
Chapter/Region: MAIC
Location: Latrobe, PA
Vehicle:
2004 WRX STi
1991 TSi

Default

dsmperformance is offline   Reply With Quote
Old 10-07-2003, 05:07 PM   #4
Bailey
Scooby Specialist
 
Member#: 12572
Join Date: Nov 2001
Chapter/Region: NWIC
Location: Portland Oregon
Vehicle:
2004 STi
35R is enough

Default

I've dragged two separate STIs. One with a tubo back and the other bone stock.

13.46 best on the car with a turbo back @99 mph
13.57 best on the stock STI @98

Both done at portland international speedway on the same evening

1.8 60' times for all

Bailey
Bailey is offline   Reply With Quote
Old 10-07-2003, 05:52 PM   #5
horshack
Scooby Specialist
 
Member#: 19236
Join Date: May 2002
Vehicle:
Axis GT35/40R STi
Not back yet

Default

I took mine with a TBE out weekend before last.

1.52 60'

13.378 @101

I know its faster than that, just need more practice.
horshack is offline   Reply With Quote
Old 10-07-2003, 06:36 PM   #6
Bailey
Scooby Specialist
 
Member#: 12572
Join Date: Nov 2001
Chapter/Region: NWIC
Location: Portland Oregon
Vehicle:
2004 STi
35R is enough

Default

Quote:
Originally posted by horshack
I took mine with a TBE out weekend before last.

1.52 60'

13.378 @101

I know its faster than that, just need more practice.
Very nice 60' time. How do you launch?? What kind of tires? DCCD in manual or automatic? If manual, what setting?

Thanks
Bailey
Bailey is offline   Reply With Quote
Old 10-07-2003, 08:47 PM   #7
horshack
Scooby Specialist
 
Member#: 19236
Join Date: May 2002
Vehicle:
Axis GT35/40R STi
Not back yet

Default

Quote:
Originally posted by Bailey


Very nice 60' time. How do you launch?? What kind of tires? DCCD in manual or automatic? If manual, what setting?

Thanks
Bailey
Launch - 5k RPM's - Lift clutch quickly and steady on last amber, do not side step!

Tires - Stock STi tires

DCCD - Manual, rolled dial all the way to the rear

Hope that helps, its not an exact science, but I am working on it.
horshack is offline   Reply With Quote
Old 10-07-2003, 10:56 PM   #8
Ziglabeu
Scooby Newbie
 
Member#: 4024
Join Date: Feb 2001
Location: Canada
Vehicle:
2004 impreza WRX STi
World Rallye Blue

Default

That 60' is impossible for the ET time... u should be near 1.7-1.8
Ziglabeu is offline   Reply With Quote
Old 10-07-2003, 11:30 PM   #9
horshack
Scooby Specialist
 
Member#: 19236
Join Date: May 2002
Vehicle:
Axis GT35/40R STi
Not back yet

Default

Quote:
Originally posted by Ziglabeu
That 60' is impossible for the ET time... u should be near 1.7-1.8
believe it or not, but 1.52 is my quickest, as is the 13.378 yet.

i have been consistantly cutting 1.6's, although i think my et is subject having to shift at the end of the track.

im afraid to rev past 6500 although i am sure the valvetrain can handle it.
horshack is offline   Reply With Quote
Old 10-08-2003, 01:13 AM   #10
AZ2004STi
Scooby Newbie
 
Member#: 43761
Join Date: Sep 2003
Location: Peoria, AZ
Vehicle:
2004 WRX STi
403AWHP & 360AWTQ (Sold)

Default

Horshack,
What track were u cutting those times? I'm from the valley and have yet to take my car to the track. Was it the typical 100 degree day here in Phx when you ran those times?
AZ2004STi is offline   Reply With Quote
Old 10-08-2003, 09:22 AM   #11
horshack
Scooby Specialist
 
Member#: 19236
Join Date: May 2002
Vehicle:
Axis GT35/40R STi
Not back yet

Default

Quote:
Originally posted by AZ2004STi
Horshack,
What track were u cutting those times? I'm from the valley and have yet to take my car to the track. Was it the typical 100 degree day here in Phx when you ran those times?
The fastest time was at Firebird surprisingly.

I started getting 1.6's when I was at Speedworld. And I have been lucky, every night that I have been, its been around 85, obviously as we get closer into fall these temps will get lower and times will get faster.
horshack is offline   Reply With Quote
Old 10-08-2003, 09:59 AM   #12
metoo
Scooby Guru
 
Member#: 4764
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston
Vehicle:
2004 STi sold :(
forizzle

Default

Quote:
Originally posted by horshack


believe it or not, but 1.52 is my quickest, as is the 13.378 yet.

i have been consistantly cutting 1.6's, although i think my et is subject having to shift at the end of the track.

im afraid to rev past 6500 although i am sure the valvetrain can handle it.
Would you please post a timeslip. I've having a hard time swallowing the 1.5. I think you may be mistaking it for reaction time or something. It sounds too low for the ET you are getting, even in 85 degree weather.
metoo is offline   Reply With Quote
Old 10-08-2003, 10:43 AM   #13
Ziglabeu
Scooby Newbie
 
Member#: 4024
Join Date: Feb 2001
Location: Canada
Vehicle:
2004 impreza WRX STi
World Rallye Blue

Default

Metoo same here... this 60'' should be a pretty low 12s car
Ziglabeu is offline   Reply With Quote
Old 10-08-2003, 04:24 PM   #14
afpdl
Scooby Guru
 
Member#: 26361
Join Date: Oct 2002
Chapter/Region: TXIC
Location: Sugar Land (Houston), Tx
Vehicle:
My shenanigans are
cheeky and fun

Default

If you are cutting 1.5sec 60fts and your et is 13.3s either you are the worst shifter of all time or your car is broken. You have 2 tents on people who are running 13.0s stock, right off the line. It just doesnt add up unless your tbe caused you to lose all top end speed.
afpdl is offline   Reply With Quote
Old 10-09-2003, 05:22 PM   #15
metoo
Scooby Guru
 
Member#: 4764
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston
Vehicle:
2004 STi sold :(
forizzle

Default

Quote:
Originally posted by horshack


believe it or not, but 1.52 is my quickest, as is the 13.378 yet.

i have been consistantly cutting 1.6's, although i think my et is subject having to shift at the end of the track.

im afraid to rev past 6500 although i am sure the valvetrain can handle it.
Come on, man. Post the slip, or at least verify whether you were mistaking your reaction time for your 60'.
metoo is offline   Reply With Quote
Old 10-09-2003, 07:37 PM   #16
horshack
Scooby Specialist
 
Member#: 19236
Join Date: May 2002
Vehicle:
Axis GT35/40R STi
Not back yet

Default

Quote:
Originally posted by metoo


Come on, man. Post the slip, or at least verify whether you were mistaking your reaction time for your 60'.
ok, 2 problems:

1. scannner doesnt work with XP, its too old, so no time slip to post.

2. i dont have the time to explain that in phoenix the track is at 1200', so there are a lot of factors in why the et is in the low 13's.

i didnt mistake or mis read, reaction time of .88 and the 60', plus its kinda hard to mistake since its labled 60' and reaction time.

you all dont have to believe me, its not that important that i prove it to you either.

plus as soon as i could have posted the slip, someone would have cried photoshop!

you some day you will also cut 1.5's - 60' and then a believer you will be.
horshack is offline   Reply With Quote
Old 10-09-2003, 07:59 PM   #17
AZ2004STi
Scooby Newbie
 
Member#: 43761
Join Date: Sep 2003
Location: Peoria, AZ
Vehicle:
2004 WRX STi
403AWHP & 360AWTQ (Sold)

Default

Horshack,
Let me know when u plan on going to the track again and I'll go there and meet u. I have yet to drag my STi so some pointers would be cool. If you run what u say u do I'll back your words on here.
AZ2004STi is offline   Reply With Quote
Old 10-09-2003, 09:15 PM   #18
Drews_WRX
Scooby Specialist
 
Member#: 20354
Join Date: Jun 2002
Chapter/Region: SCIC
Location: Rancho Cucamonga, CA
Vehicle:
2005 SRT-4
POS Mopar stage 2

Default

you would have to have upwards of 400hp to cut 1.5 60ft's. And if you cut 1.5 60's, you should be running like 11.7-12.2 1/4 mile.

Dont kid yourself and everyone on here.
Drews_WRX is offline   Reply With Quote
Old 10-09-2003, 10:37 PM   #19
nhluhr
John Wayne Toilet Paper
Moderator
 
Member#: 7327
Join Date: Jun 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2008 Mazdaspeed3
2006 Wrangler Sport

Default

the very fastest 60' times on scoobymile.com is a 1.581 and those cars all were 12.05 or faster.

If this guy is claiming a 1.5 60' and a 13.3 ET, he is either lying, or the timing equipment wasn't set up right and he doesn't know that he is telling false information. either way, it's B.S.

Nobody with a 13+ ET even broke into the 1.6 60ft times.
nhluhr is offline   Reply With Quote
Old 10-10-2003, 12:25 AM   #20
909
Scooby Newbie
 
Member#: 18776
Join Date: May 2002
Default

Dude, seriously, that 60 is not achievable with the stock set up or a slightly modded set up. I don't care how good an STi driver you are.
909 is offline   Reply With Quote
Old 10-12-2003, 07:40 PM   #21
solberg wantabee
Scooby Newbie
 
Member#: 17493
Join Date: Apr 2002
Location: San Diego
Vehicle:
2004 STi
Boring Blue

Default The laws of physics in your car don't exist

I dragged my car at qualcomm(san diego). Unfortunately only an 1/8 mile track. I put down some good times for my car being stock. My quickest time was 8.577 for the 1/8th with a 1.729 60' time with a perfect launch.
solberg wantabee is offline   Reply With Quote
Old 10-14-2003, 03:34 AM   #22
IA Performance
NASIOC Vendor
 
Member#: 25194
Join Date: Sep 2002
Chapter/Region: RMIC
Location: Boulder, CO
Vehicle:
2008 Forester XT 5mt
Dark Gray

Default

Well, the track at speedworld is generally faster than firebird. I used to cut constant 12.8s in my s4 2 years ago at speedworld. Then 13.0s and 12.9s at firebird. I've never seen a street car cut that type of 60 foot though. I'm not saying it can't be done, but highly unlikely. Clark ran a 11.87 or so at 117 mph with his completely tuned out wrx (yes, I know diff. car) and that was with a 1.6 60foot time. Fastest he had ever cut. And that was with spraying a 75shot in all 4 gears. This is on top of mods. Maybe I'll come out and watch you drag sometime. I'm hoping my soon to be 400 + whp wagon can cut a 1.7.
IA Performance is online now   Reply With Quote
Old 10-14-2003, 05:17 AM   #23
drdeuce
Scooby Newbie
 
Member#: 36075
Join Date: Apr 2003
Location: Calgary, Alberta, Canada
Vehicle:
2004 STi 2.65L GT35R
Hydra

Default

GMC syclones, which have to be one of the hardest lauching vehicles of all time, don't even get 1.5 60' foot times and that is with them lauching at full boost. There must be someting wrong with the timing equipment.

jz
drdeuce is offline   Reply With Quote
Old 10-14-2003, 01:51 PM   #24
bcblues
Scooby Specialist
 
Member#: 17256
Join Date: Apr 2002
Chapter/Region: MWSOC
Location: America's Outback
Vehicle:
04 STi
Blue w/ custom bug splat

Default

my best 60' was 1.688, on a 13.285@100.67 run. Stock, cept for a turbo-back and Joe P set to 1 bar (which may be lower than stock!)
bcblues is offline   Reply With Quote
Old 10-14-2003, 11:18 PM   #25
bcblues
Scooby Specialist
 
Member#: 17256
Join Date: Apr 2002
Chapter/Region: MWSOC
Location: America's Outback
Vehicle:
04 STi
Blue w/ custom bug splat

Default

I meant to say AXLE BACK (Prodrive) exhaust.
bcblues is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MY Stock 07 STi 1/4 mile time ..... KillaSti Proven Power Bragging 60 05-15-2007 08:40 PM
sti 1/4 mile times for stock turbo and injectors with no nitrous whitesti04 Proven Power Bragging 59 05-08-2005 11:51 PM
Stock DSM 1/4 mile times apollo Off-Topic 7 10-04-2003 12:47 AM
Who's got the best stock Impreza 1/4 mile times? Samirr76 Tri-State Area Forum 8 10-15-2001 03:54 PM


All times are GMT -4. The time now is 03:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.