Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-09-2013, 08:14 PM   #1
vijaynagaraj
Scooby Newbie
 
Member#: 327803
Join Date: Jul 2012
Chapter/Region: NESIC
Vehicle:
2012 Impreza
Dark grey metallic

Default Weird Problem with my 2012 Impreza

After shoveling two foot of snow for about two hours. I start my car and take it on the highway at 60mph the car started vibrating very badly, It was like the engine bay was not clamped or tightened properly. Severe vibrations. and then I turned back home because it felt wrong. Once I came back I just wanted to check how much the engine would rev on Park mode(have never tried it before), and it kept getting cut off at 4000rpm. If somebody could help me on this. It would be great. I'm kinda puzzled. thank you
* Registered users of the site do not see these ads.
vijaynagaraj is offline   Reply With Quote
Old 02-09-2013, 08:24 PM   #2
HinshawWRX
Medium Frank
Moderator
 
Member#: 140114
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Common Sense, VA
Vehicle:
2014 Porsche
GT3 (Currently on Fire)

Default

Was there any bit of snow packed in the wheels/wheel wells? I'm betting that is your issue.
HinshawWRX is offline   Reply With Quote
Old 02-09-2013, 08:28 PM   #3
vijaynagaraj
Scooby Newbie
 
Member#: 327803
Join Date: Jul 2012
Chapter/Region: NESIC
Vehicle:
2012 Impreza
Dark grey metallic

Default

there was very little of snow packed in the wheels. Could you maybe give me more insight on why it happens when there is snow packed in the wheels. Also is there a Rev limit of 4000 rpm in Park/Neutral mode ? I appreciate your reply
vijaynagaraj is offline   Reply With Quote
Old 02-09-2013, 08:34 PM   #4
thatderekguy
Scooby Newbie
 
Member#: 301501
Join Date: Nov 2011
Location: West virginia
Vehicle:
2002 WRX
black

Default

Ice and snow on the inside of your wheels.
thatderekguy is offline   Reply With Quote
Old 02-09-2013, 08:37 PM   #5
vijaynagaraj
Scooby Newbie
 
Member#: 327803
Join Date: Jul 2012
Chapter/Region: NESIC
Vehicle:
2012 Impreza
Dark grey metallic

Default

Is there a way to get rid of it ?
vijaynagaraj is offline   Reply With Quote
Old 02-09-2013, 08:51 PM   #6
HinshawWRX
Medium Frank
Moderator
 
Member#: 140114
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Common Sense, VA
Vehicle:
2014 Porsche
GT3 (Currently on Fire)

Default

Ice and snow on the inside of your wheels throws off the balancing. To get it off, knock it out/scrape it off. 4K RPM limit in park/neutral so you don't be an idiot and break something.
HinshawWRX is offline   Reply With Quote
Old 02-09-2013, 09:23 PM   #7
aeoporta
Scooby Specialist
 
Member#: 334126
Join Date: Oct 2012
Chapter/Region: Tri-State
Location: New York
Vehicle:
2013 5mt Sp Premium
Venetian Red & Dark Gray

Default

My gf was just complaint about this I told her what it was she looked ate funny lol oh well
aeoporta is offline   Reply With Quote
Old 02-09-2013, 09:26 PM   #8
Web Foot STi
Scooby Guru
 
Member#: 39086
Join Date: Jun 2003
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2004 STi
White

Default

Heated pressure washer at a DIY car wash, or drage your brakes for a bit to put some heat into your wheels. Nothing new for avid snow skiers. Drifting snow can pack into the wheels and there are then several oz of weight where it doesn't belong. Shake and shimmy.

Last edited by Web Foot STi; 02-09-2013 at 09:31 PM. Reason: Wromg there/their
Web Foot STi is offline   Reply With Quote
Old 02-09-2013, 09:26 PM   #9
vijaynagaraj
Scooby Newbie
 
Member#: 327803
Join Date: Jul 2012
Chapter/Region: NESIC
Vehicle:
2012 Impreza
Dark grey metallic

Default

Oh Jeeez that's a relief ... thanks guys .... I ain't gonna break anything ... was just curious
vijaynagaraj is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.