Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-09-2013, 08:30 PM   #1
nexile
Scooby Newbie
 
Member#: 346501
Join Date: Feb 2013
Default 97 sti started making terrible noises (soundclip)

Firs things first if you don't want to read, perhaps you can still have a listen:

Recently imported a 97 sti v4 type RA (84k km) I've been driving it just about a week now and it was running great. Just got the oil changed yesterday and later that night, I started hearing a rattling noise. Hardly noticeable when idling, it would get louder up to about 4k rpm and then I couldn't really hear it after that.

It was still running perfectly fine but I was fairly concerned about the rattle so I parked it last night and today I went to drive it maybe 2-3km to a mechanic friend's house so he could have a look at it. About 2 blocks from his house, it died while I was taking a turn and wouldn't start. Rolled it to his house and finally got it started up after putting it in 5th and rocking the car a bit to loosen it up I guess and now there's a couple other terrible noises, the rattle seems to be the least of my worries now.

We checked the starter, AC, power steering belts and had a look at (I think half of) the timing belt. Couldn't get at the other half very easily. None of those seem to be the issue.

I'm not sure what other information might be useful as this isn't really my area of expertise but if there's anything else I can tell to help diagnose this, just let me know. Really appreciate any help!
* Registered users of the site do not see these ads.
nexile is offline   Reply With Quote
Old 02-09-2013, 08:34 PM   #2
92tsiawdguy
Scooby Newbie
 
Member#: 235975
Join Date: Jan 2010
Chapter/Region: MWSOC
Location: kansas city missouri
Vehicle:
2007 Wrx STi
obp

Default

Sounds like rod knock from hell
92tsiawdguy is offline   Reply With Quote
Old 02-09-2013, 11:53 PM   #3
GGSimpreza
Scooby Newbie
 
Member#: 291739
Join Date: Aug 2011
Location: Harrisonburg, VA
Vehicle:
99 Impreza RS
Silver Milage

Default

Lots of head noise, rod knock also. If it has 84km on it, that's plenty of time to get abused. Probably bought a bad motor, or ran it too hard too soon if it was sitting for a while before you dropped it in.
GGSimpreza is offline   Reply With Quote
Old 02-10-2013, 01:10 AM   #4
blessthekellen
Scooby Specialist
 
Member#: 273859
Join Date: Feb 2011
Chapter/Region: W. Canada
Location: Alberta.
Vehicle:
MY98
WRX

Default

knock knock.
whos there?
blessthekellen is offline   Reply With Quote
Old 02-10-2013, 01:18 AM   #5
blkgm8
Scooby Newbie
 
Member#: 184543
Join Date: Jul 2008
Chapter/Region: NESIC
Vehicle:
JDM RHD GM8 Type R
02 6 Speed Bugeye

Default

Sounds like she's coming apart on you... good luck. I hope it isn't as bad as it sounds
blkgm8 is offline   Reply With Quote
Old 03-11-2013, 03:56 PM   #6
93TurboLegacy
Scooby Newbie
 
Member#: 349832
Join Date: Mar 2013
Default

That doesn't sound good at all. Definitely some rod knocking and some messed up heads there. Best of luck though.
93TurboLegacy is offline   Reply With Quote
Old 03-16-2013, 06:22 PM   #7
darksurfing
Scooby Newbie
 
Member#: 269804
Join Date: Jan 2011
Chapter/Region: International
Location: Stgo, Chile
Vehicle:
1997 Sti V-Limited
rally blue

Default

it definitely sounds like a rod knock, i would stop the car. Do not start the engine, you need to tear that engine apart and see the damage, i would recommend you to get a new dual thrust , double cross-drilled crankshaft, acl maim and rod bearinga, if your cylinder walls are not damage neither your pistons, you could save money and keep those that are like semi forged from the factory, just get a new set of OEM std size piston rings, new oil pump and oil cooler as well. If you cannot get your engine tune , i would recommend you to use a thicker head gasket mate, stock one is 1,37 mm. Use a 1,5 mm in order to reduce det. Thats what i did on my car and runs like a champ!. im sorry to heard this mate.. You definitely need to rebuild your ej20k engine
darksurfing is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.