Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-14-2013, 08:42 PM   #1
blacksubieee
Scooby Newbie
 
Member#: 295928
Join Date: Sep 2011
Location: Hickory, NC
Vehicle:
2005 STi

Default Coolant Smell

So I noticed this a couple months ago after I bought my ridden hard and put away wet sti. Anyways after driving for a little bit with the heat on I start to smell coolant coming through the vents. I've checked my coolant thinking maybe there was a leak but the level looked fine and still looks fine. I've been told maybe the heater core is bad. Any help would be greatly appreciated.
* Registered users of the site do not see these ads.
blacksubieee is offline   Reply With Quote
Old 02-14-2013, 08:48 PM   #2
HinshawWRX
Medium Frank
Moderator
 
Member#: 140114
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Common Sense, VA
Vehicle:
2014 Porsche
GT3 (Currently on Fire)

Default

Likely a heater core going. Good thing for you, it's a pain in the ass to do.
HinshawWRX is offline   Reply With Quote
Old 02-14-2013, 08:52 PM   #3
blacksubieee
Scooby Newbie
 
Member#: 295928
Join Date: Sep 2011
Location: Hickory, NC
Vehicle:
2005 STi

Default

Quote:
Originally Posted by HinshawWRX
Likely a heater core going. Good thing for you, it's a pain in the ass to do.
Thanks for that lol. I did buy a warranty so I hope that'll be covered
blacksubieee is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:31 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.