Welcome to the North American Subaru Impreza Owners Club Sunday April 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-27-2014, 02:40 PM   #1
Busaru48
Scooby Newbie
 
Member#: 396491
Join Date: Jul 2014
Location: Colorado Springs, CO
Vehicle:
2004 2.5TS

Default ej257 in 2004 impreza 2.5ts!?

I built my hybrid ej257 short block with ej251 sohc heads. I went to put the engine in the car and the motor mounts wont line up! It is a 2004 impreza 2.5ts and has the na crossmember and stock motor mounts. Everything i have read says it should fit like the motor mounts are the same in the sti and the only thing different about the crossmember is a cutout for the up-pipe. It is about half an inch towards the front of the car. The trans is mated to the engine. Am i doing it wrong or do i need different mounts?
* Registered users of the site do not see these ads.
Busaru48 is offline   Reply With Quote
Old 02-04-2015, 11:03 AM   #2
ozzmodan
Scooby Newbie
 
Member#: 357082
Join Date: May 2013
Default

Did you ever figure this out?

I am hoping to do the same swap with my '04 TS & want to make sure it'll work before I get too far.
ozzmodan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:51 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.