Welcome to the North American Subaru Impreza Owners Club Tuesday November 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-08-2013, 10:38 AM   #1
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default Id1000s and tic tgvs not fitting ?

So my problem is my id1000s aren't fitting into the tic tgvs

Is it supposed to be really tight ?


* Registered users of the site do not see these ads.

Last edited by gtasti; 03-08-2013 at 12:25 PM.
gtasti is offline   Reply With Quote
Old 03-08-2013, 10:49 AM   #2
mccanixx
Scooby Specialist
 
Member#: 60566
Join Date: Apr 2004
Chapter/Region: SCIC
Location: San Diego, Ca.
Vehicle:
2005 XT 5sp, 02 WRX
01 Legacy 95 Impreza L

Default

I have id1000's in tic tgvs. Fit like a glove, NO issue. Aeromotive rails but should be no different.

Mine are the metal manifold version.
mccanixx is offline   Reply With Quote
Old 03-08-2013, 11:13 AM   #3
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

I have the same tic tgvs is it possible the injectors are wrong then

I'm go check later at my buddy's shop to make sure I don't have the wrong injectors
gtasti is offline   Reply With Quote
Old 03-08-2013, 11:16 AM   #4
momoscoobiedoo
Scooby Specialist
 
Member#: 276198
Join Date: Mar 2011
Default

are you sure you have the gasket in the correct way because mine fit amazingly. i have boomba fuel rails and parallel lines only problem im having is all my godamn back fires and misfires. cause of everything else i did
momoscoobiedoo is offline   Reply With Quote
Old 03-08-2013, 11:28 AM   #5
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

Pretty sure the plug faces up no other way to put it in

I'll have to measure the whole and injectors supposed to be 14mm
gtasti is offline   Reply With Quote
Old 03-08-2013, 11:33 AM   #6
mccanixx
Scooby Specialist
 
Member#: 60566
Join Date: Apr 2004
Chapter/Region: SCIC
Location: San Diego, Ca.
Vehicle:
2005 XT 5sp, 02 WRX
01 Legacy 95 Impreza L

Default

It's hard to mess up gaskets when one is a symetrical donut and the other is an o-ring.
mccanixx is offline   Reply With Quote
Old 03-08-2013, 11:45 AM   #7
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

So I talked to the original owner he says I need to snip the small black piece at the bottom

Has anyone else had to do this ?
gtasti is offline   Reply With Quote
Old 03-08-2013, 12:12 PM   #8
mccanixx
Scooby Specialist
 
Member#: 60566
Join Date: Apr 2004
Chapter/Region: SCIC
Location: San Diego, Ca.
Vehicle:
2005 XT 5sp, 02 WRX
01 Legacy 95 Impreza L

Default

Quote:
Originally Posted by gtasti View Post
So I talked to the original owner he says I need to snip the small black piece at the bottom

Has anyone else had to do this ?
Nope. What small black piece? the injector, the gasket?

I've never had to do anything with them besides replace seals. Right from the factory tgvs to the composite.

I assume these are bosch topfeed id versions.
mccanixx is offline   Reply With Quote
Old 03-08-2013, 12:15 PM   #9
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

There's a black plastic piece holding the o rings on that is what's stopping it from going into the tgvs
gtasti is offline   Reply With Quote
Old 03-08-2013, 12:21 PM   #10
mccanixx
Scooby Specialist
 
Member#: 60566
Join Date: Apr 2004
Chapter/Region: SCIC
Location: San Diego, Ca.
Vehicle:
2005 XT 5sp, 02 WRX
01 Legacy 95 Impreza L

Default

Quote:
Originally Posted by gtasti View Post
There's a black plastic piece holding the o rings on that is what's stopping it from going into the tgvs
Hmmm. I had mine on factory rails before the aero's with no modification. News to me, but I bought the injectors brand new awhile ago. Sometimes it's a pain to get them both aligned? Idk

And the oring is on the rail side so it would prevent it from seating in the rail. If that's the scenario..
mccanixx is offline   Reply With Quote
Old 03-08-2013, 12:23 PM   #11
25rsti
Scooby Guru
 
Member#: 166324
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Haverhill, MA
Vehicle:
3 turbos &n NA
@DBlockSTi

Default

Post some pictures if you could. I would definitely hold off on cutting anything just yet.
25rsti is offline   Reply With Quote
Old 03-08-2013, 12:26 PM   #12
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

yeah i just did do you guys notice the black piece at the bottom i was told this has to be removed
gtasti is offline   Reply With Quote
Old 03-08-2013, 12:33 PM   #13
mccanixx
Scooby Specialist
 
Member#: 60566
Join Date: Apr 2004
Chapter/Region: SCIC
Location: San Diego, Ca.
Vehicle:
2005 XT 5sp, 02 WRX
01 Legacy 95 Impreza L

Default

Quote:
Originally Posted by gtasti View Post
yeah i just did do you guys notice the black piece at the bottom i was told this has to be removed
Measure. Don't think they sit that deep.
mccanixx is offline   Reply With Quote
Old 03-08-2013, 12:37 PM   #14
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

The o ring doesn't even go in that black piece stops em from seating
gtasti is offline   Reply With Quote
Old 03-08-2013, 12:45 PM   #15
mccanixx
Scooby Specialist
 
Member#: 60566
Join Date: Apr 2004
Chapter/Region: SCIC
Location: San Diego, Ca.
Vehicle:
2005 XT 5sp, 02 WRX
01 Legacy 95 Impreza L

Default



Unmodified. My lower seal is different however
mccanixx is offline   Reply With Quote
Old 03-08-2013, 12:46 PM   #16
the suicidal eggroll
Scooby Guru
 
Member#: 51961
Join Date: Jan 2004
Chapter/Region: RMIC
Location: Broomfield, CO
Vehicle:
2005 STi
2012 WRX

Default

Quote:

You do know they don't go in that direction, right? I hope you just took the picture with them oriented like that because it made the size restriction more apparent...
the suicidal eggroll is offline   Reply With Quote
Old 03-08-2013, 01:01 PM   #17
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

Your really asking that lol
Yes I no that's wrong way but the other way u won't see anything

Mcc do u got a pic of the injectors before u installed ?
gtasti is offline   Reply With Quote
Old 03-08-2013, 01:04 PM   #18
the suicidal eggroll
Scooby Guru
 
Member#: 51961
Join Date: Jan 2004
Chapter/Region: RMIC
Location: Broomfield, CO
Vehicle:
2005 STi
2012 WRX

Default

Quote:
Originally Posted by gtasti View Post
Your really asking that lol
Just making sure. We get a lot of idiots on this site, sometimes the dumb questions have to be asked.
the suicidal eggroll is offline   Reply With Quote
Old 03-08-2013, 01:10 PM   #19
Concillian
Scooby Guru
 
Member#: 4414
Join Date: Feb 2001
Location: Dublin, CA
Vehicle:
2002 WRX Sedan
Midnight Black

Default

That ID1000 looks nothing like mine.

Mine don't have the black "shelf" and 2 o-rings, they have no shelf and a very thick o-ring in all dimensions that slips on the end just like the stock ones. (looks like this http://www.t1racedevelopment.com/ind...o-cushion.html )

Are you sure you have top feed ID1000s and not the ones that were made for the T1 Race Development sidefeed --> top-feed conversion kit? The ones for the top feed conversion kit don't fit normal top-feed TGVs. You can see in this picture that there's WAY more clearance around the injector on the side-feed TGVs: http://www.titanmotorsports.com/t1sutopfefur.html

I think you have the wrong injector.

Last edited by Concillian; 03-08-2013 at 01:20 PM.
Concillian is offline   Reply With Quote
Old 03-08-2013, 01:10 PM   #20
mccanixx
Scooby Specialist
 
Member#: 60566
Join Date: Apr 2004
Chapter/Region: SCIC
Location: San Diego, Ca.
Vehicle:
2005 XT 5sp, 02 WRX
01 Legacy 95 Impreza L

Default

Quote:
Originally Posted by gtasti View Post
Mcc do u got a pic of the injectors before u installed ?
Nope. But in my pic you can see your smallest tab at 9 oclock.
mccanixx is offline   Reply With Quote
Old 03-08-2013, 01:13 PM   #21
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

Quote:
Originally Posted by the suicidal eggroll View Post
Just making sure. We get a lot of idiots on this site, sometimes the dumb questions have to be asked.
No worrys lol

Quote:
Originally Posted by Concillian View Post
That ID1000 looks nothing like mine.

Mine don't have the black "shelf" and 2 o-rings, they have no shelf and a very thick o-ring in all dimensions that slips on the end just like the stock ones. (looks like this http://www.t1racedevelopment.com/ind...o-cushion.html )

Are you sure you have top feed ID1000s and not the ones that were made for the T1 Race Development sidefeed --> top-feed conversion kit? The ones for the top feed conversion kit don't fit normal top-feed TGVs.
I got them from a member on here so they can possible be the ones for the conversion setup then fml

Quote:
Originally Posted by mccanixx View Post
Nope. But in my pic you can see your smallest tab at 9 oclock.
Ok thanks
gtasti is offline   Reply With Quote
Old 03-08-2013, 01:27 PM   #22
Concillian
Scooby Guru
 
Member#: 4414
Join Date: Feb 2001
Location: Dublin, CA
Vehicle:
2002 WRX Sedan
Midnight Black

Default

Quote:
Originally Posted by gtasti View Post
I got them from a member on here so they can possible be the ones for the conversion setup then fml
If this is the case you can try to send them back since he probably advertised them as normal top feeds. He may not have known that these were not just regular top feeds.

Or you can call T1 Race Development and explain that someone managed to dupe you into buying them and see if they have any advice for modifying them to fit... You NEED a good seal there or you'll get a boost leak through the injector mount hole. It should seal well on bottom and sides.

This is what they should look like:
http://forums.nasioc.com/forums/show....php?t=2165382

Last edited by Concillian; 03-08-2013 at 01:34 PM.
Concillian is offline   Reply With Quote
Old 03-08-2013, 03:47 PM   #23
gtasti
Scooby Specialist
 
Member#: 152036
Join Date: Jun 2007
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2004 Sti
PSM

Default

yeah thats exactly what happen i tried to save a few bucks and in the end i got ****ed

so i went to my buddys shops and here are the 2 side by side u can see mine are totally different
the top bottle necks up which doesnt allow for them to sit proper into the rails as well



gtasti is offline   Reply With Quote
Old 03-08-2013, 04:15 PM   #24
juanmedina
Scooby Guru
 
Member#: 133146
Join Date: Nov 2006
Location: SC
Vehicle:
07 FPgreen 7.37@95
WRX VF39+E85 12.0, 121mph

Default

I have 1200cc injectors for sale if interested. They are amazing...
juanmedina is online now   Reply With Quote
Old 03-08-2013, 04:18 PM   #25
STIBungy
Scooby Specialist
 
Member#: 51684
Join Date: Jan 2004
Location: CO
Default

You had to be "that guy".

This is a tech thread.

Quote:
Originally Posted by juanmedina View Post
I have 1200cc injectors for sale if interested. They are amazing...
STIBungy is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.