Welcome to the North American Subaru Impreza Owners Club Sunday March 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-10-2013, 05:01 PM   #1
HonduHunter
Scooby Guru
 
Member#: 28408
Join Date: Oct 2002
Chapter/Region: TXIC
Location: San Antonio, Tx
Vehicle:
2002 vf48ed WRX
PSM

Default Ida x305

This thing had worked for years.

A month ago I added some music to my ipod and now it doesn't read from the head unit anymore.


It charges still but doesn't play. Just says usb device error.

I've replaced the cable from ipod to the head unit but nothing has changed.

Google comes up with not much.

Does nasioc have any ideas?
* Registered users of the site do not see these ads.
HonduHunter is offline   Reply With Quote
Old 11-10-2013, 06:15 PM   #2
802-303
Scooby Newbie
 
Member#: 283194
Join Date: May 2011
Chapter/Region: RMIC
Location: Colorado
Default

Try a USB thumb drive. If the radio recognizes the thumb drive, the its a software issue on the iPod. If you still get a USB error with the thumb drive, reset the radio. I have an alpine 117 (same generation USB driver) I had similar issues with mine.
802-303 is offline   Reply With Quote
Old 11-11-2013, 12:54 PM   #3
MBelair79
Scooby Newbie
 
Member#: 363805
Join Date: Jul 2013
Chapter/Region: SCIC
Location: Irvine, CA
Vehicle:
2015 WRX Limited
Crystal White Pearl

Default

Also, the iPod cable is specific to the that radio. You can't try another iPod cable unless it is from another 305 radio.
MBelair79 is offline   Reply With Quote
Old 11-11-2013, 05:48 PM   #4
HonduHunter
Scooby Guru
 
Member#: 28408
Join Date: Oct 2002
Chapter/Region: TXIC
Location: San Antonio, Tx
Vehicle:
2002 vf48ed WRX
PSM

Default

Let me try the thumb drive. Ive tried different ipods with no luck.


Quote:
Originally Posted by MBelair79 View Post
Also, the iPod cable is specific to the that radio. You can't try another iPod cable unless it is from another 305 radio.
I replaced it with a new cable of the same part number so that shouldnt be it.
HonduHunter is offline   Reply With Quote
Old 11-11-2013, 07:01 PM   #5
802-303
Scooby Newbie
 
Member#: 283194
Join Date: May 2011
Chapter/Region: RMIC
Location: Colorado
Default

Quote:
Originally Posted by MBelair79 View Post
Also, the iPod cable is specific to the that radio. You can't try another iPod cable unless it is from another 305 radio.
That is wrong. The 305 ran a standard USB cable. (Male to female) You then plugged in the 4 inch usb to iPod cable. You also had the option to spend 30.00 for the iPod AI cable. (Probably the proprietary cable mentioned above. But was fazed out after Alpine added USB to all radios)
802-303 is offline   Reply With Quote
Old 11-11-2013, 07:09 PM   #6
802-303
Scooby Newbie
 
Member#: 283194
Join Date: May 2011
Chapter/Region: RMIC
Location: Colorado
Default

And HonduHunter, if your running the AI iPod cable. Switch to the USB. You'll see quicker response, and less glitches. Unfortunately the newer iPod software isn't playing fair with older headunits. I went with USB thumb drives in my own car. Less damage to your iPod, and cheap to replace.
802-303 is offline   Reply With Quote
Old 11-17-2013, 08:07 AM   #7
HonduHunter
Scooby Guru
 
Member#: 28408
Join Date: Oct 2002
Chapter/Region: TXIC
Location: San Antonio, Tx
Vehicle:
2002 vf48ed WRX
PSM

Default

Ok...

I tried a usb. Still no go. I even took the hard unit out and plugged the usb directly into the head unit and nothing.

Is it time to look for a new head unit?
HonduHunter is offline   Reply With Quote
Old 11-17-2013, 04:24 PM   #8
802-303
Scooby Newbie
 
Member#: 283194
Join Date: May 2011
Chapter/Region: RMIC
Location: Colorado
Default

According to Alpine's website if the display reads USB device error it's caused by an unsupported device. In your situation it my of been caused by updating your iPod. Your best bet is to take a USB drive, reformat it (deletes everything), and put a handful of songs on it that you know worked. If this doesn't work, maybe an old generation iPod. I know your radio recognizes the USB, since it charges and shows device error. When the USB drive fails it shows a "no USB error"... Also reset the radio (button behind the faceplate) while the USB is connected.
802-303 is offline   Reply With Quote
Old 11-19-2013, 09:53 AM   #9
HonduHunter
Scooby Guru
 
Member#: 28408
Join Date: Oct 2002
Chapter/Region: TXIC
Location: San Antonio, Tx
Vehicle:
2002 vf48ed WRX
PSM

Default

It's an old ipod. 80gig classic. I don't think apple updated it's software recently. I'll reformat my usb and see if that helps anything.

This situation makes me wish I would have gotten a model with a CD player. Lol.
HonduHunter is offline   Reply With Quote
Old 11-20-2013, 11:22 AM   #10
HonduHunter
Scooby Guru
 
Member#: 28408
Join Date: Oct 2002
Chapter/Region: TXIC
Location: San Antonio, Tx
Vehicle:
2002 vf48ed WRX
PSM

Default

Reformatted a usb, downloaded a background from the alpine website. No go.

Reset the heady it no go. The usb light comes on but the head unit reads "no usb device".

I'm real close to just taking this thing apart.

(Read: buying another head unit)
HonduHunter is offline   Reply With Quote
Old 11-30-2013, 04:28 AM   #11
HonduHunter
Scooby Guru
 
Member#: 28408
Join Date: Oct 2002
Chapter/Region: TXIC
Location: San Antonio, Tx
Vehicle:
2002 vf48ed WRX
PSM

Default

Bought an Aux cable. It works. But still no luck with an ipod/usb.
HonduHunter is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:50 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.