Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-13-2013, 01:07 PM   #1
worstcase
Scooby Newbie
 
Member#: 338340
Join Date: Nov 2012
Location: Olympia, WA
Default '05 Outback, ABS then AWD then engine dies.

Driving on I5, cruise cancels and I see a blip of amber but don't catch the code (cruise also blinked at me for a bit as I set out, stopped after gassing up). A minute later cruise cancels again, shows ABS light, followed 20 sec later by AWD. Engine dies as I start changing lanes to get to shoulder, power steering and brakes work well enough to stop. Turned off the car, gave it a minute then tried to restart, it did but AWD and ABS still showing so I shut down. Now will not restart, doing the dead battery flicker but I'm thinking its probably not that simple.

Time for AAA, anyone have ideas on cause, things to check? I'm thinking alternator/battery/electrical but what do I know? Help appreciated.
* Registered users of the site do not see these ads.
worstcase is offline   Reply With Quote
Old 03-13-2013, 01:13 PM   #2
dstroy
Scooby Specialist
 
Member#: 283711
Join Date: May 2011
Chapter/Region: NESIC
Location: Newport
Vehicle:
2012 STI sedan
Black with scratches

Default

Is it still cranking over like it wants to start?
dstroy is offline   Reply With Quote
Old 03-13-2013, 02:08 PM   #3
worstcase
Scooby Newbie
 
Member#: 338340
Join Date: Nov 2012
Location: Olympia, WA
Default

It tried at first, now dash lights up but the starter/engine is not turning over.
worstcase is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:15 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.