Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-15-2013, 04:13 PM   #1
Miggs11c
Scooby Newbie
 
Member#: 350147
Join Date: Mar 2013
Chapter/Region: TXIC
Location: Ft.hood, Texas
Vehicle:
2003 Impreza wrx
Platinum

Default 03 wrxnHigh beam won't turn on.

So my 03 wrx high beam and side marker lights on my passenger side won't turn on. I looked under the hood and found a white plug with green and black wires attached to it. On the drivers side I can't see where it's attached to. But it's a plug that has wires connected it to with the turn signal plug. I'm sorry if I'm using the wrong terms I just really need some help.
* Registered users of the site do not see these ads.
Miggs11c is offline   Reply With Quote
Old 03-15-2013, 04:27 PM   #2
Miggs11c
Scooby Newbie
 
Member#: 350147
Join Date: Mar 2013
Chapter/Region: TXIC
Location: Ft.hood, Texas
Vehicle:
2003 Impreza wrx
Platinum

Default

Miggs11c is offline   Reply With Quote
Old 03-15-2013, 04:27 PM   #3
Miggs11c
Scooby Newbie
 
Member#: 350147
Join Date: Mar 2013
Chapter/Region: TXIC
Location: Ft.hood, Texas
Vehicle:
2003 Impreza wrx
Platinum

Default

Miggs11c is offline   Reply With Quote
Old 03-15-2013, 04:28 PM   #4
Miggs11c
Scooby Newbie
 
Member#: 350147
Join Date: Mar 2013
Chapter/Region: TXIC
Location: Ft.hood, Texas
Vehicle:
2003 Impreza wrx
Platinum

Default

That's the wire... I need some help...
Miggs11c is offline   Reply With Quote
Old 03-15-2013, 04:43 PM   #5
satrya
Scooby Specialist
 
Member#: 5887
Join Date: Apr 2001
Chapter/Region: BAIC
Location: Fremont, CA USA
Vehicle:
2002 GDAA
797

Default

Are you sure that's a bulb socket for the sidemarkers (i.e. the orange trapezoid on the front fenders)? It looks more like the parking/city light that goes to the main headlight cluster. The socket itself is not visible unless you take the headlight out.

The high beams not working probably has nothing to do with that. Also check the fuse box inside, below the steering column, to the left where the coin tray is.
satrya is offline   Reply With Quote
Old 03-15-2013, 05:17 PM   #6
Miggs11c
Scooby Newbie
 
Member#: 350147
Join Date: Mar 2013
Chapter/Region: TXIC
Location: Ft.hood, Texas
Vehicle:
2003 Impreza wrx
Platinum

Default

Where's the fuse box? Can't seem to locate it.
Miggs11c is offline   Reply With Quote
Old 03-16-2013, 12:02 AM   #7
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

The Main Fuse panel under the hood has a flat rectangular cover over it and should be about a foot away from the battery. There is a dash fuse panel also.
Cougar4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:15 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.