Welcome to the North American Subaru Impreza Owners Club Sunday May 24, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-16-2013, 08:48 PM   #1
Bpatts
Scooby Newbie
 
Member#: 288358
Join Date: Jul 2011
Chapter/Region: MWSOC
Location: Michigan and NY
Vehicle:
2005 Wrx Sedan
Silver

Default I phone 5 compatible headunits?

Does anybody know if any company has released an Iphone 5 compatible headunit?

And if yes, has anybody used them? Thanks in advance
* Registered users of the site do not see these ads.
Bpatts is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-17-2013, 01:40 AM   #2
sizemic1
Scooby Newbie
 
Member#: 270669
Join Date: Jan 2011
Chapter/Region: SCIC
Location: Temecula, CA
Vehicle:
2011 WRX Sedan
Stg 2 Phatbotti e-tuned

Default

Quote:
Originally Posted by Bpatts View Post
Does anybody know if any company has released an Iphone 5 compatible headunit?

And if yes, has anybody used them? Thanks in advance
Pioneer has some.
sizemic1 is offline   Reply With Quote
Old 03-17-2013, 02:09 PM   #3
2lo4dsno
Scooby Newbie
 
Member#: 348485
Join Date: Feb 2013
Location: Rochester NY
Vehicle:
2011 Wrx
Satin white pearl

Default

All of the pioneer "iPhone compatible" HU's should be 100% iphone5 by the end of the month, along with the new Alpine units. Sony and JVC will follow shortly after.
2lo4dsno is offline   Reply With Quote
Old 03-17-2013, 05:23 PM   #4
Angelus911
Scooby Specialist
 
Member#: 89967
Join Date: Jun 2005
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sport
DGM

Default

Quote:
Originally Posted by 2lo4dsno View Post
All of the pioneer "iPhone compatible" HU's should be 100% iphone5 by the end of the month, along with the new Alpine units. Sony and JVC will follow shortly after.
If you get their advanced DVD receivers (pioneer), the you'll have to shell out $100 for an adapter from them. If you want an advanced DVD receiver, stay away from pioneer if you have an i5
Angelus911 is offline   Reply With Quote
Old 03-17-2013, 06:45 PM   #5
2lo4dsno
Scooby Newbie
 
Member#: 348485
Join Date: Feb 2013
Location: Rochester NY
Vehicle:
2011 Wrx
Satin white pearl

Default

I'm the manager of a car audio/accessory shop in NY, so no worries.
2lo4dsno is offline   Reply With Quote
Old 03-21-2013, 05:20 PM   #6
Bpatts
Scooby Newbie
 
Member#: 288358
Join Date: Jul 2011
Chapter/Region: MWSOC
Location: Michigan and NY
Vehicle:
2005 Wrx Sedan
Silver

Default

Quote:
Originally Posted by 2lo4dsno View Post
All of the pioneer "iPhone compatible" HU's should be 100% iphone5 by the end of the month, along with the new Alpine units. Sony and JVC will follow shortly after.
When you say compatible, are any extra cables/software updates required to make them fully compatible?
Bpatts is offline   Reply With Quote
Old 03-24-2013, 10:53 AM   #7
2lo4dsno
Scooby Newbie
 
Member#: 348485
Join Date: Feb 2013
Location: Rochester NY
Vehicle:
2011 Wrx
Satin white pearl

Default

Yes. Different cables for different head units.
2lo4dsno is offline   Reply With Quote
Old 03-25-2013, 11:04 AM   #8
JLD13
Scooby Newbie
 
Member#: 330696
Join Date: Aug 2012
Chapter/Region: NWIC
Location: Seattle
Vehicle:
05 Saabaru V7ej207

Default

I have the Kenwood KIV-BT901, using Apple's adaptor, Pandora and iPod music work. Videos and music through Bluetooth do not work.
JLD13 is offline   Reply With Quote
Old 03-25-2013, 11:32 AM   #9
Ryan321
Scooby Newbie
 
Member#: 225014
Join Date: Sep 2009
Chapter/Region: NESIC
Vehicle:
2005 Impreza WRX STI
Black

Default

I know my AVIC z120bt works with blue tooth with any phone. No need to plug it in. My 4s works as an iPod so I presume that the 5 would work. You can check their web site. They have great head units. I will never use another radio beside a pioneer double din AVIC series.
Ryan321 is offline   Reply With Quote
Old 03-25-2013, 11:40 AM   #10
Ryan321
Scooby Newbie
 
Member#: 225014
Join Date: Sep 2009
Chapter/Region: NESIC
Vehicle:
2005 Impreza WRX STI
Black

Default







Just some pics. Great unit =]
Ryan321 is offline   Reply With Quote
Old 03-25-2013, 07:24 PM   #11
freddyo_0
Scooby Newbie
 
Member#: 339277
Join Date: Nov 2012
Vehicle:
2011 WRX STI Limited
SWP

Default

Quote:
Originally Posted by Bpatts View Post

When you say compatible, are any extra cables/software updates required to make them fully compatible?
Firmware update for older HU's, up to $120 for a pioneer cable, a VGA to lightning adapter ($49) and a spare lightning cable.
freddyo_0 is offline   Reply With Quote
Old 03-25-2013, 09:20 PM   #12
Dmochowski
Scooby Specialist
 
Member#: 306478
Join Date: Jan 2012
Chapter/Region: South East
Location: chattanooga, TN
Vehicle:
2012 WRX limited
305whp/360tq TSM tuned

Default

glad i got rid of my iphone for a new droid.... now my phone actually connects with Bluetooth.
Dmochowski is online now   Reply With Quote
Old 03-26-2013, 08:28 PM   #13
Ryan321
Scooby Newbie
 
Member#: 225014
Join Date: Sep 2009
Chapter/Region: NESIC
Vehicle:
2005 Impreza WRX STI
Black

Default

Quote:
Originally Posted by Dmochowski View Post
glad i got rid of my iphone for a new droid.... now my phone actually connects with Bluetooth.
Really? What head unit did you have.
Ryan321 is offline   Reply With Quote
Old 03-26-2013, 09:12 PM   #14
Dmochowski
Scooby Specialist
 
Member#: 306478
Join Date: Jan 2012
Chapter/Region: South East
Location: chattanooga, TN
Vehicle:
2012 WRX limited
305whp/360tq TSM tuned

Default

Haha the oem unit. It worked for a while when I first got the car. Then after the update to the ios of the iPhone 5 it stopped syncing. Would work until I turned the cat off then have to resync. Got a droid DNA and works everytine now.
Dmochowski is online now   Reply With Quote
Old 03-26-2013, 09:33 PM   #15
Ryan321
Scooby Newbie
 
Member#: 225014
Join Date: Sep 2009
Chapter/Region: NESIC
Vehicle:
2005 Impreza WRX STI
Black

Default

Quote:
Originally Posted by Dmochowski View Post
Haha the oem unit. It worked for a while when I first got the car. Then after the update to the ios of the iPhone 5 it stopped syncing. Would work until I turned the cat off then have to resync. Got a droid DNA and works everytine now.
Oh gotcha. I assumed It was aftermarket. I didn't know what the newer Subarus had for head units. The 04-06 had terrible units haha it ate my techno cd, only one I had. ( yeah techno may not be most people choose for music)
Ryan321 is offline   Reply With Quote
Old 03-27-2013, 08:29 AM   #16
dr spaceman
Scooby Newbie
 
Member#: 321817
Join Date: May 2012
Default

Quote:
Originally Posted by Dmochowski View Post
Haha the oem unit. It worked for a while when I first got the car. Then after the update to the ios of the iPhone 5 it stopped syncing. Would work until I turned the cat off then have to resync. Got a droid DNA and works everytine now.
I have a 2012 Impreza with the non nav HU. If you have something similar, I think I know actual problem you were encountering, and I believe it is unrelated to the type of phone.

There are 2 separate sections of bluetooth pairing, the audio player pairing, which you access through the knobs and screen where the interface is red, and the cell phone pairing, which i think you can only access through the steering wheel controls and shows a blue interface. Phones are of course both a phone and an audio player.

When you updated your phone, i suppose the software on it changed significantly enough that the head unit did not think it was the same device, but at the same time did think it was the same device because the name would be identical ("Dmochowski's iPhone" or some such thing). You need to unpair from both the audio player link AND the cell phone link, and then repair through the cell phone link.

Getting a brand new, totally different phone, regardless of make or model, didn't confuse the head unit like the same phone with an update did.

I know this because I had a similar problem. I tried to unpair and repair a few times through only the audio interface to no avail, then it worked when I unpaired and repaired through the phone interface
dr spaceman is offline   Reply With Quote
Old 03-27-2013, 09:25 AM   #17
Dmochowski
Scooby Specialist
 
Member#: 306478
Join Date: Jan 2012
Chapter/Region: South East
Location: chattanooga, TN
Vehicle:
2012 WRX limited
305whp/360tq TSM tuned

Default

Yeah that could have been the issue I wad only pairing through the steering wheel buttons. I started a thread about it but only got "its a software update issue with the phone." For an answer.
Dmochowski is online now   Reply With Quote
Old 04-01-2013, 12:43 PM   #18
Ryan321
Scooby Newbie
 
Member#: 225014
Join Date: Sep 2009
Chapter/Region: NESIC
Vehicle:
2005 Impreza WRX STI
Black

Default

Quote:
Originally Posted by Dmochowski View Post
Yeah that could have been the issue I wad only pairing through the steering wheel buttons. I started a thread about it but only got "its a software update issue with the phone." For an answer.
Yeah that's a typical answer for this forum. Not many helpful or willing people on here.
Ryan321 is offline   Reply With Quote
Old 05-16-2013, 11:07 AM   #19
Ballindre
Scooby Newbie
 
Member#: 309540
Join Date: Feb 2012
Chapter/Region: SCIC
Vehicle:
2012 WRX STI
WRB

Default

Quote:
Originally Posted by dr spaceman View Post

I have a 2012 Impreza with the non nav HU. If you have something similar, I think I know actual problem you were encountering, and I believe it is unrelated to the type of phone.

There are 2 separate sections of bluetooth pairing, the audio player pairing, which you access through the knobs and screen where the interface is red, and the cell phone pairing, which i think you can only access through the steering wheel controls and shows a blue interface. Phones are of course both a phone and an audio player.

When you updated your phone, i suppose the software on it changed significantly enough that the head unit did not think it was the same device, but at the same time did think it was the same device because the name would be identical ("Dmochowski's iPhone" or some such thing). You need to unpair from both the audio player link AND the cell phone link, and then repair through the cell phone link.

Getting a brand new, totally different phone, regardless of make or model, didn't confuse the head unit like the same phone with an update did.

I know this because I had a similar problem. I tried to unpair and repair a few times through only the audio interface to no avail, then it worked when I unpaired and repaired through the phone interface
I kept doing the same thing unpairing and pairing on the unit. Once I did it on the steering wheel, it worked fine. My phone connects automatically now. I went from a 4 to a 5 btw.
Ballindre is offline   Reply With Quote
Old 05-16-2013, 11:20 AM   #20
luan87us
Scooby Specialist
 
Member#: 335013
Join Date: Oct 2012
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2013 Premium WRX 5dr
WRB

Default

I have the OEM Nav HU and my iphone 5 (iOS 6.1.2) works fine with it. Sync automatically everytime i turn on my car.
luan87us is offline   Reply With Quote
Old 05-18-2013, 10:08 PM   #21
likeawind
Scooby Newbie
 
Member#: 238303
Join Date: Feb 2010
Chapter/Region: W. Canada
Location: Calgary, Alberta
Vehicle:
2015 WRX
WRB

Default

I also have Z120BT and it works flawless with my iphone 5 BT, I love it.
likeawind is offline   Reply With Quote
Old 05-18-2013, 11:27 PM   #22
emazz104
Scooby Specialist
 
Member#: 281811
Join Date: May 2011
Chapter/Region: NESIC
Location: Vermont
Vehicle:
04 WRX
World Rally Blue

Default

Quote:
Originally Posted by Ryan321 View Post

Just some pics. Great unit =]
Old post, but is that an AVH-P4300DVD? If so I have it and really like it. It worked with my iPhone 4 and now works with my iPhone 5.
emazz104 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.