Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-21-2014, 08:16 PM   #1
msdss
Scooby Newbie
 
Member#: 117347
Join Date: Jun 2006
Chapter/Region: TXIC
Vehicle:
2002 WRX
Silver

Default Help with CEL P0128

The car is an 02 WRX and I would appreciate some advice on how to trouble shoot CEL P0128. My car was perfectly fine, then about half way to work I threw the code. I've read a few service pdfs and have checked a few things but I'm not sure where to go from here. It is just the one code, there are no others.

I've checked the levels of coolant in the radiator, it was topped off.

I read to check how long the radiator fans run when idling and it was under a minute (it said to check for 3 minutes or higher)

The temp gauge in the gauge cluster reads below the mid mark.

At this point I'm not sure what else I can check. It if I should even drive the car.

I would really appreciate some suggestions on things I could check before I take it to a shop. Ideally I would like to just fix it myself if it isn't too complicated.

Sent from my SAMSUNG-SGH-I337 using NASIOC mobile app
* Registered users of the site do not see these ads.
msdss is offline   Reply With Quote
Old 07-21-2014, 10:33 PM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Uncle Scotty is offline   Reply With Quote
Old 07-22-2014, 09:24 AM   #3
msdss
Scooby Newbie
 
Member#: 117347
Join Date: Jun 2006
Chapter/Region: TXIC
Vehicle:
2002 WRX
Silver

Default

Helpful as always. There should just be an auto reply system that says "never try to have a conversation, search through 12 years of forum posts instead"

Sent from my SAMSUNG-SGH-I337 using NASIOC mobile app
msdss is offline   Reply With Quote
Old 07-23-2014, 01:56 AM   #4
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

d000000000000d...there are a finite number of causes for this cel to be set and a logic tree associated with solving the issue is pretty clear and concise

if you do not have the factory service manual you can google

impreza manuals

and the top hit will yield the results you desire.....
Uncle Scotty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:04 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.