Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-09-2013, 03:58 AM   #51
sam_rigger
Scooby Newbie
 
Member#: 355800
Join Date: May 2013
Chapter/Region: International
Location: Melbourne, Australia
Vehicle:
2012 Impreza WRX
Silver

Default

Has anyone been able to contact SVXdc? I've tried emailing many times, and no response? Is he on holidays or something?
* Registered users of the site do not see these ads.
sam_rigger is offline   Reply With Quote
Old 07-09-2013, 10:14 AM   #52
luan87us
Scooby Specialist
 
Member#: 335013
Join Date: Oct 2012
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2013 Premium WRX 5dr
WRB

Default

Just wait for him. He get many emails asking for help on audio install each day so it'll take him a bit of time to get back with everyone. He'll give you all the info you need to get your HU working properly.

I sent you a link in your PM about the USB + Media hub thing with the Kenwood Nav unit.
luan87us is offline   Reply With Quote
Old 07-09-2013, 10:19 AM   #53
sam_rigger
Scooby Newbie
 
Member#: 355800
Join Date: May 2013
Chapter/Region: International
Location: Melbourne, Australia
Vehicle:
2012 Impreza WRX
Silver

Default

Thanks mate. I didny get a link tho, just two identical pms with no link.
sam_rigger is offline   Reply With Quote
Old 07-10-2013, 06:45 AM   #54
sam_rigger
Scooby Newbie
 
Member#: 355800
Join Date: May 2013
Chapter/Region: International
Location: Melbourne, Australia
Vehicle:
2012 Impreza WRX
Silver

Default

I did eventually get that link, thanks.

Due to the lack of any response at all from SVX.dc I have given up, and am selling the sat nav unit. Cannot be bothered stressing about it. I really just want the DVD part of it anyway.
sam_rigger is offline   Reply With Quote
Old 07-10-2013, 04:44 PM   #55
fastfive09
Scooby Specialist
 
Member#: 169597
Join Date: Jan 2008
Chapter/Region: South East
Location: Baton Rouge, LA
Vehicle:
2011 WRX Sedan
Silver

Default

picture links are broken. That happpened fast
fastfive09 is offline   Reply With Quote
Old 07-11-2013, 06:35 AM   #56
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by sam_rigger View Post
I have just bought the Kenwood HU Navi, and really want to keep the usb media hub so it works with the Kenwood HU. So it just worked once it was plugged in?

It interesting the Mic worked, everyone is telling me it won't work.
...
Luan's thread here is about Subaru's new satnav, made by Fujitsu Ten. That is completely different than the older model you found (made by Kenwood).

The OEM Kenwood satnav does not have built-in USB, and does not do Bluetooth for music audio streaming. The factory microphones in non-nav 2011-up models (including your 2012) are not compatible with the Kenwood. See this page for more information about transplanting the Kenwood nav into a non-nav Impreza or Forester.

And sorry I wasn't able to reply to your e-mails as quickly as you wanted. I don't have a staff of people to answer the numerous (and often lengthy and/or complicated) e-mails that I receive, so sometimes it takes a few days.

At some point, I'll put together a similar guide for transplanting the FT nav into a non-nav car.
SVXdc is offline   Reply With Quote
Old 07-11-2013, 06:48 AM   #57
sam_rigger
Scooby Newbie
 
Member#: 355800
Join Date: May 2013
Chapter/Region: International
Location: Melbourne, Australia
Vehicle:
2012 Impreza WRX
Silver

Default

Thanks for the email David, I actually should apologize. I was being a little over-the-top with that last post. I think I was just frustrated that what I bought wasn't going to work like I had planned. I appreciate you are a one man operation, and certainly well respected amongst many Forums.
I'm selling that kenwood unit, and may buy a DVD unit in the future, which I'll be in contact for if I need a harness.

THanks again for getting back to me, and for your help.

Cheers.






I
sam_rigger is offline   Reply With Quote
Old 07-11-2013, 08:39 AM   #58
luan87us
Scooby Specialist
 
Member#: 335013
Join Date: Oct 2012
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2013 Premium WRX 5dr
WRB

Default

Quote:
Originally Posted by fastfive09 View Post
picture links are broken. That happpened fast
lol sorry I took the pictures off my flickr account because I'm now using it for my photography portfolio. I'll try to upload them again at a different host.
luan87us is offline   Reply With Quote
Old 07-17-2013, 01:23 PM   #59
pkluong
Scooby Specialist
 
Member#: 341113
Join Date: Dec 2012
Chapter/Region: SCIC
Location: Huntington Beach, CA
Vehicle:
2013 WRX
Dark Grey Metallic

Default

So is this still a work in progress?
pkluong is offline   Reply With Quote
Old 07-30-2013, 05:00 PM   #60
luan87us
Scooby Specialist
 
Member#: 335013
Join Date: Oct 2012
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2013 Premium WRX 5dr
WRB

Default

Everything is finished. I got all the functions working properly. (well aside for the XM radio as I didn't want to buy the antenna). FYI You can play divx codec avi files through USB.
luan87us is offline   Reply With Quote
Old 07-30-2013, 05:22 PM   #61
dan2510
Scooby Newbie
 
Member#: 305615
Join Date: Jan 2012
Location: IL
Vehicle:
2013 WRX Limited Sdn
SWP

Default

I have a 2013 WRX and want to install the factory NAV...any suggestions? I cant even order the Nav through my local dealer they wont sell it to me! They are trying to force me to go aftermarket which I dont wont.
dan2510 is offline   Reply With Quote
Old 07-31-2013, 02:08 AM   #62
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Watch eBay.
SVXdc is offline   Reply With Quote
Old 07-31-2013, 08:35 AM   #63
luan87us
Scooby Specialist
 
Member#: 335013
Join Date: Oct 2012
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2013 Premium WRX 5dr
WRB

Default

Quote:
Originally Posted by dan2510 View Post
I have a 2013 WRX and want to install the factory NAV...any suggestions? I cant even order the Nav through my local dealer they wont sell it to me! They are trying to force me to go aftermarket which I dont wont.
Yeah I got my from Ebay. Also try watching the private for sale section here or the gt86 forum as I've seen a few for sale there before. This HU cost $1000+ from the dealer so I don't think it's a wise choice. I got a really good deal ($375 shipped) on the HU that's why I went with this. Aftermarket would probably be A LOT easier lol. The maps database on my HU is kinda outdated though Haven't found a way to load custom database like the Toyota navigation HUs.
luan87us is offline   Reply With Quote
Old 07-31-2013, 04:23 PM   #64
dan2510
Scooby Newbie
 
Member#: 305615
Join Date: Jan 2012
Location: IL
Vehicle:
2013 WRX Limited Sdn
SWP

Default

I guess I wouldnt mind going aftermarket...hows Kenwood HU? I believe they use Garmin maps. Ultimately, I want to keep the functionality of my steering wheel buttons...also, will I need a new mic for BT?
dan2510 is offline   Reply With Quote
Old 08-01-2013, 08:07 AM   #65
luan87us
Scooby Specialist
 
Member#: 335013
Join Date: Oct 2012
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2013 Premium WRX 5dr
WRB

Default

Quote:
Originally Posted by dan2510 View Post
I guess I wouldnt mind going aftermarket...hows Kenwood HU? I believe they use Garmin maps. Ultimately, I want to keep the functionality of my steering wheel buttons...also, will I need a new mic for BT?
I'm not expert on car audio so you'll have to research it from other people with the HU you're interested in. SWC can be kept through the use of Axxess ASWC adapter or similar adapters. Usually when you buy an aftermarket HU you'll need a new mic but most of them should come with one or sold separate as an add-on.
luan87us is offline   Reply With Quote
Old 08-16-2013, 12:26 AM   #66
wrexed1
Scooby Newbie
 
Member#: 320175
Join Date: May 2012
Location: Manalapan, NJ
Vehicle:
2013 WRX Premium
Silver

Default 13 WRX nav swap completed

So I bought my 13 premium sedan 4 days after the special order cut-off. It had everything I wanted but nav. I wanted OEM, so I decided to roll the dice and attempt the transplant. Thanks to this thread, and David's guidance and harnesses (thank you again!!), and a fully functional ebay Fujitsu Ten HU out of a 12' (pd $300- Subaru quoted me 2k), the installation was very straight forward. As this thread/ discussion enabled me to perform the install, I've tried to document everything in a useable format to hopefully fill in any gaps for any of you looking to do this, as a thank you to the community and the service it provided to me.

Below are all of the parts you'll need for the the installation, and a general how-to. And for those of you who want to use satellite radio and don't want to rip down your headliner to replace your oem antenna/ wiring (if you have a 13, your antenna does not have an xm receiver built in, nor is it pre-wired), I included the adapters you'll need in order to run any aftermarket xm antenna into the HU.

Just an FYI, the interface on the Fujitsu Ten is great, and the sound quality is much improved. The FM reception, even with the HD radio is still laughable, but I feel like that's a Subaru hallmark. My only gripe is the BT speaker phone. The only time anyone can make out what I'm saying is parked with the engine off (and yes, I have my mic volume max'd). Other than that, all steering wheel controls and functions work as-stock. All console mounted inputs (aux and USB) function correctly.

__________
Purchased from David(SVXdc):

(1) 10+6-pin reverse harness (w/ illum.-)
(1) 20-pin forward harness (w/ illum.- & long 3 SWC)
(1) 28-pin harness assembly (w/ VSS, r.gear, SWC, 16-pin>aux/mic)
(1) 16-pin rear camera harn. (w/ p.brake bypass, 6V, Impreza loop)
(1) Subaru USB cable (to male USB A)

Purchased Separately:

(1) GPS Antenna ($12) http://www.ebay.com/itm/231020270302...84.m1439.l2649
(1) FM Antenna Adapter ($13) http://www.ebay.com/itm/400494961719...84.m1439.l2649
(1) Lexus reverse USB adapter ($10) http://www.ebay.com/itm/190850462942...84.m1439.l2649
(1) OEM Subaru Nav Bezel ($72) This really isn't necessary.. Other than the corners being rounded(vs square), and the HU sitting a bit more flush (vs recessed using standard bezel) normal human beings really wouldn't be able to recognize any discernible difference. I'm advising to save your cash on this one(see pics below).

stock bezel

http://i.imgur.com/bBLCMmS.jpg
(click to see image)

nav bezel
http://i.imgur.com/SPYjyXN.jpg
(click to see image)


Camera

(1) Sony CCD Camera ($21) http://www.ebay.com/itm/251260310863...84.m1439.l2649 And yes, it may be silly cheap but it works great. It's a 520p CCD with really good day and night resolution.

Satellite Radio

(1) XM antenna adapter ($9) http://www.ebay.com/itm/150617057429...84.m1439.l2649
(1) GPS Antenna ($12) http://www.ebay.com/itm/231020270302...84.m1439.l2649
__________

The XM was the biggest PITA for me. The proprietary square plug was impossible to adapt, but the GPS antenna's plug is remarkably close (with a tiny bit of dremel magic). So essentially, I purchased 2 of the same GPS antennas listed above, using 1 for the GPS obv. and the other to splice into the "XM antenna adapter," essentially creating a patch cord go-between to be used to mate any aftermarket XM antenna to this HU.


Here's the kit of parts after soldering and heat shrinking David's harnesses (minus the USB wiring which I received after taking this, and the XM patch cord). Note, the spool on the right.. red is to VSS, black is to reverse gear. David supplies you with color decoders and instructions for his harnesses as well, so there's no guess work involved. The nav unit I purchased didn't have the mounting brackets but the stock HU's swapped directly over.

http://i.imgur.com/1X8WCtOhm.jpg[/img]
(click to see image)

I used 3m tape to affix the GPS ant to the top of the cluster, beneath the hood. Reception is perfect. FYI, the wrx dash pops apart easier than my childhood Camaro's. The hood is held on by 4 clips and pulls straight off, and the radio bezel with another 5 plastic clips, so don't get intimidated. I pulled the cluster out (2 screws..I know..) to route the GPS antenna wiring to the back of the HU. I also pulled the hvac duct in the stack to free some space so I had room to organize the myriad of HU harnesses(2 screws).

http://i.imgur.com/bENFxQn.jpg
(click to see image)

http://i.imgur.com/skTwSvkhm.jpg[/img]
(click to see image)

You'll need to tap 0-3 wires from the vehicle harness depending on what you plan on installing. An easy access point for the VSS is through the harness under the glove box. It's pink/green. I connected it at first but found it to be utterly useless and quite the nuisance so wound up disconnecting. The reverse gear wire can be accessed through the harness above the passenger side kick panel, if you're connecting a reverse cam. It's brown and yellow. You'll also need a 12v switched power lead, which will connect to the cam +. I tapped into the switched 12+ from the clock harness *see emboldened revision/note below. This one is brown/white. If you're not doing a cam, and don't mind the GPS getting confused in tunnels, you don't have to hack into anything.

http://i.imgur.com/PwxJPld.jpg[/IMG]
(click to see image)

http://i.imgur.com/X3kPi84.jpg
(click to see image)

http://i.imgur.com/7Atq2vb.jpg
(click to see image)

I mounted the cam in center of the trunk garnish. The honkin connectors hard wired to the cam itself were able to fit through the stock hole in the trunk (where the plate light wires exit). Just shoved the grommet through, pushed the cam wiring through next to it, and pulled the grommet back out to it's original position. This HU has to sense a cam within 5 sec of boot up or the cam function will be overridden, which means the camera needs to be wired to the switched-on as mentioned(clock). Correction: the camera harness David supplied has a red wire. This can be used as the switched power supply as well.


As for the XM, this was my solution:

http://i.imgur.com/2lBQ7AR.jpg
(click to see image)

http://i.imgur.com/SbYHpQG.jpg
(click to see image)

http://i.imgur.com/da9pYXy.jpg
(click to see image)

Splice the GPS connector into the XM adapter. Viola- your patch cord. You'll need to shave a bit of extrusion on the GPS connector but it's super simple and very easy to do with a file or dremel (shown here). As I said earlier, this was..a source of stress for me. You would need to purchase approx $300 of hardware from Subaru (antenna body, mast, wiring) and drop the liner if you wanted to go stock appearance. I was unable to source a splice cord or square terminal adapter to do this any other way than to splice the 2 seemingly unrelated cables. I mounted the xm ant on my trunk, but you can place it on the rear deck under the glass (barring metallic tint on the rear window) or on the dash.


I have tons of photos covering just about every phase of the install if anyone needs specifics. Good luck.

Last edited by wrexed1; 08-22-2013 at 01:14 AM.
wrexed1 is offline   Reply With Quote
Old 08-16-2013, 08:21 AM   #67
luan87us
Scooby Specialist
 
Member#: 335013
Join Date: Oct 2012
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2013 Premium WRX 5dr
WRB

Default

Nice info! I might have to buy that GPS Antenna as the plug on the one I got didn't plug in correctly and I had to break the plastic connetor to get it to go in. You're lucky David has found the solution to the USB cable. I had to buy the harness from Toyota for $80 T.T and only needed half of it. OH well I think it worthed it. USB functionalities are pretty awesome.
luan87us is offline   Reply With Quote
Old 08-17-2013, 10:12 AM   #68
wrexed1
Scooby Newbie
 
Member#: 320175
Join Date: May 2012
Location: Manalapan, NJ
Vehicle:
2013 WRX Premium
Silver

Default

Thanks man. Yea, the GPS antenna was a great buy and this is the most cost effective USB solution, both courtesy of David of course. I use bt streaming or xm 99% of the time so rarely use the USB but its nice to know its there.
wrexed1 is offline   Reply With Quote
Old 08-20-2013, 03:35 PM   #69
tonymontana1204
Scooby Newbie
 
Member#: 275899
Join Date: Mar 2011
Chapter/Region: Tri-State
Location: New York
Vehicle:
2013 BRZ/XVCrosstrek
Lightning Red / Blue

Default

Definitely want to do this to the XV. Great info here.
tonymontana1204 is online now   Reply With Quote
Old 09-08-2013, 04:41 PM   #70
kayfouroh
Scooby Newbie
 
Member#: 280113
Join Date: Apr 2011
Vehicle:
2011 Forester

Default

Quote:
Originally Posted by wrexed1 View Post
Fujitsu Ten HU
I have a MY14 Forester with a similar FT HU (FF615US instead of your 602) and I cannot disable the VSS feed. Do you have any advice? I tried completely disconnecting the pink/green wire to no benefit. The unit still knows when I am in motion and locks out a majority of the nav functions.
kayfouroh is offline   Reply With Quote
Old 09-09-2013, 10:45 PM   #71
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by kayfouroh View Post
I have a MY14 Forester with a similar FT HU (FF615US instead of your 602) and I cannot disable the VSS feed. Do you have any advice? I tried completely disconnecting the pink/green wire to no benefit. The unit still knows when I am in motion and locks out a majority of the nav functions.
FT models with newer firmware also use GPS to detect motion. You would need to somehow add a switch to disconnect the GPS antenna (in addition to disconnecting VSS and grounding the HU's parking brake input).

You could try using a metal plate to cover the GPS antenna (which is just below the dash, above the instrument cluster). A sheet of aluminum foil might be enough.
SVXdc is offline   Reply With Quote
Old 09-13-2013, 02:11 PM   #72
luan87us
Scooby Specialist
 
Member#: 335013
Join Date: Oct 2012
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2013 Premium WRX 5dr
WRB

Default

So question for everyone with this headunit.

Have anyone tried playing video files off USB? I've been trying to get videos to work on my HU. However no matter what file format I use (avi (divx), mp4, wmv) All I get is audio and the screen is just blue (except it's black when mp4 file is used). I thought my codec might be too new so I tried older codec conversion and still have the same problem. I'm thinking it might be due to that I don't have my VSS and handbreak signal connected? I would greatly appreciate if anyone can test this out and lets me know.
luan87us is offline   Reply With Quote
Old 09-14-2013, 08:20 AM   #73
Cathexis
Scooby Specialist
 
Member#: 335445
Join Date: Oct 2012
Chapter/Region: MAIC
Location: Mechanicsville
Vehicle:
2012 WRX - BLK STIG
Stg. 2 - 287whp/317wtq.

Default

Quote:
Originally Posted by luan87us View Post
So question for everyone with this headunit.

Have anyone tried playing video files off USB? I've been trying to get videos to work on my HU. However no matter what file format I use (avi (divx), mp4, wmv) All I get is audio and the screen is just blue (except it's black when mp4 file is used). I thought my codec might be too new so I tried older codec conversion and still have the same problem. I'm thinking it might be due to that I don't have my VSS and handbreak signal connected? I would greatly appreciate if anyone can test this out and lets me know.
Works fine for me. I have a bunch of top gear episodes on usher. I had to run them through a converter to lower the resolution. Max is 640x480 iirc. Making more today will let you know what I find. Its been a year since I converted them. Its also in the owners manual.
Cathexis is offline   Reply With Quote
Old 09-15-2013, 03:10 AM   #74
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by luan87us View Post
Have anyone tried playing video files off USB? I've been trying to get videos to work on my HU. However no matter what file format I use (avi (divx), mp4, wmv) All I get is audio and the screen is just blue (except it's black when mp4 file is used).
...
I'm thinking it might be due to that I don't have my VSS and handbreak signal connected?
Bingo! You just need to plug in my rear camera harness, which will ground your HU's parking brake input.

If you had connected the HU's VSS input to the car's VSS signal, you would also need to add a switch to break that connection whenever you wanted to be able to view video.

Beware that a future firmware update could cause the HU to start also using GPS to detect motion and activate the lock-out. That happened to the FT nav in the BRZ.

I don't know whether a firmware update could possibly piggy-back on a map update. The BRZs were offered a firmware update to fix problems with GPS reception (in addition to a new bracket that moved the GPS antenna slightly).
SVXdc is offline   Reply With Quote
Old 09-16-2013, 08:35 AM   #75
luan87us
Scooby Specialist
 
Member#: 335013
Join Date: Oct 2012
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2013 Premium WRX 5dr
WRB

Default

Quote:
Originally Posted by SVXdc View Post
Bingo! You just need to plug in my rear camera harness, which will ground your HU's parking brake input.

If you had connected the HU's VSS input to the car's VSS signal, you would also need to add a switch to break that connection whenever you wanted to be able to view video.

Beware that a future firmware update could cause the HU to start also using GPS to detect motion and activate the lock-out. That happened to the FT nav in the BRZ.

I don't know whether a firmware update could possibly piggy-back on a map update. The BRZs were offered a firmware update to fix problems with GPS reception (in addition to a new bracket that moved the GPS antenna slightly).
Ah ok I knew it probably was the handbrake signal. Your rear camera harness has a black wire sticking out do I need to ground that too? or just simply plug the harness in? And I do not plan on connecting my VSS signal. I rarely use the navigation and its seems to work well enough everywhere I go so...
luan87us is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.