Welcome to the North American Subaru Impreza Owners Club Wednesday December 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-30-2013, 01:43 PM   #1
STIfella
Scooby Newbie
 
Member#: 300326
Join Date: Nov 2011
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2011 Legacy
Blue

Default Need Help Installing a Boost Gauge

Right now I am in the process of installing a boost gauge and I'm having a hard time routing the vaccum line through the firewall. I am following the instructions I found on a thread on IWSTI and I am in the verge of losing my patience.
Anybody close to Beltsville not busy today that wouldn't mind giving me a hand?
* Registered users of the site do not see these ads.
STIfella is offline   Reply With Quote
Old 03-30-2013, 02:01 PM   #2
STIfella
Scooby Newbie
 
Member#: 300326
Join Date: Nov 2011
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2011 Legacy
Blue

Default

Anybody?
STIfella is offline   Reply With Quote
Old 03-30-2013, 02:26 PM   #3
XERO287
Scooby Specialist
 
Member#: 253541
Join Date: Jul 2010
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
2011 WRX 5DR Premium
OBP

Default

There are so many options Lol. There are two grommets in the firewall. One right behind the pedals and one on the passenger side. You'll have to remove your tmic to access it from the engine side.
XERO287 is offline   Reply With Quote
Old 03-30-2013, 02:46 PM   #4
STIfella
Scooby Newbie
 
Member#: 300326
Join Date: Nov 2011
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2011 Legacy
Blue

Default

I already have the intercooler removed, I am having trouble running the vacuum line through the firewall.
Text me!!!
STIfella is offline   Reply With Quote
Old 03-30-2013, 05:11 PM   #5
STIfella
Scooby Newbie
 
Member#: 300326
Join Date: Nov 2011
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2011 Legacy
Blue

Default

Never mind. Was able to get it done by myself. Thanks to those who replied (XERO287)
STIfella is offline   Reply With Quote
Old 03-30-2013, 06:28 PM   #6
madcatz
Scooby Specialist
 
Member#: 187530
Join Date: Aug 2008
Chapter/Region: International
Location: Goan
Vehicle:
Fuk UrSelf

Default

the internets...how do they work....oh we all sit around waiting for someone to have an issue.....FLUFFY BUNNY INTERNET HALP CLUB to the rescue.....

you are better off to google and youtube your wants if you expect an answer within 5 hours...

in other words Im trying to tell you to go **** yourself and I hope your car blows up because you need a stupid boost gauge
madcatz is offline   Reply With Quote
Old 03-30-2013, 07:31 PM   #7
STIfella
Scooby Newbie
 
Member#: 300326
Join Date: Nov 2011
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2011 Legacy
Blue

Default

Quote:
Originally Posted by madcatz View Post
the internets...how do they work....oh we all sit around waiting for someone to have an issue.....FLUFFY BUNNY INTERNET HALP CLUB to the rescue.....

you are better off to google and youtube your wants if you expect an answer within 5 hours...

in other words Im trying to tell you to go **** yourself and I hope your car blows up because you need a stupid boost gauge
I love you too sweetheart!
STIfella is offline   Reply With Quote
Old 03-30-2013, 07:50 PM   #8
infinite012
Scooby Specialist
 
Member#: 74392
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
2015 Forester
SWP

Default

Vacuum line through the firewall?

Return poor people boost gauge.
Purchase Defi electronic boost gauge.
Install electronic boost gauge.
Profit.
infinite012 is offline   Reply With Quote
Old 03-30-2013, 07:52 PM   #9
STIfella
Scooby Newbie
 
Member#: 300326
Join Date: Nov 2011
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2011 Legacy
Blue

Default

Quote:
Originally Posted by infinite012 View Post
Vacuum line through the firewall?

Return poor people boost gauge.
Purchase Defi electronic boost gauge.
Install electronic boost gauge.
Profit.
I'm strongly considering it!
STIfella is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:07 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.