Welcome to the North American Subaru Impreza Owners Club Wednesday September 28, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-29-2016, 05:43 PM   #1
mcwrx16
Scooby Newbie
 
Member#: 439322
Join Date: Jan 2016
Default Reputable shop - Were they trying to ripped me off?

*Sorry, Long post*

Hello MSC, I am in need of some opinions/input.
On Monday I dropped off my car at "reputable shop" that was highly recommended to have some suspension work done.
Through their shop I ordered these parts to be installed:
-RCE Yellow Springs
-Whiteline Comp C Top Hats
-Whiteline Adjustable Lower Control Arms

Yesterday I picked up the car, in a rush to get back to work. I did glance over the car to check if everything looked in order with the car. I saw that the springs were installed, but did not check the other parts. Last night after work, I went to look over the car again. I saw again the springs were installed. Checked under the hood and saw the top hats were installed. However, when I went under the car to look as if the whiteline lca were installed. They appear to me, they weren't. Why? Because the whiteline lcas are white/silver color right? But the ones underneath the car are black. Look to be oem control arms.

So early this morning I drove back to the "reputable shop" to voice my concerns. He tells me they were whiteline lcas that were painted black. Obviously I did not believe his words. I tell him I ordered the silver whiteline lcas, the ones that I paid you guys for. Not the whiteline lcas supposedly painted black. So the whiteline lcas are estimated to arrive sometime Tuesday or Wednesday. I expect them to install them for no charge and I expect them to give me a free alignment. The commute there and back is about 40 miles each time, gas isn't free. How should I go about this MSC? Should I just go in next week, get the part installed, get my alignment done, be on my way and not question it. Or should I start asking alot of questions? Obviously I will not be doing future business this "reputable shop" again.

Your input is much appreciated, thanks MSC.
* Registered users of the site do not see these ads.

Last edited by mcwrx16; 07-29-2016 at 05:51 PM.
mcwrx16 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-29-2016, 08:38 PM   #2
Shipman
Scooby Guru
 
Member#: 312847
Join Date: Mar 2012
Chapter/Region: Tri-State
Location: MD
Vehicle:
2006 WRX STi
2008 Legacy/2003 Forester

Default

What do you intend on accomplishing by asking questions and bitching? You seem to already have your mind made up about future business with them so I suggest you dont waste your time. Get the correct parts installed and be on your way. Do you expect them to tell you the truth if you believe they already attempted to BS you once?

Im curious to know what shop youre talking about though, if you wouldnt mind PMing me I would appreciate it. I would like to know if Ive had similar experiences with them.
Shipman is offline   Reply With Quote
Old 07-29-2016, 09:43 PM   #3
AllAWD
Scooby Specialist
 
Member#: 17079
Join Date: Apr 2002
Chapter/Region: MAIC
Location: Alexandria, VA
Default

Vendor reviews: http://forums.nasioc.com/forums/forumdisplay.php?f=58

When they get done you can post up a review.

I would also be curious to know the shop that did that and whether anyone has heard of these black painted whiteline parts.
AllAWD is offline   Reply With Quote
Old 07-30-2016, 09:19 AM   #4
jstepp5220
Scooby Specialist
 
Member#: 207098
Join Date: Mar 2009
Chapter/Region: MAIC
Location: Bel Air to Westminster
Vehicle:
STI :( Gone
'14XV Gone, '10 FXT

Default

Save others from a potential bad experience as well. IMO you should disclose the shop that has done this. But that's just my .02
jstepp5220 is offline   Reply With Quote
Old 07-30-2016, 10:02 AM   #5
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

I think there is something to be gained by asking to speak to a manager and explain what happened. No need to be emotional about it, just explain that you're disappointed such a reputable shop gave you a run-around. You understand that humans make mistakes, and whoever you talked to initially should've owned up to the mistake rather than (apparently) feeding you a line of BS about black-painted Whiteline arms.

Make sure you ask to keep the black arms when the new arms are installed.
Patrick Olsen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:06 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.