Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-26-2013, 05:17 PM   #1
4thgen
Scooby Newbie
 
Member#: 298633
Join Date: Oct 2011
Default SS. Maryland assistance with cusco engine and transmission mounts

I purchased a set of Cusco engine and trasmission mounts and attempted to install them. I was able to get one side of the engine mounts in but the other was giving me a real problem. I put the stock mounts back on and was going to have them installed at a shop. I found out they were going to charge almost as much as the kit. I was looking to see if anyone has installed these and could either assist me or I could pay you a reasonable fee to install these for me. I live in Silver Spring Maryland. If anyone lives close and could help. Please message me. Thanks in advance.
* Registered users of the site do not see these ads.
4thgen is offline   Reply With Quote
Old 03-27-2013, 11:50 AM   #2
StillBoostin
Scooby Specialist
 
Member#: 46177
Join Date: Oct 2003
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
2002 WRB WRX
99 2.5RS Coupe

Default

Quote:
Originally Posted by 4thgen View Post
I purchased a set of Cusco engine and trasmission mounts and attempted to install them. I was able to get one side of the engine mounts in but the other was giving me a real problem. I put the stock mounts back on and was going to have them installed at a shop. I found out they were going to charge almost as much as the kit. I was looking to see if anyone has installed these and could either assist me or I could pay you a reasonable fee to install these for me. I live in Silver Spring Maryland. If anyone lives close and could help. Please message me. Thanks in advance.
Yeah its a pain in the ass. You need swivel sockets and to be able to work your hands without looking. Good times.
StillBoostin is offline   Reply With Quote
Old 03-30-2013, 10:18 PM   #3
freezen
Scooby Newbie
 
Member#: 159373
Join Date: Sep 2007
Chapter/Region: E. Canada
Location: Ontario Canada
Vehicle:
2004 WRX STI
Blue

Default

Quote:
Originally Posted by 4thgen View Post
I purchased a set of Cusco engine and trasmission mounts and attempted to install them. I was able to get one side of the engine mounts in but the other was giving me a real problem. I put the stock mounts back on and was going to have them installed at a shop. I found out they were going to charge almost as much as the kit. I was looking to see if anyone has installed these and could either assist me or I could pay you a reasonable fee to install these for me. I live in Silver Spring Maryland. If anyone lives close and could help. Please message me. Thanks in advance.
i did mine when i had my transmission out, made it much easier, make sure you have the engine mounts facing the right way, other wise your oil pan will hit
freezen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:35 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.