Welcome to the North American Subaru Impreza Owners Club Sunday December 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-02-2013, 11:13 AM   #1
abaton6
Scooby Newbie
 
Member#: 149373
Join Date: May 2007
Default 97 auto won't downshift

My Son's 97 won't down shift when needed. Going uphill, it will not D S till it's really bogging down, then, WHAM! into 1st, 5000 rpm. He can shift it down manually, but it will not do it on it's own. Any suggestions would be appreciated. Trying to make this thing last till he's out of College.
* Registered users of the site do not see these ads.
abaton6 is offline   Reply With Quote
Old 04-02-2013, 12:16 PM   #2
Rudgers73
Scooby Newbie
 
Member#: 141433
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Rochester, NY
Vehicle:
2006 Impreza 2.5i
Obsidian Black

Default

Check the trans fluid level
Rudgers73 is offline   Reply With Quote
Old 04-04-2013, 08:00 PM   #3
abaton6
Scooby Newbie
 
Member#: 149373
Join Date: May 2007
Default

Thanx, The tranny fluid is fine. This has a vacuum activated downshifter assist. I put my mityvac on the hose that goes from the diaphragm housing to the intake manifold. It holds a vacuum, but does not move.. So the diaphragm is fine. Any other suggestions why this will not work?. I noticed that the booster has an electrical connection..............................
abaton6 is offline   Reply With Quote
Old 04-04-2013, 08:44 PM   #4
silverton
Scooby Newbie
 
Member#: 331131
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Burien, WA
Vehicle:
2001 2.5RS
STM

Default

maybe the TPS? since it'll shift in to the lower gears manually, but won't do it automagically at speed like it should, it's gotta be a sensor.
silverton is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:23 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.