Welcome to the North American Subaru Impreza Owners Club Tuesday October 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-03-2013, 09:00 AM   #1
BoyBlunder
Scooby Newbie
 
Member#: 351632
Join Date: Mar 2013
Chapter/Region: NESIC
Location: Shrewsbury, MA
Vehicle:
2013 WRX 5dr
Satin White Pearl

Default Wear-in period for stock clutch?

What's the usual break-in period for the stock clutch? I'm about 400mi in on my '13 WRX, and I still get the occasional burnt clutch smell sometimes when I reverse.
* Registered users of the site do not see these ads.
BoyBlunder is offline   Reply With Quote
Old 04-03-2013, 12:43 PM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

just like the rest of the car....give it at least 1k miles
Uncle Scotty is offline   Reply With Quote
Old 04-03-2013, 08:45 PM   #3
kabz
Scooby Newbie
 
Member#: 351744
Join Date: Mar 2013
Chapter/Region: TXIC
Location: Northwest Houston
Vehicle:
2013 WRX
WRB

Default

Mine broke in overnight about 800 miles. Overnight, because Monday is was sharp and Tuesday it was more like I'd expect. Nice and smooth and not as much feeling like I'm about to stall. It took a good bit of driving in traffic to do that though. I think I babied it a bit long.
kabz is offline   Reply With Quote
Old 04-04-2013, 01:14 AM   #4
SideDish120
Scooby Newbie
 
Member#: 348769
Join Date: Mar 2013
Chapter/Region: MWSOC
Location: Cleveland/Toledo, Ohio
Vehicle:
2013 WRX Hatch Ltd
Satin White Pearl

Default

I'm about about 900 and it's finally smoothed out. I stopped getting the smell around 500 I'd say. Shifts like butter now.
SideDish120 is offline   Reply With Quote
Old 04-04-2013, 08:57 AM   #5
BoyBlunder
Scooby Newbie
 
Member#: 351632
Join Date: Mar 2013
Chapter/Region: NESIC
Location: Shrewsbury, MA
Vehicle:
2013 WRX 5dr
Satin White Pearl

Default

Thanks for the advice guys! Looks like I'll need to do some more city driving to wear this baby in right
BoyBlunder is offline   Reply With Quote
Old 04-07-2013, 05:17 PM   #6
bkruelle
Scooby Newbie
 
Member#: 279027
Join Date: Apr 2011
Chapter/Region: MAIC
Vehicle:
2011 WRX
WRB

Default

After you guys break in ur clutch did it get stiffer or did it stay soft? I had my 2011 wrx clutch replaced at 20k and im at 25k now and the clutch feels the same as it did when i got the car back from the stealership.. My oem clutch after break in got harder but this replacement clutch is not..
bkruelle is offline   Reply With Quote
Old 04-15-2013, 08:35 PM   #7
kabz
Scooby Newbie
 
Member#: 351744
Join Date: Mar 2013
Chapter/Region: TXIC
Location: Northwest Houston
Vehicle:
2013 WRX
WRB

Default

Mine stayed about the same pedal force, or a tad lighter, but the engagement is nicely progressive. Really took the slight nervousness off driving it.

At about 1500 miles now, and can really feel the bite start to come in. Still a really solid engagement when driving 'briskly'.
kabz is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:26 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.