Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-08-2013, 04:48 PM   #1
need4speed45
Scooby Newbie
 
Member#: 317767
Join Date: Apr 2012
Location: New York
Vehicle:
2002 Wrx
Blue

Default 2002 wrx-opinions wanted

How's it going fellow suby lovers. I have a 2002 wrx with a m2 turboback, isc coilovers, accessport with a stage 2 tune. (not a protune) A 2005 wrx recently came into my dealership with a sti interior, turbo xs top mount intercooler, greddy strut bar etc. I was able to swap out all the parts. I want to wait a little while to bank some money before i go in and upgrade the fuel pump, injectors and turbo. With the intercooler and a protune and intake will my car run like it did before I swapped out the intercoolers? Because it obviously does not drive the same because the lack of back pressure. Any opinions or suggestions are appreciated.
* Registered users of the site do not see these ads.
need4speed45 is offline   Reply With Quote
Old 04-09-2013, 11:09 AM   #2
art@grimmspeed
NASIOC Vendor
 
Member#: 301037
Join Date: Nov 2011
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
2004 Forester XT
Aspen White

Default

All you did was swap out the TMIC so far right?
art@grimmspeed is offline   Reply With Quote
Old 04-09-2013, 12:26 PM   #3
420bugeye
Scooby Newbie
 
Member#: 283513
Join Date: May 2011
Chapter/Region: MWSOC
Location: Minot ND
Vehicle:
2012 Wrx
Wrb

Default

I put a big old top mount on my bugeye more then a year ago and didnt notice anything diffrent but my bov cracking open sooner. Y u need protune wouldnt it make more sence to wait until u put in injectors and turbo? U dont 'need' protune until those parts
420bugeye is offline   Reply With Quote
Old 04-10-2013, 09:47 AM   #4
need4speed45
Scooby Newbie
 
Member#: 317767
Join Date: Apr 2012
Location: New York
Vehicle:
2002 Wrx
Blue

Default

Yeah after doing some digging around it turns out the sleeve from the turbo to the intercooler was shot and not making a good seal so that's why I was not making any boost. Thanks for the help though guys
need4speed45 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.