Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-24-2013, 12:16 PM   #1
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default first time tuning. need major help

hey guys. I am looking to start tuning my own car, but I am having a hard time knowing where to start. I have read the "tuning for newbies guide" and also a bunch of other threads on here/ as well as the romraider forums.

I am not looking to be spoonfed, but I just need a little bit of direction on where to start, and I think I will be able to figure it out much more quickly with a bit of guidance from you guys that have been doing this for awhile now.

so anyways here is what I have for tuning equipment

innovate mtxl wideband
blue vagcom cable
romraider
ecuflash v1.29.906
learningview
windows 8

here is a link to my build thread on the car
http://forums.nasioc.com/forums/show....php?t=1753564

cn:
07 2.5i m/t
built motor
large turbo
modded wrx injectors
blow through maf
mbc

right now I have just a base tune that I had done by someone else. it's running wastegate pressure (7pounds)... I would like to smooth everything out, and start turning up the boost.

basically I am wondering where to start? what should I be logging?
* Registered users of the site do not see these ads.

Last edited by olsen726; 02-24-2013 at 12:25 PM.
olsen726 is offline   Reply With Quote
Old 02-24-2013, 04:05 PM   #2
endrswrd
Scooby Newbie
 
Member#: 323908
Join Date: Jun 2012
Chapter/Region: MWSOC
Location: Dayton Ohio
Vehicle:
2013 BRZ ltd
ISM

Default

What rom are you running on your NA ecu that allows you to tune for boost? Are you using a WRX rom on your NA ECU?
endrswrd is offline   Reply With Quote
Old 03-01-2013, 11:49 AM   #3
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

using the factory 2.5i ecu/ rom.
im pretty sure the ecu doesnt know that the car is boosting..that you just tune it how people would tune there older na/t subarus with a piggyback

i could be way off though. i am still trying to learn this as i go
olsen726 is offline   Reply With Quote
Old 03-02-2013, 04:24 PM   #4
ProfessWRX
Scooby Specialist
 
Member#: 323379
Join Date: Jun 2012
Vehicle:
06 WRX

Default

Quote:
Originally Posted by olsen726 View Post
using the factory 2.5i ecu/ rom.
im pretty sure the ecu doesnt know that the car is boosting..that you just tune it how people would tune there older na/t subarus with a piggyback

i could be way off though. i am still trying to learn this as i go
Does the stock MAP sensor read high enough? Can you scale the necessary tables? I've tuned a turbo car on an na ecm. Not a Subaru but It can be done. Not ideal but it works.

Last edited by ProfessWRX; 03-02-2013 at 04:32 PM.
ProfessWRX is offline   Reply With Quote
Old 03-03-2013, 02:00 AM   #5
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

im not sure about the factory map sensor. i believe it will read high enough, but i dont know for sure.
and yes i am pretty sure you can scale everything that you would be able to scale on a wrx ecu
olsen726 is offline   Reply With Quote
Old 03-03-2013, 02:01 AM   #6
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

tomorrow i will post a log. hopefully one of you guys can help me out with deciphering the info on it

is this everything i should be logging
• Engine Speed (RPM)
• Engine Load
• IAM
• A/F Correction
• A/F Learning
• A/F Sensor
• CL/OL Fueling
• Feedback Knock Correction (FBCK)
• Fine Learning Knock Correction (FLKC)
• Ignition Base Timing
• Ignition Total Timing
• Knock Correction Advance
• Mass Air Flow Sensor Voltage
• Throttle Opening Angle
• Manifold Relative Pressure
• Injector Duty Cycle
• Intake Air Temp
olsen726 is offline   Reply With Quote
Old 03-03-2013, 02:54 AM   #7
ProfessWRX
Scooby Specialist
 
Member#: 323379
Join Date: Jun 2012
Vehicle:
06 WRX

Default

Quote:
Originally Posted by olsen726 View Post
tomorrow i will post a log. hopefully one of you guys can help me out with deciphering the info on it

is this everything i should be logging
• Engine Speed (RPM)
• Engine Load
• IAM
• A/F Correction
• A/F Learning
• A/F Sensor
• CL/OL Fueling
• Feedback Knock Correction (FBCK)
• Fine Learning Knock Correction (FLKC)
• Ignition Base Timing
• Ignition Total Timing
• Knock Correction Advance
• Mass Air Flow Sensor Voltage
• Throttle Opening Angle
• Manifold Relative Pressure
• Injector Duty Cycle
• Intake Air Temp
I would skip maf volts and scan maf afgs instead.
If also skip base timing and advance timing.total is all that's really important. Scan absolute manifold pressure and atmospheric pressure instead of relative pressure.
...But that's just me.

Also idc is only needed if you question their ability to keep up with fueling requirements. Otherwise fewer parameters is better.
ProfessWRX is offline   Reply With Quote
Old 03-03-2013, 12:15 PM   #8
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

sounds good. i will head out here in a few to get some logging done... thanks for all of the help
olsen726 is offline   Reply With Quote
Old 03-03-2013, 02:45 PM   #9
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

of course the frigging serial to usb adapter that i bought wont work with windows 8... i will just have to log without the wideband, until i can get another converter cable
olsen726 is offline   Reply With Quote
Old 03-08-2013, 05:36 PM   #10
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

finally got everything hooked up and working properly.
here are some of my logs
i logged them today
60 degrees out/ blue sky
3rd gear 3k-6200 wot

gonna figure out how to post the logs, and have them on here very shortly
olsen726 is offline   Reply With Quote
Old 03-08-2013, 05:49 PM   #11
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

http://www.fileswap.com/dl/RNPxwD4z/
http://www.fileswap.com/dl/K1vkKd7rrf/
http://www.fileswap.com/dl/B9yCWaynKk/

that is a link to the files... i am still trying to figure out how to post them on here
olsen726 is offline   Reply With Quote
Old 03-08-2013, 06:26 PM   #12
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

i think i figured it out... here is the 3rd log i did
https://docs.google.com/spreadsheet/...=0&output=html
olsen726 is offline   Reply With Quote
Old 03-08-2013, 06:32 PM   #13
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

olsen726 is offline   Reply With Quote
Old 03-10-2013, 02:54 PM   #14
ProfessWRX
Scooby Specialist
 
Member#: 323379
Join Date: Jun 2012
Vehicle:
06 WRX

Default

Don't go wot again. You are very lean.

It also looks like your map sensor is maxed out at 19.88. Don't know enough about your computer but it could be a sensor limitation or the ECM reading limit. I assume the sensor.

That means the computer is seeing 5 psi max.

Last edited by ProfessWRX; 03-10-2013 at 03:34 PM.
ProfessWRX is offline   Reply With Quote
Old 03-10-2013, 03:36 PM   #15
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

should i see if i can track down a wrx map sensor, and swap that it?
also i thought around 11.1 afr was what it was supposed to be under boost, or are you referring to the 3246-4216 rpm range?
olsen726 is offline   Reply With Quote
Old 03-10-2013, 06:53 PM   #16
ProfessWRX
Scooby Specialist
 
Member#: 323379
Join Date: Jun 2012
Vehicle:
06 WRX

Default

Quote:
Originally Posted by olsen726 View Post
should i see if i can track down a wrx map sensor, and swap that it?
also i thought around 11.1 afr was what it was supposed to be under boost, or are you referring to the 3246-4216 rpm range?
It may not be as easy as a simple swap. Might want to see is somebody else has done that and see what all it takes. It is a very important sensor.

And yes, 3200-4200 is way too lean.
ProfessWRX is offline   Reply With Quote
Old 03-10-2013, 09:39 PM   #17
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

Ok, thanks for the help. I will do some digging, and see what I can find on the map sensor issue... I have a feeling I wont be able to find much info on it though... there arent a whole lot of people tuning/boosting these cars
olsen726 is offline   Reply With Quote
Old 03-10-2013, 09:59 PM   #18
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

Just found a thread on rs25 where a guy said that his map maxed out at 5psi too. He had to run a voltage clamp thing... im still reading up on my options though
olsen726 is offline   Reply With Quote
Old 03-15-2013, 08:25 PM   #19
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

i grabbed a map sensor off of a wrx motor that i had laying around, and it bolted right up now i just need to figure out how to calibrate this thing!
olsen726 is offline   Reply With Quote
Old 03-15-2013, 09:24 PM   #20
endrswrd
Scooby Newbie
 
Member#: 323908
Join Date: Jun 2012
Chapter/Region: MWSOC
Location: Dayton Ohio
Vehicle:
2013 BRZ ltd
ISM

Default

if the calibration values are in the same units as the wrx rom, you may be able to pull it directly from there. Hopefully somebody who has more knowledge on this type of situation can help...
endrswrd is offline   Reply With Quote
Old 03-20-2013, 03:49 AM   #21
Gamble_WRX
Scooby Specialist
 
Member#: 234783
Join Date: Jan 2010
Chapter/Region: Tri-State
Location: Pennsylvania
Vehicle:
2003 WRX Wagon
PSM

Default

im just getting back into tuning, but can i get a copy of your rom? i wanna see how the map lines up with the log. thanks!
Gamble_WRX is offline   Reply With Quote
Old 03-20-2013, 10:18 PM   #22
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

i will get you one as soon as i can figure out how to get ecuflash to read my rom
olsen726 is offline   Reply With Quote
Old 03-25-2013, 11:29 AM   #23
abstrakraft
Scooby Newbie
 
Member#: 292008
Join Date: Aug 2011
Chapter/Region: BAIC
Location: Bay Area, CA
Vehicle:
2007 OBS SE
Blue/Grey

Default

Your 2.5i uses a MAF (Mass Air Flow) sensor, not a MAP (Manifold Air Pressure) sensor. Where exactly are you plugging in the MAP sensor? If it's replacing the MAF, I wouldn't think the ECU (which is still expecting MAF) will be too happy.
abstrakraft is offline   Reply With Quote
Old 03-25-2013, 05:18 PM   #24
mechatricity
Scooby Specialist
 
Member#: 290592
Join Date: Aug 2011
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2006 WRX Wagon
2004 WRX Wagon

Default

Quote:
Originally Posted by abstrakraft View Post
Your 2.5i uses a MAF (Mass Air Flow) sensor, not a MAP (Manifold Air Pressure) sensor. Where exactly are you plugging in the MAP sensor? If it's replacing the MAF, I wouldn't think the ECU (which is still expecting MAF) will be too happy.
errrrr....they are not mutually exclusive...
mechatricity is offline   Reply With Quote
Old 03-28-2013, 12:26 PM   #25
olsen726
Scooby Specialist
 
Member#: 154175
Join Date: Jul 2007
Chapter/Region: NWIC
Location: PDX
Vehicle:
07 Impreza Wagon
2.5i???

Default

Quote:
Originally Posted by abstrakraft View Post
Your 2.5i uses a MAF (Mass Air Flow) sensor, not a MAP (Manifold Air Pressure) sensor. Where exactly are you plugging in the MAP sensor? If it's replacing the MAF, I wouldn't think the ECU (which is still expecting MAF) will be too happy.
It uses both map and maf.
olsen726 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:02 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.