Welcome to the North American Subaru Impreza Owners Club Thursday December 8, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-30-2016, 11:28 PM   #1
lww
Scooby Newbie
 
Member#: 166885
Join Date: Dec 2007
Chapter/Region: BAIC
Location: SF Bay
Vehicle:
2000 Impreza Outback
White

Default OMG! Squeaky power steering belt...

So, I've been fighting with this for about 4 months now. A shop I don't normally use did a tune up & oil change on my wife's '00 Outback Sport in prep for the wonderful CA smog check. They also replaced the belts that were worn while they were in there.

Ever since, the damn power steering belt squeals for about 10-15 seconds on cold start and sometimes when making slow turns.

This is usually a loose belt but I've been so busy at work I haven't had 2 seconds to mess with it so my wife has dropped it off at the shop 3 times to have it adjusted. Works "fine" after a few "adjustments" meaning it's warmed up and won't squeal until the next morning.

Finally, today, after reaching the end of my rope I checked it and the adjustment was completely bottomed out and there was still WAY too much play on the belt. I drove to O'Reilly's and grabbed a new belt, pulled off the old belt and when I put them together, the new belt is at least a half inch shorter! Those ass holes put the wrong belt on and weren't clued enough to realize the adjuster was bottomed.

Now the adjuster bolt is only about 2/3's the way up, it has exactly the right amount of play in the belt and it drives perfectly with nary a sound on slow turns.
* Registered users of the site do not see these ads.
lww is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-07-2016, 08:33 PM   #2
blue042.5rs
Scooby Newbie
 
Member#: 456447
Join Date: Oct 2016
Default

Bearing might of gone with it cranked down that far.
blue042.5rs is offline   Reply With Quote
Old 11-07-2016, 08:47 PM   #3
TrickNipple
moon moon
Moderator
 
Member#: 86213
Join Date: May 2005
Chapter/Region: NWIC
Location: Wild wild Northwest
Default

Quote:
Originally Posted by blue042.5rs View Post
Bearing might of gone with it cranked down that far.
Did you even read the post?
TrickNipple is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 01:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.