Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-24-2013, 07:33 PM   #1
La_Madre_Tuya
Scooby Newbie
 
Member#: 300471
Join Date: Nov 2011
Default Wheel jerking entire car

Hey whats up guys, while i was driving today i noticed that my passenger rear wheel jerks the entire car every here and there. I went to work on the car and noticed that the rotor swings back and forth a little when the wheel is mounted on but doesnt without a wheel on. While driving it also sounds something like the brake pad scratching the rotor. If anybody can help id appreciate it. Thanks
* Registered users of the site do not see these ads.
La_Madre_Tuya is offline   Reply With Quote
Old 04-24-2013, 08:10 PM   #2
A-man07
Scooby Specialist
 
Member#: 271525
Join Date: Jan 2011
Location: BagEnd
Vehicle:
07 STi
424whp/382wtq GT3076

Default

And you drove it...sounds like a wheel bearing.
A-man07 is offline   Reply With Quote
Old 04-24-2013, 11:38 PM   #3
La_Madre_Tuya
Scooby Newbie
 
Member#: 300471
Join Date: Nov 2011
Default

Yea sucks I know. I'm trying to find out for sure
La_Madre_Tuya is offline   Reply With Quote
Old 04-25-2013, 08:45 AM   #4
La_Madre_Tuya
Scooby Newbie
 
Member#: 300471
Join Date: Nov 2011
Default

Bump...
La_Madre_Tuya is offline   Reply With Quote
Old 04-25-2013, 08:49 AM   #5
A-man07
Scooby Specialist
 
Member#: 271525
Join Date: Jan 2011
Location: BagEnd
Vehicle:
07 STi
424whp/382wtq GT3076

Default

What else do you want to know? You've already done the poor man's test, time to have it changed.
A-man07 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:28 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.