Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-21-2013, 08:25 PM   #1
kiwiz34
Scooby Newbie
 
Member#: 304789
Join Date: Dec 2011
Default Front swaybar bushing clamp direction.

Recently had a shop re-grease my whiteline 22mm front swaybar/polybushings on my 07 2.5i wagon.

While doing my oil change i noticed that the drivers side clamp appeared to be on backwards. The clamp has an arrow stamped on the bottom which i assume is supposed to point to the front of the car (was pointed to the back)
Additionally that side had creaked after the job, it is not the same direction as the passenger side and just doesn't look right.

I'd appreciate if anyone could help me find some documentation showing exactly how the bushing clamp should be oriented. I've not been able to find anything detailed enough.

Thanks!
* Registered users of the site do not see these ads.
kiwiz34 is offline   Reply With Quote
Old 04-21-2013, 10:03 PM   #2
jamal
Scooby Guru
 
Member#: 71875
Join Date: Oct 2004
Location: Montana
Vehicle:
98 2.5GT
my wheels fit

Default

Arrow forward. When you put it back on it's kind of obviously bent to fit better in the right direction.
jamal is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:45 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.