Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-27-2013, 04:17 AM   #1
dmg44
Scooby Newbie
 
Member#: 354408
Join Date: Apr 2013
Chapter/Region: MWSOC
Vehicle:
2010 WRX
White

Default Weird hissing sound at 4k RPM

My car is a 2010 Wrx Sedan.
My only mods right now are a CBE and COBB Ap Stage 1 93.

Recently, I just started hearing a constant high pitch whistling/hissing sound coming from the engine bay when I am WOT at 4k. Sounds like an air leak. I've had my data logs reviewed by a tuner friend and he said there is no obvious boost leak and that the car appears to be running healthy.


Here is a video of the actual sound of me doing WOT in 2nd at 3k rpm and the hissing kicks in around 4k until I left off the gas, and then continues while I'm WOT in 4th.

Any idea what is wrong?
* Registered users of the site do not see these ads.
dmg44 is offline   Reply With Quote
Old 04-27-2013, 04:51 AM   #2
Coreycarlile911
Scooby Specialist
 
Member#: 282614
Join Date: May 2011
Chapter/Region: NWIC
Location: Spokane Washington
Vehicle:
2006 Wrx sti
Black pearl

Default

The hiss of your turbo? Sounds pretty normal
Coreycarlile911 is offline   Reply With Quote
Old 04-27-2013, 01:03 PM   #3
dmg44
Scooby Newbie
 
Member#: 354408
Join Date: Apr 2013
Chapter/Region: MWSOC
Vehicle:
2010 WRX
White

Default

well it didn't have that sound a few months ago. And I don't hear it on other WRX pull videos.
dmg44 is offline   Reply With Quote
Old 04-27-2013, 01:56 PM   #4
Cathexis
Scooby Specialist
 
Member#: 335445
Join Date: Oct 2012
Chapter/Region: MAIC
Location: Ashland, VA
Vehicle:
2012 WRX - BLK STIG
Stg. 2 - 287whp/317wtq.

Default

Have you checked you intercooler clamps, i assume you took it off to get to the back bolt ehen you installed your dp. Details are in my reply to your other post on this issue.
Cathexis is offline   Reply With Quote
Old 04-27-2013, 03:33 PM   #5
dmg44
Scooby Newbie
 
Member#: 354408
Join Date: Apr 2013
Chapter/Region: MWSOC
Vehicle:
2010 WRX
White

Default

I haven't installed the dp yet. I've never touched the intercooler on this car.
dmg44 is offline   Reply With Quote
Old 04-27-2013, 07:01 PM   #6
Coreycarlile911
Scooby Specialist
 
Member#: 282614
Join Date: May 2011
Chapter/Region: NWIC
Location: Spokane Washington
Vehicle:
2006 Wrx sti
Black pearl

Default

Quote:
Originally Posted by dmg44 View Post
well it didn't have that sound a few months ago. And I don't hear it on other WRX pull videos.
Well with stage one and catback you are running bit more boost and the aftermarket cat back is a tad less restricted. Idk just sounds like the turbo doing its job to me. How long have you been on the stage1 map?
Coreycarlile911 is offline   Reply With Quote
Old 04-28-2013, 02:19 AM   #7
dmg44
Scooby Newbie
 
Member#: 354408
Join Date: Apr 2013
Chapter/Region: MWSOC
Vehicle:
2010 WRX
White

Default

about a month now

I checked all the clamps and hoses and everything seems to be snug.

Now I think about it, I first heard the noise right after installing my turbo XS CBE. My mechanic friend noticed the noise too and said that turbo is louder because its more free flowing. I am just bothered because I don't hear it on other WRX's with stage 1 and 3" CBE.

Last edited by dmg44; 04-28-2013 at 03:13 AM.
dmg44 is offline   Reply With Quote
Old 04-28-2013, 06:50 AM   #8
Cathexis
Scooby Specialist
 
Member#: 335445
Join Date: Oct 2012
Chapter/Region: MAIC
Location: Ashland, VA
Vehicle:
2012 WRX - BLK STIG
Stg. 2 - 287whp/317wtq.

Default

If you didnt replace the dp you likely wouldnt hear anything from the turbo because of the restrictive cat. I had issues getting my dp on so i drove around for awhile with a cbe. Once i got the catted dp on, i only just could hear some turbo whine, no hiss. The only hiss i get is from the cold air intake. Have you checked the mating of your cbe to stock dp for a possible leak. Will be really easy to spot if you've been hearing it for a month, it will have black carbon streaks where its leaking. I ditched the spring bolts for a more traditional, tight fitting, nut and bolt.

If thats not it, do a log. Log a third gear pull, and do a short cruise log. Post it on google drive or better google docs, make it public, and let's take a look at your fuel trims.

Last edited by Cathexis; 04-28-2013 at 07:03 AM.
Cathexis is offline   Reply With Quote
Old 04-28-2013, 10:07 AM   #9
C3hutson
Scooby Specialist
 
Member#: 347969
Join Date: Feb 2013
Vehicle:
04 STi
JBP

Default

Quote:
Originally Posted by Cathexis View Post
If you didnt replace the dp you likely wouldnt hear anything from the turbo because of the restrictive cat. I had issues getting my dp on so i drove around for awhile with a cbe. Once i got the catted dp on, i only just could hear some turbo whine, no hiss. The only hiss i get is from the cold air intake. Have you checked the mating of your cbe to stock dp for a possible leak. Will be really easy to spot if you've been hearing it for a month, it will have black carbon streaks where its leaking. I ditched the spring bolts for a more traditional, tight fitting, nut and bolt.

If thats not it, do a log. Log a third gear pull, and do a short cruise log. Post it on google drive or better google docs, make it public, and let's take a look at your fuel trims.
I'm pretty sure I hear more turbo just from adding the nameless muffled axleback. A new noise has started since the install at full boost... Kind of a low pitch hiss...
C3hutson is offline   Reply With Quote
Old 04-28-2013, 06:59 PM   #10
Coreycarlile911
Scooby Specialist
 
Member#: 282614
Join Date: May 2011
Chapter/Region: NWIC
Location: Spokane Washington
Vehicle:
2006 Wrx sti
Black pearl

Default

Quote:
Originally Posted by C3hutson View Post

I'm pretty sure I hear more turbo just from adding the nameless muffled axleback. A new noise has started since the install at full boost... Kind of a low pitch hiss...
Yea that's most likely what your hearing. You could do a log and make sure boost and everything is up to par but from the video it doesn't sound like you have anything bad going on.
Coreycarlile911 is offline   Reply With Quote
Old 04-28-2013, 07:39 PM   #11
bootystank
Scooby Newbie
 
Member#: 354475
Join Date: Apr 2013
Chapter/Region: NESIC
Location: Mendon MA
Vehicle:
2011 WRX Hatch
Satin white pearl

Default

if your that worried do a smoke test. But when im on the highway i hear my turbo hiss/whine from 2500 to 4500 rpms and i Can make it louder of quieter just with my foot
bootystank is offline   Reply With Quote
Old 04-28-2013, 09:03 PM   #12
cond
Scooby Newbie
 
Member#: 339416
Join Date: Dec 2012
Chapter/Region: Tri-State
Location: Binghamton, NY
Vehicle:
2015 STI
WRB

Default

Yea I also recently started noticing a hiss after stage one map and namless axleback. Think its fine as long as your not over boosting or anything
cond is offline   Reply With Quote
Old 04-28-2013, 09:38 PM   #13
dmg44
Scooby Newbie
 
Member#: 354408
Join Date: Apr 2013
Chapter/Region: MWSOC
Vehicle:
2010 WRX
White

Default

Quote:
Originally Posted by Cathexis View Post
If you didnt replace the dp you likely wouldnt hear anything from the turbo because of the restrictive cat. I had issues getting my dp on so i drove around for awhile with a cbe. Once i got the catted dp on, i only just could hear some turbo whine, no hiss. The only hiss i get is from the cold air intake. Have you checked the mating of your cbe to stock dp for a possible leak. Will be really easy to spot if you've been hearing it for a month, it will have black carbon streaks where its leaking. I ditched the spring bolts for a more traditional, tight fitting, nut and bolt.

If thats not it, do a log. Log a third gear pull, and do a short cruise log. Post it on google drive or better google docs, make it public, and let's take a look at your fuel trims.
I just had my car on the lift today while we were installing my dp and I noticed an exhaust leak from the stock dp to turbo xs cbe. After going stage 2 today and fixing the leak, I don't think I hear it as much. But I wasn't paying attention because I was too distracted by how awesome stage 2 is and the new sound of my catless downpipe. But I'll post my log in a few days.
dmg44 is offline   Reply With Quote
Old 04-28-2013, 10:07 PM   #14
Cathexis
Scooby Specialist
 
Member#: 335445
Join Date: Oct 2012
Chapter/Region: MAIC
Location: Ashland, VA
Vehicle:
2012 WRX - BLK STIG
Stg. 2 - 287whp/317wtq.

Default

Awesome!!!
Cathexis is offline   Reply With Quote
Old 04-29-2013, 06:32 PM   #15
dmg44
Scooby Newbie
 
Member#: 354408
Join Date: Apr 2013
Chapter/Region: MWSOC
Vehicle:
2010 WRX
White

Default

Thanks for all your help!
dmg44 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:09 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.