Welcome to the North American Subaru Impreza Owners Club Wednesday November 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-29-2013, 07:35 PM   #1
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default help!

So I just had a mechanic replace all my pullies and timing belt because the old pullies had bad bearings and were wearing the old timing belt which was causing it to slap on cold and semi-cold starts. I have only had the car back for 5 days and the slapping is still there. It is much quieter on a cold start but if I let the car sit for a few hours and start it again it sounds terrible. Also the idle flucuates very slightly on a cold start which it never did before. Its a auto 2007 2.5i impreza

Ive been dealing with this challenge for over three weeks now along with a number of other problems with the car. Really starting to consider selling it and ridding myself of the curse.

Anyone have any advice or assistance for me?
* Registered users of the site do not see these ads.
RallyB is offline   Reply With Quote
Old 04-29-2013, 09:28 PM   #2
Dominic49
Scooby Newbie
 
Member#: 167881
Join Date: Dec 2007
Default

what did your mechanic say when you brought it back?
Dominic49 is offline   Reply With Quote
Old 04-29-2013, 10:27 PM   #3
RallyB
Scooby Newbie
 
Member#: 294247
Join Date: Sep 2011
Location: Pennsylvania
Vehicle:
2007 Impreza

Default

Havent brought it back yet, told him whats going on over the phone and got "I have no idea what it could be"
RallyB is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:41 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.