Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Vancouver Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Vancouver Impreza Club Forum -- VIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-07-2013, 05:10 PM   #1
coupe-a-loop
Scooby Newbie
 
Member#: 336028
Join Date: Oct 2012
Chapter/Region: VIC
Location: Scuurrvey BC
Vehicle:
1995 v2 sti type ra
Glacier White

Default v2 brake issues

Hey guys, after noticing strange uneven wear on my rotors in finally got around to checking out my brakes. I have a v2 so it has the 2 pot front 1 pot rear with vented rotors. I got new pads all around and 2 new front rotors. When removing the front caliper I checked my caliper and on both sides 1 piston is coming out slower than the other. I swapped out and oem used caliper off a turbo legacy and tried it out, same thing. So I'm thinking this is either a master cylinder problem, or that all 3 calipers are messed up and this is a normal occurence for these with age. Any thoughts? I don't really feel like fixing more then is needed at this point. Thanks.
* Registered users of the site do not see these ads.
coupe-a-loop is offline   Reply With Quote
Old 05-07-2013, 06:00 PM   #2
Zefy
Scooby Specialist
 
Member#: 105104
Join Date: Jan 2006
Chapter/Region: VIC
Location: Coquitlam, BC, Canada
Vehicle:
1979 BRAT / 01 RSTI
99 2.5TS (DEAD) / 87 GL

Default

i think that is actually normal operation for a 2 piston caliper... Either way, I have a pair you can try out if you want from an RS.

How are your caliper brackets? If the pins are stiff to move than that is a problem. They should be nice and smooth.
Zefy is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:22 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.