Welcome to the North American Subaru Impreza Owners Club Tuesday October 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-18-2013, 06:16 PM   #1
fourbyedude
Scooby Newbie
 
Member#: 362528
Join Date: Jul 2013
Location: Seattle
Vehicle:
91 Legacy
White

Default 91 legacy smokes

Hey I have a 91 legacy wagon with 2.2 non turbo and stick. Having a problem when I start the car in the morning it smokes out the tail pipe (blue smoke) for up to 5 minutes then it clears up and is fine. Trying to figure out if I need new heads or a hole motor or if it is something simple
* Registered users of the site do not see these ads.
fourbyedude is offline   Reply With Quote
Old 07-18-2013, 11:50 PM   #2
Cody1994
Scooby Newbie
 
Member#: 361637
Join Date: Jul 2013
Chapter/Region: MWSOC
Location: Milwaukee, Wisconsin
Vehicle:
1994 Legacy L
Winestone Pearl

Default

Not sure what your problem is, but it seems nobody else is helping. So I recommend checking this site out: http://legacycentral.org/

It's pertains to all first gen Legacys, somebody will definitely help you figure out your problem. They have helped me quite a bit over there.
Cody1994 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.