Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-05-2013, 03:20 PM   #1
Jonlegacy98
Scooby Newbie
 
Member#: 275412
Join Date: Feb 2011
Chapter/Region: MWSOC
Location: detroit
Vehicle:
1998 Legacy L
green

Have a Nice Day? ej 22 bog down

I have a98 subaru legacy 2.2
when i start it and hit the gas it bogs down. it says like this for about 10 minutes then seems good til i accelerate after a light.

FROM IDLE to GAS it bog down and i have to feather the pedal the get it out

tried cats, cam sens, maf, tps, knock sens, tranny fluid, sticky butterfly
* Registered users of the site do not see these ads.
Jonlegacy98 is offline   Reply With Quote
Old 06-08-2013, 06:02 PM   #2
LGT187
Scooby Newbie
 
Member#: 330956
Join Date: Sep 2012
Location: ME
Vehicle:
2005 legacy GT
Blue

Default

Fuel treatment?
LGT187 is offline   Reply With Quote
Old 07-08-2013, 09:10 PM   #3
Jonlegacy98
Scooby Newbie
 
Member#: 275412
Join Date: Feb 2011
Chapter/Region: MWSOC
Location: detroit
Vehicle:
1998 Legacy L
green

Default

took a minute to get back on. I am running 93 premium and doing gumout once a month. i seafoamed it in march tbc in april. it bogs down bad especially in rain. dealershipped it finally and they took 5 hours to tell me it was cats and my wipers messing up aerodynamics.
a local shop says its my journals or a bad rear main.
Jonlegacy98 is offline   Reply With Quote
Old 07-09-2013, 06:47 AM   #4
Jessekrs123
Scooby Specialist
 
Member#: 236927
Join Date: Jan 2010
Chapter/Region: NESIC
Location: Oakville CT
Vehicle:
1993 Legacy Sedan
1984 BRAT

Default

Quote:
Originally Posted by Jonlegacy98 View Post
took a minute to get back on. I am running 93 premium and doing gumout once a month. i seafoamed it in march tbc in april. it bogs down bad especially in rain. dealershipped it finally and they took 5 hours to tell me it was cats and my wipers messing up aerodynamics.
a local shop says its my journals or a bad rear main.
No, no, just no.

First off, shouldn't you be running 87 octane in this EJ22? Running a higher octane will do you nothing but be harder on your wallet and probably end up giving you poorer gas mileage than if you were just to run 87.

Journals or bad rear main? What? That might be the dumbest thing I've ever heard, only second to the wipers screwing up aerodynamics. None of which would cause your car to bog while taking off.

It is either spark or fuel related. Check the condition of your fuel filter, fuel pump, and the coil.

When was the last time you changed out plugs, wires, fuel filter, general maintenance crap? Any CELs? Seems like you wasted a bunch of time on random things for no reason whatsoever without investigating what could be the actual cause of the problem.
Jessekrs123 is offline   Reply With Quote
Old 07-15-2013, 01:58 AM   #5
SubieRSjustin
Scooby Specialist
 
Member#: 262254
Join Date: Oct 2010
Chapter/Region: Tri-State
Location: Central NJ
Vehicle:
2000 00rs/99 legacy
silver/ tan

Default

Aerodynamics of windshield wipers causing it to bog lol lol lol oh boy
SubieRSjustin is offline   Reply With Quote
Old 07-17-2013, 03:05 PM   #6
08legacy207
Scooby Newbie
 
Member#: 362577
Join Date: Jul 2013
Default

Your stealership mechanic needs an ear punch. Im not sure how you made it out the door without realizing he took you for a fool, but all I can say is WOW
08legacy207 is offline   Reply With Quote
Old 07-17-2013, 06:22 PM   #7
98legwag
Scooby Specialist
 
Member#: 160325
Join Date: Sep 2007
Chapter/Region: MAIC
Location: MD
Vehicle:
09 Legacy 3.0R
SWP

Default

I was going to say spark plugs, wires, coil, and fuel filter. All that has been said. My car bogged too. I changed all that over time and now it doesn't.
98legwag is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.