Welcome to the North American Subaru Impreza Owners Club Thursday April 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-26-2013, 02:20 PM   #26
RR
Scooby Specialist
 
Member#: 48191
Join Date: Nov 2003
Chapter/Region: NESIC
Location: Little Rhody
Vehicle:
2012 WRX
Ducati Monster

Default

I just got a new A/V panel bezel (66065SC130) and now the gaps on the sides are gone but i still have a quarter inch gap at the top, I assume everyone has this as the bezel opening is 4" top to bottom and the unit is roughly 3.75"?
* Registered users of the site do not see these ads.
RR is offline   Reply With Quote
Old 06-26-2013, 04:00 PM   #27
deanesn
Scooby Newbie
 
Member#: 260578
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Mundelein, IL
Vehicle:
2011 WRX Premium
WRB

Default

Quote:
Originally Posted by RR View Post
I just got a new A/V panel bezel (66065SC130) and now the gaps on the sides are gone but i still have a quarter inch gap at the top, I assume everyone has this as the bezel opening is 4" top to bottom and the unit is roughly 3.75"?
Yep. I don't notice it cuz everything is black but it's there.
deanesn is offline   Reply With Quote
Old 06-28-2013, 11:43 AM   #28
RR
Scooby Specialist
 
Member#: 48191
Join Date: Nov 2003
Chapter/Region: NESIC
Location: Little Rhody
Vehicle:
2012 WRX
Ducati Monster

Default

Update: I have the thing rooted now, I've installed a few apps including Sygic which does not appear to be much if any better then iGO. I also put a anti-glare screen protector last night which makes it a little better.

Unit would not turn on last night for about an hour, then all of a sudden started working again. That in combination with the radio reception still being subpar are still making me think about returning it.
RR is offline   Reply With Quote
Old 07-12-2013, 07:28 PM   #29
El Wray
Scooby Newbie
 
Member#: 303030
Join Date: Dec 2011
Chapter/Region: BAIC
Location: CA
Vehicle:
2009 STI
DGM

Default

Unika just came in, Smart came in on Wednesday. Hoping to knock out the install tomorrow. Had a couple of questions.

1. Metra 70-7552 isn't enough on the harness? I'll need additional leads? Nevermind. Remembered I had to add the extra leads when I installed my ASWC.
2. Any special bullet connectors/butt connectors I'll need? (Outside from those needed for the Smart<->Metra)

How long you all take on the install?

Last edited by El Wray; 07-12-2013 at 07:58 PM.
El Wray is offline   Reply With Quote
Old 07-13-2013, 02:07 PM   #30
deanesn
Scooby Newbie
 
Member#: 260578
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Mundelein, IL
Vehicle:
2011 WRX Premium
WRB

Default

I soldered my wired from smart to the harness. As far as unika I cut some of the extra cables and used those. You can find bullet connectors at radio shock but they are different size unless you want to replace them all.
deanesn is offline   Reply With Quote
Old 07-15-2013, 03:47 PM   #31
RR
Scooby Specialist
 
Member#: 48191
Join Date: Nov 2003
Chapter/Region: NESIC
Location: Little Rhody
Vehicle:
2012 WRX
Ducati Monster

Default

Same here, I soldered everything, that probably took 20-30 minutes? Install was a piece of cake after that, whole thing was done in under an hour.

I still have not gotten my unika working, I bought a second metra harness to harvest the pins but haven't figured out how best to free them yet.
RR is offline   Reply With Quote
Old 07-19-2013, 03:35 PM   #32
zamboniman87
Scooby Newbie
 
Member#: 279437
Join Date: Apr 2011
Vehicle:
2011 WRX 5-door

Default

Quote:
Originally Posted by RR View Post
Update: I just connected the blue parrot wire to the blue and white metra wire, radio works much better now.
I just installed the asteroid smart and have mine connected the same way, but my reception still isn't great. It's not absolutely terrible, but it's definitely worse than the alpine I just had installed but decided to return.
zamboniman87 is offline   Reply With Quote
Old 07-19-2013, 03:45 PM   #33
zamboniman87
Scooby Newbie
 
Member#: 279437
Join Date: Apr 2011
Vehicle:
2011 WRX 5-door

Default

Quote:
Originally Posted by El Wray View Post
Unika just came in, Smart came in on Wednesday. Hoping to knock out the install tomorrow. Had a couple of questions.

1. Metra 70-7552 isn't enough on the harness? I'll need additional leads? Nevermind. Remembered I had to add the extra leads when I installed my ASWC.
2. Any special bullet connectors/butt connectors I'll need? (Outside from those needed for the Smart<->Metra)

How long you all take on the install?
These are the crimp connectors I use and recommend. They allow the two wires to actually connect rather than relying on the crimp to conduct current.

http://www.amazon.com/gp/product/B005HQ4T6I/ref=as_li_ss_tl?ie=UTF8&camp=1789&creative=390957&creativeASIN=B005HQ4T6I&linkCode=as2&tag=graliv-20">Install Bay CC2218 Crimp Cap Nylon Connector 22/18 Gauge (100-Pack)</a><img src="http://ir-na.amazon-adsystem.com/e/ir?t=graliv-20&l=as2&o=1&a=B005HQ4T6Ihttp://www.amazon.com/gp/product/B005HQ4T6I/ref=as_li_ss_tl?ie=UTF8&camp=1789&creative=390957&creativeASIN=B005HQ4T6I&linkCode=as2&tag=graliv-20">Install Bay CC2218 Crimp Cap Nylon Connector 22/18 Gauge (100-Pack)</a><img src="http://ir-na.amazon-adsystem.com/e/ir?t=graliv-20&l=as2&o=1&a=B005HQ4T6I
zamboniman87 is offline   Reply With Quote
Old 08-02-2013, 05:28 PM   #34
S1RC
Scooby Newbie
 
Member#: 364150
Join Date: Aug 2013
Default

Quote:
Originally Posted by deanesn View Post
Also you need to hook up Unika with power so you will need to connect Unika to ACC and IGN power cables from your harness. The 4-pin small connector from Unika that goes in the back of Parrot has red cable that gets power from Parrot but the voltage is only 3.5V and it is not enough to power Unika.
I'm trying to get my Asteroid Smart + Unika working on my 2011 STI and I found your post. Very helpful, I was just wondering if you could clarify where you connected Accessory (pin 3) and Ignition (pin 13) to on the Unika harness?
S1RC is offline   Reply With Quote
Old 08-02-2013, 09:38 PM   #35
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by S1RC View Post
I'm trying to get my Asteroid Smart + Unika working on my 2011 STI and I found your post. Very helpful, I was just wondering if you could clarify where you connected Accessory (pin 3) and Ignition (pin 13) to on the Unika harness?
Subaru pin 13 is not ignition. It is one of the SWC wires (for the mode and phone/Bluetooth buttons in Imprezas and Foresters).

deanesn's post has a typo. The UNIKA connects to the car's +12V Accessory and +12V Battery leads (pins 3 and 20, respectively, on the Subaru 20-pin radio harness). The UNIKA and the Asteroid Smart do not use the car's +12V Ignition signal (the 3rd position of your ignition key, one click past ACC).
SVXdc is offline   Reply With Quote
Old 08-02-2013, 10:01 PM   #36
S1RC
Scooby Newbie
 
Member#: 364150
Join Date: Aug 2013
Default

SVXdc: Thank you for the clarification. I had already used pin 13 with my Unika harness so I was confused.

Do you know which wire(s) on the Unika harness I need to connect the car's +12V Accessory and +12V Battery leads?
S1RC is offline   Reply With Quote
Old 08-05-2013, 01:44 PM   #37
S1RC
Scooby Newbie
 
Member#: 364150
Join Date: Aug 2013
Default

Any clarification as to how I hook up the +12 Accessory and +12V Batter leads to the Unika? I tried putting them on V2 on the harness and the Asteroid Smart just locked up when trying to enable steering wheel controls. Plus no green light lit up on the Unika.
S1RC is offline   Reply With Quote
Old 08-05-2013, 07:35 PM   #38
deanesn
Scooby Newbie
 
Member#: 260578
Join Date: Oct 2010
Chapter/Region: MWSOC
Location: Mundelein, IL
Vehicle:
2011 WRX Premium
WRB

Default

Quote:
Originally Posted by S1RC View Post
Any clarification as to how I hook up the +12 Accessory and +12V Batter leads to the Unika? I tried putting them on V2 on the harness and the Asteroid Smart just locked up when trying to enable steering wheel controls. Plus no green light lit up on the Unika.
I connected the to the same v12 less that powers the factory radio so you power your smart and unika the same cable.
deanesn is offline   Reply With Quote
Old 08-05-2013, 10:23 PM   #39
S1RC
Scooby Newbie
 
Member#: 364150
Join Date: Aug 2013
Default

Thanks for the reply.

I still need some clarification. I'm not sure what lead/wire to connect the v12 to on the Unika harness. The diagrams don't list that, could you let me know?
S1RC is offline   Reply With Quote
Old 08-06-2013, 01:44 AM   #40
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default Information about the Asteroid Smart and UNIKA

More information about wiring the Asteroid Smart and UNIKA in a Subaru.

Quote:
The Asteroid Smart head unit comes with an ISO harness:

(click for larger image)
The smaller plug at the right (16-pin) plugs into the back of the HU. The connector at the left is a 16-pin ISO. The black object underneath the wires is an in-line fuse holder, on the HU's yellow power wire.

Note that there are two black wires. The larger-gauge wire connects straight through from the HU to the ISO connector. The second, with a smaller-gauge wire, is a "pigtail," terminated with an insulated female bullet connector.

Other wires on that harness:
  • RED -- +12V Accessory (key-switched)
  • YELLOW -- +12V Battery (constant-on, for memory)
  • LIGHT GREEN -- Parking brake input (with insulated male bullet connector)
  • ORANGE -- Reverse Gear input (with insulated male bullet connector)
  • BLUE -- Power antenna (+12V output)
  • PINK -- Illumination dimming (input)
  • (8 more wires for speakers, standard aftermarket colors)

All of the power wires also have male/female bullet connectors, allowing you to disconnect some or even swap pairs (sometimes necessary in ISO car installations).

Harnesses with Subaru-to-ISO connectors are commonly available in Europe and Australia but hard to find in the US. In any case, those adapters don't include SWC wires (and some cheaper ones may also omit one or more of the ground, illumination, and/or power antenna leads).

The rear of the HU (picture ) does not have a 3.5mm jack for the "wired remote input," as most other HU brands do. Instead, it has a 4-pin Molex socket (next to the Motorola antenna socket). Parrot's UNIKA is the only steering wheel module that will work with the Asteroid Smart (at least currently).

UNIKA module:

(click for larger images)
The UNIKA includes a harness with yet another set of ISO connectors. It's intended for you to plug in between a car-to-ISO adapter and the Asteroid Smart's ISO harness, to tap power and ground for the UNIKA:


(click for larger image)
(picture by mdkflip. A few more in his thread here)
The UNIKA's main harness plugs into the module itself (22 pin plug). It also has these other connectors/features:
  • 4-pin male Molex plug to connect to back of the Asteroid Smart HU
  • Wires to connect to car's SWC wires
  • 4-pin white plug for module's power and ground (connect to either of the UNIKA's other harnesses)
  • Fuse holder on its +12V Accessory power wire
This main harness includes a huge number of extra wires that you won't use (the ones labeled K-BUS, CAN high/low, and the group AUX 1-7). Picture:

(click for larger image)
The UNIKA includes yet another T-harness (with 24-pin male/female connectors, at bottom left of above picture), to permit plug-and-play installation with other Parrot Bluetooth kits. You won't use this one with the Asteroid Smart.

If you were to assemble all of their harnesses the way they intend, you would wind up with a ridiculous mass of connectors and wires behind your HU (possibly too much to cram in that space).

So your quickest/easiest solution (in my opinion) will be to cut the ISO connector off of the Asteroid Smart HU's harness. For the UNIKA, don't use their ISO adapter -- take the other harness with the male/female 24-pin connectors, cut off the leg with the white 4-pin plug, and make your connections to that leg (so you can leave the UNIKA's main harness intact). Then solder or crimp the Asteroid Smart's and UNIKA's wires directly to my 20-pin Subaru harness.

Beware! Parrot's ISO harnesses use some whacky (non-industry-standard) colors. Even some colors on the Asteroid Smart and UNIKA harnesses are different from each other. Do not blindly connect like colors to my harness! If you need assistance sorting this out, post your questions in this thread.

The UNIKA taps +12V Accessory (red wire on their harnesses) and ground (black wires). Both of those are standard aftermarket colors (same as on my 20-pin harness).

The UNIKA also takes +12V Battery (yellow wire on my harness, and confusingly ORANGE on the UNIKA's ISO harness), passes that into and back out of the module, and then sends that on to the HU via a separate wire. I don't know why they go through that trouble. I can't imagine that the UNIKA would ever need to interrupt that power -- I would think that would cause the HU to loose its memory and clock.

Instead, you can simply connect the car's +12V Battery power (yellow wire on my harness, Subaru pin #20) to the HU's yellow and also to the UNIKA's red/yellow wire. If you had used the UNIKA's ISO harness, that is the wire that connects from the car's +12V Battery power to the UNIKA module.

The UNIKA's blue/yellow wire is the one that goes from the module out to the HU. You can insulate the end of this wire.

On the Asteroid Smart's harness, use the larger-gauge black wire for ground. The smaller gauge black wire (with the insulated female bullet connector) you can connect to their parking brake lead (which conveniently has a male bullet connector).

The Asteroid Smart's wires for +12V Accessory (red) and +12V Battery (yellow) are the standard aftermarket colors. Connect these to the same colors on my 20-pin harness.

For the SWC wires, connect:
  • UNIKA's V1 to my BROWN/RED (Subaru pin #4)
  • UNIKA's Aux1 to my BROWN/BLUE (Subaru pin #13) [only Imprezas and Foresters with the phone/Bluetooth buttons]
  • UNIKA's ground (in the bundle with its V1/V2 wires) to my BROWN/BLACK (Subaru pin #14)
Do not use any of the UNIKA's other wires (K-Bus, CAN, Aux2-7). Make sure the ends of all of those are individually insulated (so they can't contact any other wires or metal).

Last edited by SVXdc; 08-06-2013 at 11:33 PM.
SVXdc is offline   Reply With Quote
Old 08-06-2013, 12:38 PM   #41
El Wray
Scooby Newbie
 
Member#: 303030
Join Date: Dec 2011
Chapter/Region: BAIC
Location: CA
Vehicle:
2009 STI
DGM

Default

Awesome post SVXdc! Wife/work has had me too buried to actually devote time to figuring out that mess. I was hoping to have everything soldered/bundled nicely on my table before I even got to the car. Definitely arms me with ample info and will help clean up the current mess hiding in the dash.

I'm currently using two external amps and it looks like the only wires I actually need to connect to the Asteroid Smart are:
+12V ACC
+12V Batt
Ground
Remote (Amp turn-on)

Question - Do you have any pics of this?:
Quote:
So your quickest/easiest solution (in my opinion) will be to cut the ISO connector off of the Asteroid Smart HU's harness. For the UNIKA, don't use their ISO adapter -- take the other harness with the male/female 24-pin connectors, cut off the leg with the white 4-pin plug, and make your connections to that leg (so you can leave the UNIKA's main harness intact). Then solder or crimp the Asteroid Smart's and UNIKA's wires directly to my 20-pin Subaru harness.
El Wray is offline   Reply With Quote
Old 08-06-2013, 02:01 PM   #42
S1RC
Scooby Newbie
 
Member#: 364150
Join Date: Aug 2013
Default

Quote:
Originally Posted by El Wray View Post
Awesome post SVXdc!
+1!

Thanks for that post! I was able to sort everything out, Unika is working for my SWC now.
S1RC is offline   Reply With Quote
Old 08-31-2013, 09:19 AM   #43
kevin85193
Scooby Specialist
 
Member#: 145900
Join Date: Apr 2007
Chapter/Region: Tri-State
Location: east brunswick, nj
Vehicle:
2003 16gxt wagon
silver

Default

any updates :0
kevin85193 is online now   Reply With Quote
Old 09-08-2013, 07:02 PM   #44
El Wray
Scooby Newbie
 
Member#: 303030
Join Date: Dec 2011
Chapter/Region: BAIC
Location: CA
Vehicle:
2009 STI
DGM

Default

So.. What did you all do to permanently mount the mic? The sticker lasted all of 2 days in the California sun. I can't seem to tuck the movable plastic piece in a way that won't vibrate loose and leave the mic hanging near my mirror.
El Wray is offline   Reply With Quote
Old 09-20-2013, 04:02 PM   #45
breakthestatic
Scooby Newbie
 
Member#: 310683
Join Date: Feb 2012
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2011 WRX
Dark Grey Metallic

Default

Does anyone know how to contact SVXdc? I need one of his wiring harnesses to finish up my Asteroid Smart install, but haven't received a response to my email "order" yet. I don't want to pester, but I have everything else ready for the install except the proper harness with the extra swc pins. If anyone knows the best way to get one of these harnesses, asap it would be a huge help!
breakthestatic is offline   Reply With Quote
Old 10-19-2013, 03:37 AM   #46
El Wray
Scooby Newbie
 
Member#: 303030
Join Date: Dec 2011
Chapter/Region: BAIC
Location: CA
Vehicle:
2009 STI
DGM

Default

Fixed the mic a while back. First, the adhesive on the flat thing didn't hold for more than 2 days. Second, I tried the clip but that wasn't really working for me either.

My fix:
1. Peel off the worthless adhesive, apply it to the ball area so the mic actually stays in there. (it practically falls out on it's own due to gravity.)

2. Apply some industrial double-sided tape to the backing.
El Wray is offline   Reply With Quote
Old 11-11-2013, 11:55 AM   #47
TomiT
Scooby Newbie
 
Member#: 163135
Join Date: Oct 2007
Chapter/Region: International
Location: Finland
Vehicle:
2008 WRX STi 2008
Red

Default

How about latest Subarus with 24pin connectors?? Any diagrams to UNIKA/ 24pin connector and how about the four Dip switches??

I have MY08 STi with OEM Kenwood navi ( Using 24pin connector )
and I have swapped player to Asteroid Smart, I love the Asteroid but I like to use those steering wheel buttons as well...

Looks like 24pin connector 3 Brown and 15 Yellow goes to Steering wheel modulle.
TomiT is offline   Reply With Quote
Old 11-11-2013, 12:45 PM   #48
TomiT
Scooby Newbie
 
Member#: 163135
Join Date: Oct 2007
Chapter/Region: International
Location: Finland
Vehicle:
2008 WRX STi 2008
Red

Default

OK, more info, the CAP must be installed, othervice Asteroid does not found UNIKA. Now Asteroid found UNIKA and Steering wheel option could be enable or disabled.

Now I only have to find correct button wiring UNIKA/24pin Subaru harness.

Last edited by TomiT; 11-11-2013 at 01:34 PM.
TomiT is offline   Reply With Quote
Old 11-12-2013, 12:10 AM   #49
SVXdc
Scooby Specialist
 
Member#: 25837
Join Date: Oct 2002
Chapter/Region: South East
Location: Atlanta, GA
Vehicle:
1996 SVX L AWD
Laguna Blue Pearl

Default

Quote:
Originally Posted by TomiT View Post
How about latest Subarus with 24pin connectors?? Any diagrams to UNIKA/ 24pin connector and how about the four Dip switches??

I have MY08 STi with OEM Kenwood navi ( Using 24pin connector )
...
The SWCs in Imprezas and Foresters with the OEM Kenwood Navi are electrically identical to those cars that have the non-nav HU without Bluetooth, except that the SWC wires connect to the HU on that secondary 24-pin harness. Connections to the UNIKA are the same as in the 2nd diagram "deanesn" posted above.

I can make a 24-pin harness that connects to the factory plug, so you won't have to hack into your factory wires. E-mail me for details.

Quote:
Originally Posted by TomiT View Post
OK, more info, the CAP must be installed, [otherwise] Asteroid does not found UNIKA. Now Asteroid found UNIKA and Steering wheel option could be enable or disabled.
What do you mean by "CAP"?
SVXdc is offline   Reply With Quote
Old 11-12-2013, 12:54 AM   #50
TomiT
Scooby Newbie
 
Member#: 163135
Join Date: Oct 2007
Chapter/Region: International
Location: Finland
Vehicle:
2008 WRX STi 2008
Red

Default

I got the right connector/harness ( Thanks David Carter ) but SWC do not work?? Well... when I hook up the 24pin connector Parrot volume runs to "0", If I turn volume up from display the bar runs back to zero ("0")??
I have measured all SWC button ohms and ohms are just OK!

David SWC 24pin connector got two wiring Pin3 and Pin15. Is it possible that I have wrong UNIKA or UNIKA harness??

UNIKA: PI090020AG3G022951 UNIKA for MKi/RKi series
Harness: CBL038UNPR50 03/07/2013

UNIKA Dips 1 : on 2,3,4 : off ( UNIKA led is green )

Before I hook the connector to the UNIKA led is Green, When I hook the connector the led turns Orange. (Parrot also find the UNIKA and I can Update it too via Parrot)

My car is WRX STI MY08 Euro/UK version. OEM Radio is Kenwood FXDD07EF2

Last edited by TomiT; 12-12-2013 at 10:37 AM.
TomiT is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.