Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-13-2013, 06:59 PM   #1
precisely3
Scooby Newbie
 
Member#: 355824
Join Date: May 2013
Chapter/Region: NESIC
Location: Conecticut
Vehicle:
2002 Impreza OBS
Silver

Angry Previous owner cut factory harness...

So I decided to look behind the crummy Sony Xplod head unit that's in my OBS and figure out if I needed to buy a harness to install my head unit, or if there was already one in there.

Well, surprise surprise, whoever installed it cut the factory harness and spliced directly into that from the head unit. Ugh.

Should I pick up a factory harness, reattach that, then attach my stereo to an adapter harness for the install? I'm assuming yes, but I'm just looking for someone to tell me yes/maybe play devil's advocate and provide reasons why I may want to stick with the botch job.
* Registered users of the site do not see these ads.
precisely3 is offline   Reply With Quote
Old 05-13-2013, 07:24 PM   #2
Guzzi 1
Scooby Newbie
 
Member#: 338666
Join Date: Nov 2012
Chapter/Region: MWSOC
Location: Northeast Ohio
Vehicle:
2013 Impreza Premium
Dark Grey Metalic CVT

Default

Depending on how much would need to be replaced, that could be a boatload of work. If it were me, I would get the proper end from sVXdc who posts here on this board and put the factory connector back on the end of the wire. I would suggest doing a good solder job with shrink wrap. Then, moving forward from there, use his plugs to adapt whatever you desire from there.

Here: http://ae64.com/

Many here, including myself have purchased connectors from David. I would highly recommend his services.

John
Guzzi 1 is offline   Reply With Quote
Old 05-14-2013, 08:05 AM   #3
precisely3
Scooby Newbie
 
Member#: 355824
Join Date: May 2013
Chapter/Region: NESIC
Location: Conecticut
Vehicle:
2002 Impreza OBS
Silver

Default

Yeah, I figured it would just be easier to get the harness in the dash all set back to normal first, so I know for sure that it would just be plug-and-play.

I wasn't aware that ae64 was a NASIOC member-run site, otherwise I would have ordered from there. I instead picked up a Scosche reverse harness at Best Buy for like $12 :-/

I kinda feel bad now, but if I need anything else in the future I'll be sure to support the community

Thanks for the reply!
precisely3 is offline   Reply With Quote
Old 05-14-2013, 09:44 AM   #4
luan87us
Scooby Specialist
 
Member#: 335013
Join Date: Oct 2012
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2013 Premium WRX 5dr
WRB

Default

Yeah you can just buy the reverse harness and splice it back into the current OEM harness. Then just get a forward harness if you need to install another aftermarket Hu.
luan87us is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.