Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Interior & Exterior Modification

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-13-2014, 10:26 PM   #51
blkstar15
Scooby Newbie
 
Member#: 363892
Join Date: Jul 2013
Chapter/Region: BAIC
Location: San Mateo Area
Vehicle:
2013 WRX Hatch Prem
SWP

Default

Quote:
Originally Posted by dwong View Post
Just got my order today and was surprised to find the wire connectors are actually included!

Anyone know what the included "felt" strip with the adhesive backing is used for?
^this

Just got mine today as well as was wondering about the felt strip?? What are these used for?
* Registered users of the site do not see these ads.
blkstar15 is offline   Reply With Quote
Old 01-13-2014, 11:47 PM   #52
Teedub21
Scooby Newbie
 
Member#: 333099
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Vancouver, WA
Vehicle:
2013 WRX STi
ISM

Default

Funny, mine came today too! Insanely fast shipping. My question for you guys that have done this already, how do you get the factory reflectors out? I haven't tried yet, but will it be obvious?
Teedub21 is offline   Reply With Quote
Old 01-13-2014, 11:52 PM   #53
MikeMiranda
Scooby Newbie
 
Member#: 355937
Join Date: May 2013
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2010 Impreza OBS
Black on Black

Default

Quote:
Originally Posted by Teedub21 View Post
Funny, mine came today too! Insanely fast shipping. My question for you guys that have done this already, how do you get the factory reflectors out? I haven't tried yet, but will it be obvious?
Push tabs in an push reflector out
MikeMiranda is offline   Reply With Quote
Old 01-16-2014, 07:23 PM   #54
yanj88
Scooby Newbie
 
Member#: 290520
Join Date: Aug 2011
Chapter/Region: Tri-State
Location: queens ny
Vehicle:
2011 wrx 5 door
wrb

Default

just got it today installed in about 30 mins during work time. very easy to install based on the picture provided on page 1. So here are some tips that may help you speed up the process.
that what you get from the kit on ebay. It comes with everything you need for installation. I went to get the wires and wire splitter thinking it didn't come with it.
some were asking how you take the reflectors off well just go behind the bumper and push the tap toward each other and pop it out.
So i took the two screws off the tail lights and slide it towards myself. I used a wire hanger and taped the wire and pulled it up because my hands was def. too big to fit in that area.
I unplugged the lights so i can sit in my trunk to play with the wire.
I plugged blue with green and used a plier to flatten the metal piece of the wire tab.
plug in red with red and finally black with black.
turned on the car to see if it was working correctly and it did.
same process with the other side.

sorry for the slanted pic of the finish product
yanj88 is offline   Reply With Quote
Old 01-17-2014, 01:23 AM   #55
blkstar15
Scooby Newbie
 
Member#: 363892
Join Date: Jul 2013
Chapter/Region: BAIC
Location: San Mateo Area
Vehicle:
2013 WRX Hatch Prem
SWP

Default

Quote:
Originally Posted by yanj88 View Post
just got it today installed in about 30 mins during work time. very easy to install based on the picture provided on page 1. So here are some tips that may help you speed up the process.
that what you get from the kit on ebay. It comes with everything you need for installation. I went to get the wires and wire splitter thinking it didn't come with it.
some were asking how you take the reflectors off well just go behind the bumper and push the tap toward each other and pop it out.
So i took the two screws off the tail lights and slide it towards myself. I used a wire hanger and taped the wire and pulled it up because my hands was def. too big to fit in that area.
I unplugged the lights so i can sit in my trunk to play with the wire.
I plugged blue with green and used a plier to flatten the metal piece of the wire tab.
plug in red with red and finally black with black.
turned on the car to see if it was working correctly and it did.
same process with the other side.

sorry for the slanted pic of the finish product

are the wires long enough to reach the brake light?
blkstar15 is offline   Reply With Quote
Old 01-17-2014, 04:32 AM   #56
yanj88
Scooby Newbie
 
Member#: 290520
Join Date: Aug 2011
Chapter/Region: Tri-State
Location: queens ny
Vehicle:
2011 wrx 5 door
wrb

Default

Quote:
Originally Posted by blkstar15 View Post
are the wires long enough to reach the brake light?
Yes they are.
yanj88 is offline   Reply With Quote
Old 01-18-2014, 12:18 AM   #57
blkstar15
Scooby Newbie
 
Member#: 363892
Join Date: Jul 2013
Chapter/Region: BAIC
Location: San Mateo Area
Vehicle:
2013 WRX Hatch Prem
SWP

Default

Quote:
Originally Posted by yanj88 View Post
Yes they are.
awesome thanks!!
blkstar15 is offline   Reply With Quote
Old 01-18-2014, 10:27 PM   #58
blkstar15
Scooby Newbie
 
Member#: 363892
Join Date: Jul 2013
Chapter/Region: BAIC
Location: San Mateo Area
Vehicle:
2013 WRX Hatch Prem
SWP

Default

Just finished installing. It really does take about 30 min or less. I just want to mention that for the price this is a well worth it DIY mod. The quality of the pieces are outstanding.
blkstar15 is offline   Reply With Quote
Old 01-22-2014, 06:44 PM   #59
TravTagz
Scooby Newbie
 
Member#: 326310
Join Date: Jul 2012
Chapter/Region: Tri-State
Location: Central, NJ
Vehicle:
2012 WRX Premium
OBP

Default

Did you guys get a taking number when ordering it from ebay?
TravTagz is offline   Reply With Quote
Old 01-22-2014, 07:08 PM   #60
jdp9807
Scooby Newbie
 
Member#: 367167
Join Date: Sep 2013
Chapter/Region: MAIC
Location: Tunkhannock, P.A.
Vehicle:
2010 Impreza OBS
Silver

Default

Just ordered mine from eBay on Tuesday..... No tracking number yet.
jdp9807 is online now   Reply With Quote
Old 01-22-2014, 08:11 PM   #61
MikeMiranda
Scooby Newbie
 
Member#: 355937
Join Date: May 2013
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2010 Impreza OBS
Black on Black

Default

Quote:
Originally Posted by jdp9807 View Post
Just ordered mine from eBay on Tuesday..... No tracking number yet.
I think it took a day or so
MikeMiranda is offline   Reply With Quote
Old 01-22-2014, 08:18 PM   #62
TravTagz
Scooby Newbie
 
Member#: 326310
Join Date: Jul 2012
Chapter/Region: Tri-State
Location: Central, NJ
Vehicle:
2012 WRX Premium
OBP

Default

Only ask because I orders mine Saturday and haven't got any emails from seller or update on eBay
TravTagz is offline   Reply With Quote
Old 01-22-2014, 09:17 PM   #63
danbudzenski
Scooby Newbie
 
Member#: 347547
Join Date: Feb 2013
Chapter/Region: MAIC
Location: Lexington Park, MD
Vehicle:
2013 STI
WR Blue

Default

It took a couple days for my tracking number to show up. Though I never did get it to work right to actually track the package.

Mine finally arrived yesterday, hopefully install this weekend.
danbudzenski is offline   Reply With Quote
Old 01-22-2014, 10:44 PM   #64
blkstar15
Scooby Newbie
 
Member#: 363892
Join Date: Jul 2013
Chapter/Region: BAIC
Location: San Mateo Area
Vehicle:
2013 WRX Hatch Prem
SWP

Default

The only thing that shows up is an international tracking info. THe package usually takes a week and a half
blkstar15 is offline   Reply With Quote
Old 01-27-2014, 11:19 PM   #65
Teedub21
Scooby Newbie
 
Member#: 333099
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Vancouver, WA
Vehicle:
2013 WRX STi
ISM

Default

Installed mine today! As others have posted it took all of 30 minutes to do and they look great! The fit and finish of the lights is as good as OEM except these light up!
Teedub21 is offline   Reply With Quote
Old 01-28-2014, 09:49 AM   #66
motown
Scooby Newbie
 
Member#: 308483
Join Date: Jan 2012
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2013 WRX SWP HATCH
RIP 2011 WRX-SANDY VICTIM

Default

Quote:
Originally Posted by Teedub21 View Post
Installed mine today! As others have posted it took all of 30 minutes to do and they look great! The fit and finish of the lights is as good as OEM except these light up!
did you hook them up to just running lights or brake lights as well?
motown is offline   Reply With Quote
Old 01-28-2014, 10:37 AM   #67
Teedub21
Scooby Newbie
 
Member#: 333099
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Vancouver, WA
Vehicle:
2013 WRX STi
ISM

Default

Quote:
Originally Posted by motown View Post
did you hook them up to just running lights or brake lights as well?
hooked them up how the online directions show. Pretty sure they are running lights and brake.
Teedub21 is offline   Reply With Quote
Old 01-28-2014, 12:00 PM   #68
Teedub21
Scooby Newbie
 
Member#: 333099
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Vancouver, WA
Vehicle:
2013 WRX STi
ISM

Default

Which color wire activates the brake lights? Apparently one of my quick taps (hate those things) must not have made contact because my driver's side light isn't coming on with the brake lights but the passenger side is.
Teedub21 is offline   Reply With Quote
Old 01-29-2014, 01:17 PM   #69
Trustkevin13
Scooby Specialist
 
Member#: 259184
Join Date: Sep 2010
Chapter/Region: MWSOC
Location: Kansas
Vehicle:
2008 Subaru WRX
Silver

Default

^^^ Red and brown. Not sure what wires if you attach them on the brake lights themselves. Red and red maybe?
Trustkevin13 is online now   Reply With Quote
Old 01-29-2014, 01:26 PM   #70
MikeMiranda
Scooby Newbie
 
Member#: 355937
Join Date: May 2013
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2010 Impreza OBS
Black on Black

Default

Quote:
Originally Posted by Teedub21 View Post
Which color wire activates the brake lights? Apparently one of my quick taps (hate those things) must not have made contact because my driver's side light isn't coming on with the brake lights but the passenger side is.


red wire brake positive
Black ground
Blue to green running Light
MikeMiranda is offline   Reply With Quote
Old 01-29-2014, 03:20 PM   #71
Teedub21
Scooby Newbie
 
Member#: 333099
Join Date: Sep 2012
Chapter/Region: NWIC
Location: Vancouver, WA
Vehicle:
2013 WRX STi
ISM

Default

Yeah, red. Got it sorted last night. Just had to squash the wire tap a little more. The wires on the lights were installing are pretty thin so you have to make sure the taps make contact with them.
Teedub21 is offline   Reply With Quote
Old 01-29-2014, 03:27 PM   #72
GSXpress
Scooby Newbie
 
Member#: 95825
Join Date: Sep 2005
Chapter/Region: MAIC
Location: NoVA
Vehicle:
2011 WRX Hatch
SWP

Default

Just ordered after reading this thread. Got an estimate delivery date of Thursday, Feb 20, 2014 - Wednesday, Mar 19, 2014.

Now the waiting game.
GSXpress is offline   Reply With Quote
Old 01-29-2014, 03:50 PM   #73
TravTagz
Scooby Newbie
 
Member#: 326310
Join Date: Jul 2012
Chapter/Region: Tri-State
Location: Central, NJ
Vehicle:
2012 WRX Premium
OBP

Default

Ordered mine on the 18th have been checking my mail everyday since
TravTagz is offline   Reply With Quote
Old 01-29-2014, 04:20 PM   #74
blaze741
Scooby Newbie
 
Member#: 224564
Join Date: Sep 2009
Chapter/Region: NESIC
Location: Merrimack, NH
Vehicle:
2014 WRX 5-Door
Crystal Black Silica

Default

I ordered the 18th as well. Shipped the 26th. Expect it about 1.5 weeks I'd think coming from overseas.
blaze741 is offline   Reply With Quote
Old 01-29-2014, 05:08 PM   #75
MikeMiranda
Scooby Newbie
 
Member#: 355937
Join Date: May 2013
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2010 Impreza OBS
Black on Black

Default

I noticed mine had spent a week or so in customs
MikeMiranda is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:02 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.