Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-21-2013, 03:00 PM   #1
veel86
Scooby Specialist
 
Member#: 308550
Join Date: Jan 2012
Chapter/Region: MWSOC
Location: South West Michigan
Vehicle:
2006 Wrx STi
Aspen White

Default Bad ring land?

So I'm having high knock as much as -12 FBKC at low load cruising speeds. It is very random and shows different knock values. The car isn't smoking anywhere and I don't have a low oil issue. I'm going to do a compression test tonight and I will report back with the results. Has anyone had a similar problem to mine? And what did you do to fix it?
Thank you
Rob
* Registered users of the site do not see these ads.
veel86 is offline   Reply With Quote
Old 05-21-2013, 04:55 PM   #2
danny_d19
Scooby Specialist
 
Member#: 180748
Join Date: May 2008
Chapter/Region: VIC
Location: BC
Vehicle:
2005 STi
CGM

Default

could just be a rattle in the engine bay causing false knock readings.
danny_d19 is offline   Reply With Quote
Old 05-21-2013, 05:03 PM   #3
Cathexis
Scooby Specialist
 
Member#: 335445
Join Date: Oct 2012
Chapter/Region: MAIC
Location: Ashland, VA
Vehicle:
2012 WRX - BLK STIG
Stg. 2 - 287whp/317wtq.

Default

I had one was -11.xx, but was told just a hiccup from the ecu, it also had no correction afyer it, just went straight to 0 on the next line. Does yours do this or does it "unlearn" the knock incrementally back to 0?
Cathexis is online now   Reply With Quote
Old 05-21-2013, 05:56 PM   #4
Sypher
Scooby Specialist
 
Member#: 106366
Join Date: Jan 2006
Chapter/Region: MAIC
Location: VA
Vehicle:
2006 WRX
Blue

Default

Pull your battery terminal and reset the "ram" in the ecu then drive it around and log.
Sypher is offline   Reply With Quote
Old 05-21-2013, 07:04 PM   #5
trev762
Scooby Specialist
 
Member#: 280572
Join Date: Apr 2011
Chapter/Region: E. Canada
Location: southern ontario canada
Vehicle:
2011 sti sedan
plasma blue pearl

Default

Forget the compression test it is only false knock.
U need to search and read how to data log your suby. Any thing under 4000rpm forget it but anything above then be concerned but learn how to data log first!!!
trev762 is offline   Reply With Quote
Old 05-21-2013, 07:05 PM   #6
veel86
Scooby Specialist
 
Member#: 308550
Join Date: Jan 2012
Chapter/Region: MWSOC
Location: South West Michigan
Vehicle:
2006 Wrx STi
Aspen White

Default

Mine has went straight to -12 or high knock numbers and sometimes it goes up and down slowly. I just did a compression test.
Cylinder #
1. 143
2. 145
3. 142
4. 145
veel86 is offline   Reply With Quote
Old 05-21-2013, 07:16 PM   #7
trev762
Scooby Specialist
 
Member#: 280572
Join Date: Apr 2011
Chapter/Region: E. Canada
Location: southern ontario canada
Vehicle:
2011 sti sedan
plasma blue pearl

Default

Quote:
Originally Posted by Sypher View Post
Pull your battery terminal and reset the "ram" in the ecu then drive it around and log.
Absolutely do not do this/
trev762 is offline   Reply With Quote
Old 05-21-2013, 07:18 PM   #8
trev762
Scooby Specialist
 
Member#: 280572
Join Date: Apr 2011
Chapter/Region: E. Canada
Location: southern ontario canada
Vehicle:
2011 sti sedan
plasma blue pearl

Default

Quote:
Originally Posted by danny_d19 View Post
could just be a rattle in the engine bay causing false knock readings.
^^^
This as in drivetrain vibrations and what not.....etc
trev762 is offline   Reply With Quote
Old 05-21-2013, 07:22 PM   #9
veel86
Scooby Specialist
 
Member#: 308550
Join Date: Jan 2012
Chapter/Region: MWSOC
Location: South West Michigan
Vehicle:
2006 Wrx STi
Aspen White

Default

Alright ill just have to take a close look at everything.
veel86 is offline   Reply With Quote
Old 05-21-2013, 07:33 PM   #10
trev762
Scooby Specialist
 
Member#: 280572
Join Date: Apr 2011
Chapter/Region: E. Canada
Location: southern ontario canada
Vehicle:
2011 sti sedan
plasma blue pearl

Default

Quote:
Originally Posted by veel86 View Post
Alright ill just have to take a close look at everything.
All right I'm in a good mood!!
Just before u go to data log for a wrx will be 3rd gear, sti will be 4th gear. When u get to 2,500rpm start data logging "wot" to almost redline then immediately stop data logging. Try to do it on flat road and safe area.

U only need to data log your default parameters.

So u know for next time u should of posted in engine management & tuning for better results.
trev762 is offline   Reply With Quote
Old 05-21-2013, 07:54 PM   #11
veel86
Scooby Specialist
 
Member#: 308550
Join Date: Jan 2012
Chapter/Region: MWSOC
Location: South West Michigan
Vehicle:
2006 Wrx STi
Aspen White

Default

Right I guess I can do another log. It doesn't knock though.
veel86 is offline   Reply With Quote
Old 05-21-2013, 08:09 PM   #12
trev762
Scooby Specialist
 
Member#: 280572
Join Date: Apr 2011
Chapter/Region: E. Canada
Location: southern ontario canada
Vehicle:
2011 sti sedan
plasma blue pearl

Default

Quote:
Originally Posted by veel86 View Post
Right I guess I can do another log. It doesn't knock though.
Once u do look at your fbk and fkc, if u don't see any of this between 4,000-7,000 rpm u r good and also have a look at how much boost just in case u need to switch to either lwg or hwg map.

Last edited by trev762; 05-21-2013 at 08:30 PM.
trev762 is offline   Reply With Quote
Old 06-01-2013, 09:09 AM   #13
veel86
Scooby Specialist
 
Member#: 308550
Join Date: Jan 2012
Chapter/Region: MWSOC
Location: South West Michigan
Vehicle:
2006 Wrx STi
Aspen White

Default

Right I understand that. What I don't understand is about a week about I was at the track and my car would pick up FBKC when I was between shifts or right after I shifted and was back on the throttle. But I did a log yesterday of 2-4 and I got no FBKC at all. I'm just very confused as to where it is coming from. I will post the logs as soon as I can.
Thank you
veel86 is offline   Reply With Quote
Old 06-01-2013, 10:07 AM   #14
trev762
Scooby Specialist
 
Member#: 280572
Join Date: Apr 2011
Chapter/Region: E. Canada
Location: southern ontario canada
Vehicle:
2011 sti sedan
plasma blue pearl

Default

Quote:
Originally Posted by veel86 View Post
Right I understand that. What I don't understand is about a week about I was at the track and my car would pick up FBKC when I was between shifts or right after I shifted and was back on the throttle. But I did a log yesterday of 2-4 and I got no FBKC at all. I'm just very confused as to where it is coming from. I will post the logs as soon as I can.
Thank you
Huh/

Its quite obvious u don't understand like I've already said forget looking at fbk or anything else until u do a proper log as anything else will be only false knock/
trev762 is offline   Reply With Quote
Old 06-01-2013, 10:32 AM   #15
veel86
Scooby Specialist
 
Member#: 308550
Join Date: Jan 2012
Chapter/Region: MWSOC
Location: South West Michigan
Vehicle:
2006 Wrx STi
Aspen White

Default

I all ready did a 3rd gear pull from 2000 rpm and everything was fine.
veel86 is offline   Reply With Quote
Old 06-01-2013, 10:59 AM   #16
moonrider_99
Scooby Specialist
 
Member#: 258628
Join Date: Sep 2010
Chapter/Region: Tri-State
Location: PA
Vehicle:
2009 WRX stg2-SOLD
2012 MS3

Default

Quote:
Originally Posted by veel86 View Post
I all ready did a 3rd gear pull from 2000 rpm and everything was fine.
Post the log.
moonrider_99 is offline   Reply With Quote
Old 06-01-2013, 03:47 PM   #17
veel86
Scooby Specialist
 
Member#: 308550
Join Date: Jan 2012
Chapter/Region: MWSOC
Location: South West Michigan
Vehicle:
2006 Wrx STi
Aspen White

Default

https://docs.google.com/spreadsheet/...3c&usp=sharing

I am aware of the over boost. This is the ACN91 stage 2 cobb tune. I will be switching back to the stage 2 lwg 93 map.
veel86 is offline   Reply With Quote
Old 06-01-2013, 04:22 PM   #18
trev762
Scooby Specialist
 
Member#: 280572
Join Date: Apr 2011
Chapter/Region: E. Canada
Location: southern ontario canada
Vehicle:
2011 sti sedan
plasma blue pearl

Default

Quote:
Originally Posted by veel86 View Post
https://docs.google.com/spreadsheet/...3c&usp=sharing

I am aware of the over boost. This is the ACN91 stage 2 cobb tune. I will be switching back to the stage 2 lwg 93 map.
Everything looks good and u r not overboosting its a little boost spike until the wg is regulating boost. If u start to throw p0244 overboost cel then change to the lwg map.
trev762 is offline   Reply With Quote
Old 06-01-2013, 04:26 PM   #19
veel86
Scooby Specialist
 
Member#: 308550
Join Date: Jan 2012
Chapter/Region: MWSOC
Location: South West Michigan
Vehicle:
2006 Wrx STi
Aspen White

Default

Oh okay thank you
veel86 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:32 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.