Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-14-2013, 12:09 PM   #1
Subilover06
Scooby Newbie
 
Member#: 344208
Join Date: Jan 2013
Chapter/Region: South East
Location: Savannah ga
Vehicle:
2006 Wrx limited
Steel grey

Default clutch issue

so here is the issue and I really need some help I have an 06 wrx limited I replaced the clutch about 10000 miles ago with an exedy stage 1 and yesterday when I was driving the car the pedal got soft usually the pedal is very stiff so it got soft and start repeatedly popping on my foot when I would push it in so today I started to bleed it and I got a lot of air and then nothing now I have no pressure in the pedal and I cant get air or fluid out of the line
* Registered users of the site do not see these ads.
Subilover06 is offline   Reply With Quote
Old 06-15-2013, 12:52 AM   #2
cameronxt
Scooby Newbie
 
Member#: 305971
Join Date: Jan 2012
Chapter/Region: MWSOC
Location: Wichita, KS
Vehicle:
2004 WRX STi
Wold Rally Blue

Default

Your master or slave cylinder or possibly your clutch line (the soft one) has a leak that is letting it suck in air and not let it build pressure. Once youve figured out which is your problem, i had to keep bleeding mine through several cyles after i was not getting anymore out of the hose before it started to build presure
cameronxt is offline   Reply With Quote
Old 06-15-2013, 10:26 PM   #3
DTJ01Dan
Scooby Newbie
 
Member#: 359581
Join Date: Jun 2013
Chapter/Region: MWSOC
Location: Chicago Land area
Vehicle:
2008 Subaru WRX
Black

Default Same issue

Quote:
Originally Posted by Subilover06 View Post
so here is the issue and I really need some help I have an 06 wrx limited I replaced the clutch about 10000 miles ago with an exedy stage 1 and yesterday when I was driving the car the pedal got soft usually the pedal is very stiff so it got soft and start repeatedly popping on my foot when I would push it in so today I started to bleed it and I got a lot of air and then nothing now I have no pressure in the pedal and I cant get air or fluid out of the line
I have an 08 wrx and i have the same problem so i went to bleed the slave cylinder and the master cylinder and had some air in the lines. But my clutch is still very soft and when i drive and get up to about 3500 RPM it slips into neutral, Im guessing i have a bad master cylinder because i don't have any leaks.
DTJ01Dan is offline   Reply With Quote
Old 06-19-2013, 11:47 PM   #4
Subilover06
Scooby Newbie
 
Member#: 344208
Join Date: Jan 2013
Chapter/Region: South East
Location: Savannah ga
Vehicle:
2006 Wrx limited
Steel grey

Default

Bump!!!!!!
Subilover06 is offline   Reply With Quote
Old 06-19-2013, 11:48 PM   #5
Subilover06
Scooby Newbie
 
Member#: 344208
Join Date: Jan 2013
Chapter/Region: South East
Location: Savannah ga
Vehicle:
2006 Wrx limited
Steel grey

Default

So replaces the clutch master cylinder and slave cylinder and problem continues the car drives but when I press in the clutch it's very soft and the peddle pulses on my foot helpppppp plz!!!!!!!
Subilover06 is offline   Reply With Quote
Old 06-20-2013, 12:02 PM   #6
Subilover06
Scooby Newbie
 
Member#: 344208
Join Date: Jan 2013
Chapter/Region: South East
Location: Savannah ga
Vehicle:
2006 Wrx limited
Steel grey

Default

Afternoon bump
Subilover06 is offline   Reply With Quote
Old 06-20-2013, 12:02 PM   #7
Subilover06
Scooby Newbie
 
Member#: 344208
Join Date: Jan 2013
Chapter/Region: South East
Location: Savannah ga
Vehicle:
2006 Wrx limited
Steel grey

Default

Bump bump bump
Subilover06 is offline   Reply With Quote
Old 06-20-2013, 01:06 PM   #8
RoadKillDMD
Scooby Specialist
 
Member#: 284792
Join Date: Jun 2011
Chapter/Region: RMIC
Location: Vanilla Valley, CO
Vehicle:
2011 STI
Blurple

Default

Quote:
Originally Posted by Subilover06 View Post
Bump!!!!!!
Quote:
Originally Posted by Subilover06 View Post
Afternoon bump
Quote:
Originally Posted by Subilover06 View Post
Bump bump bump
....







Follow the steps starting about halfway down post #2 through post #3.

http://forums.nasioc.com/forums/show....php?t=2419445
RoadKillDMD is offline   Reply With Quote
Old 06-27-2013, 11:13 PM   #9
Subilover06
Scooby Newbie
 
Member#: 344208
Join Date: Jan 2013
Chapter/Region: South East
Location: Savannah ga
Vehicle:
2006 Wrx limited
Steel grey

Default

I actually went ahead an pulled the transmission for the second time the clutch that I just put in the car was an exedy stage 1 racing clutch my recommendations is that they blow after 10000 miles the diaphragm on the pressure plate broke and four of the fingers were bent in causing the issue I was having so went and ordered a spec stage 2 plus clutch
Subilover06 is offline   Reply With Quote
Old 06-28-2013, 10:08 AM   #10
mneste8718
Scooby Specialist
 
Member#: 51562
Join Date: Dec 2003
Chapter/Region: South East
Location: Raleigh NC/High Point NC
Vehicle:
2004 WRX Sedan PSM
EJ205 VF39@22psi 300whp

Default

SPEC Stage 2... is that the Kevlar disc? If so, good luck with the constant clutch chatter. It is awful. And if you ever launch the car once. The clutch will fuse itself with the flywheel at will, as if daily driving it wasn't difficult enough.
mneste8718 is offline   Reply With Quote
Old 06-28-2013, 06:29 PM   #11
ryansx
Scooby Newbie
 
Member#: 324527
Join Date: Jun 2012
Location: Memphis TN
Vehicle:
2013 wrx
white

Default

Quote:
Originally Posted by mneste8718 View Post
SPEC Stage 2... is that the Kevlar disc? If so, good luck with the constant clutch chatter. It is awful. And if you ever launch the car once. The clutch will fuse itself with the flywheel at will, as if daily driving it wasn't difficult enough.
Mine doesn't chatter nor has it fused to my flywheel. Now it's not on my wrx, but on my 240 that I autox(launch it there), clutch kicks, and just straight out abuse it, then drive home. Drove it daily for 3 years before wrx. Still no issues. Also if you haven't replaced rubber section on clutch line, you should consider what others said about replacing it
ryansx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.