Welcome to the North American Subaru Impreza Owners Club Thursday July 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-17-2013, 02:30 PM   #1
06_subie
Scooby Newbie
 
Member#: 335841
Join Date: Oct 2012
Default CEL light help P0442

I've been throwing the po442 light for a month or so now and I have been having a hell of a time trying to figure this out. I know it's a small evap leak and I've searched on google ad found that common parts to cause this were the purge control solenoid valve and purge valve. I have already replaced my gas cap with a new subaru one and still throw the code. I talked to subaru today and asked them about the parts and he gave me some part # and prices. I'm just curious if anybody can confirm it for me because he didn't seem to sure.

Purge valve 42084-FE010
$ 36.38

Duty cycle solenoid 16102AA391
$119.00
According to the parts guy this was the purge control solenoid valve. Any advice is appreciated
* Registered users of the site do not see these ads.
06_subie is offline   Reply With Quote
Old 06-17-2013, 08:34 PM   #2
06_subie
Scooby Newbie
 
Member#: 335841
Join Date: Oct 2012
Default

Anybody?
06_subie is offline   Reply With Quote
Old 06-17-2013, 11:20 PM   #3
dstroy
Scooby Specialist
 
Member#: 283711
Join Date: May 2011
Chapter/Region: NESIC
Location: Newport
Vehicle:
2012 STI sedan
Black with scratches

Default

Did you clean the purge valve already?
dstroy is offline   Reply With Quote
Old 06-18-2013, 07:01 AM   #4
06_subie
Scooby Newbie
 
Member#: 335841
Join Date: Oct 2012
Default

Quote:
Originally Posted by dstroy View Post
Did you clean the purge valve already?
I wasn't aware you could clean it. What would be best to clean it with out damaging it? And I'm going to try and replace the lines on it tonight and zip tie all the ends will regular vacuum hose be ok for this?
06_subie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:39 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.