Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-21-2013, 02:26 PM   #1
icemanftr
Scooby Newbie
 
Member#: 320444
Join Date: May 2012
Chapter/Region: NWIC
Location: Spokane, WA
Vehicle:
2012 WRX
SWP

Default

2012 Wrx Stage 3 torqued performance. Does it everytime after sitting for a few hours. Tomei equal length exhaust and up-pipe, Perrin catted dp, SPT cbe. Let me know if you need more info.
Starts at about 19 second mark.

https://www.youtube.com/watch?v=p5JY...e_gdata_player
* Registered users of the site do not see these ads.

Last edited by icemanftr; 07-21-2013 at 02:34 PM.
icemanftr is offline   Reply With Quote
Old 07-21-2013, 04:28 PM   #2
dstroy
Scooby Specialist
 
Member#: 283711
Join Date: May 2011
Chapter/Region: NESIC
Location: Newport
Vehicle:
2012 STI sedan
Black with scratches

Default

Still have air injection?
dstroy is offline   Reply With Quote
Old 07-21-2013, 04:48 PM   #3
icemanftr
Scooby Newbie
 
Member#: 320444
Join Date: May 2012
Chapter/Region: NWIC
Location: Spokane, WA
Vehicle:
2012 WRX
SWP

Default

Quote:
Originally Posted by dstroy View Post
Still have air injection?
Yes.

Cobb SF intake
Cobb AP
Avo tmic
3 port ebcs
Forge bpv
Dw 65 fuel pump
Stage 3 protune
Wrapped tomei El headers uppipe
Perrin dp
SPT cbe
icemanftr is offline   Reply With Quote
Old 07-21-2013, 05:00 PM   #4
dstroy
Scooby Specialist
 
Member#: 283711
Join Date: May 2011
Chapter/Region: NESIC
Location: Newport
Vehicle:
2012 STI sedan
Black with scratches

Default

That's what is doing it most likely then. You can find out by unplugging the air pump.
dstroy is offline   Reply With Quote
Old 07-21-2013, 05:01 PM   #5
Andrewxxcarlson
Scooby Specialist
 
Member#: 316415
Join Date: Apr 2012
Location: Elk Grove, CA
Vehicle:
2006 WRX
WRB

Default

Probably swingin lean on startup, then it settles. No biggie in my book but my sure there's no exhaust leaks, if there's leaks before the muffler it can cause the popping heard in the video, my car does the same thing at cold start but not as delicious as yours.
Andrewxxcarlson is online now   Reply With Quote
Old 07-21-2013, 05:37 PM   #6
icemanftr
Scooby Newbie
 
Member#: 320444
Join Date: May 2012
Chapter/Region: NWIC
Location: Spokane, WA
Vehicle:
2012 WRX
SWP

Default

Ya not too worried just annoyed, been doing it for over 6 months... Lol
I do have an exhaust leak at dp-cbe stupid gasket sucks right there at the 3-2/ " conversion.
icemanftr is offline   Reply With Quote
Old 07-21-2013, 05:58 PM   #7
Francois_
Scooby Specialist
 
Member#: 284101
Join Date: May 2011
Chapter/Region: Tri-State
Location: Hawthorne, NJ
Vehicle:
2004 STI
world rally blue

Default

That sounds awesome.
Francois_ is online now   Reply With Quote
Old 07-21-2013, 06:25 PM   #8
nate_fisher
Scooby Specialist
 
Member#: 270482
Join Date: Jan 2011
Location: albany ny
Vehicle:
2011 forester xt
corn fed td06 20g 8cm

Default

Its the secondary air injection mine does it to.
nate_fisher is offline   Reply With Quote
Old 07-21-2013, 07:25 PM   #9
Half Crazed
NASIOC Supporter
 
Member#: 321842
Join Date: May 2012
Chapter/Region: NESIC
Location: Manchester, NH
Vehicle:
2008 STi
Blue

Default

I'll too say yes, it's the air injection. I hated that! I have an Invidia Q300 exhaust system and it was loud, sounded like crap. Ended up doing the air pump delete mod... now startup sounds fine!
Half Crazed is offline   Reply With Quote
Old 07-21-2013, 07:35 PM   #10
icemanftr
Scooby Newbie
 
Member#: 320444
Join Date: May 2012
Chapter/Region: NWIC
Location: Spokane, WA
Vehicle:
2012 WRX
SWP

Default

Quote:
Originally Posted by Half Crazed View Post
I'll too say yes, it's the air injection. I hated that! I have an Invidia Q300 exhaust system and it was loud, sounded like crap. Ended up doing the air pump delete mod... now startup sounds fine!
Does sound like crap at first startup. People walk by when I'm leaving work thinking my car is gonna blow up.
icemanftr is offline   Reply With Quote
Old 07-21-2013, 07:46 PM   #11
Half Crazed
NASIOC Supporter
 
Member#: 321842
Join Date: May 2012
Chapter/Region: NESIC
Location: Manchester, NH
Vehicle:
2008 STi
Blue

Default

Quote:
Originally Posted by icemanftr View Post
Does sound like crap at first startup. People walk by when I'm leaving work thinking my car is gonna blow up.
I know right.. embarrassing
Half Crazed is offline   Reply With Quote
Old 07-21-2013, 08:56 PM   #12
the suicidal eggroll
NASIOC Supporter
 
Member#: 51961
Join Date: Jan 2004
Chapter/Region: RMIC
Location: Broomfield, CO
Vehicle:
2005 STi
2012 WRX

Default

lol, that sounds ridiculous. I can definitely say that my '05 with every mod under the sun, and my stage 2 '12, do not make that noise on startup.
the suicidal eggroll is offline   Reply With Quote
Old 07-22-2013, 12:13 AM   #13
A7x411
Scooby Newbie
 
Member#: 354532
Join Date: Apr 2013
Chapter/Region: Tri-State
Location: Long Island
Vehicle:
2004 STi
WRB

Default

X2 for downpipe to catback gaskets sucking! Lol
A7x411 is offline   Reply With Quote
Old 07-22-2013, 12:56 AM   #14
Rowrx11
Scooby Newbie
 
Member#: 338312
Join Date: Nov 2012
Default

This is my setup with invidia n1 dual and tomei equal lenght

https://www.youtube.com/watch?v=UMfF...e_gdata_player

And nameless performance ( cold start )

https://www.youtube.com/watch?v=z0P0...e_gdata_player

With air intake k&n - process west tmic - synapse diverter valve.
Rowrx11 is offline   Reply With Quote
Old 07-22-2013, 12:00 PM   #15
Asharus
Scooby Specialist
 
Member#: 276300
Join Date: Mar 2011
Vehicle:
2011 WRX Ltd 5DR SWP
Stg2 310/326@17.5psi pump

Default

LOL, that popcorn noise. i get it on cold starts too....
Asharus is offline   Reply With Quote
Old 07-22-2013, 06:26 PM   #16
icemanftr
Scooby Newbie
 
Member#: 320444
Join Date: May 2012
Chapter/Region: NWIC
Location: Spokane, WA
Vehicle:
2012 WRX
SWP

Default

Quote:
Originally Posted by Rowrx11 View Post
This is my setup with invidia n1 dual and tomei equal lenght

https://www.youtube.com/watch?v=UMfF...e_gdata_player

And nameless performance ( cold start )

https://www.youtube.com/watch?v=z0P0...e_gdata_player

With air intake k&n - process west tmic - synapse diverter valve.
Atleast I'm not alone!
icemanftr is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:22 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.