Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-19-2013, 04:37 AM   #26
BURNING4ORCE
Scooby Newbie
 
Member#: 356215
Join Date: May 2013
Default

Smoke test for sure to rule out leaks and definitely check those sensors throwing those codes. Could be a simple as sensor plugs not plugged in all the way or something completely different.
* Registered users of the site do not see these ads.
BURNING4ORCE is offline   Reply With Quote
Old 07-19-2013, 11:46 AM   #27
jesseber
Scooby Newbie
 
Member#: 293509
Join Date: Sep 2011
Location: New Orleans, LA
Vehicle:
2004 WRX STI
Blue

Default

Just had her towed back to the shop. Gonna report the findings here as I'm informed.
jesseber is offline   Reply With Quote
Old 07-22-2013, 06:02 PM   #28
jesseber
Scooby Newbie
 
Member#: 293509
Join Date: Sep 2011
Location: New Orleans, LA
Vehicle:
2004 WRX STI
Blue

Default

Just talked to the shop. After messing around with it he found and sealed a leak by the FMIC, but the problem persisted so at this point he thinks it's either a kinked fuel line or a cam gear is off time. Should know sometime this week, I'd assume.
jesseber is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.