Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-27-2013, 02:35 PM   #1
DSM Goat
Scooby Newbie
 
Member#: 313071
Join Date: Mar 2012
Chapter/Region: MWSOC
Location: Is this heaven? No, it's...
Vehicle:
1998 Forester L
White

Default Piston and Head Damage - Opinions, please

I've an EJ20T w/a VF48 running E85. Stock bottom end, stock heads. Tuned by Clark Turner. Peak boost 22-24 lbs.

Anywhooo...I had a head gasket fail. So I pulled the motor, pulled the heads off, and was preparing to replace the head gaskets with some Cometic units and was also going to run ARP head studs.

So I started cleaning up the mating surface on the right hand cylinder head and noticed this,





Hmm, wasn't expecting to see THAT. Naturally, I wanted to see what the other side (piston/block) looked like...
* Registered users of the site do not see these ads.
DSM Goat is offline   Reply With Quote
Old 07-27-2013, 02:37 PM   #2
DSM Goat
Scooby Newbie
 
Member#: 313071
Join Date: Mar 2012
Chapter/Region: MWSOC
Location: Is this heaven? No, it's...
Vehicle:
1998 Forester L
White

Default

And this is what I found,





Ouch!

Any takers on what happened here? I'd appreciate some thoughtful input. Thanks.
DSM Goat is offline   Reply With Quote
Old 07-27-2013, 03:19 PM   #3
sultanofsubguns
Scooby Newbie
 
Member#: 351404
Join Date: Mar 2013
Chapter/Region: NWIC
Location: somewhere over the rainbow
Vehicle:
02 WRX Wagon
ProbablySomethingMundane

Default

Is that at the bottom of the head/block? It so it may have been a previously damaged spark plug that lost a grounding strap into the head.
sultanofsubguns is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:28 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.