Welcome to the North American Subaru Impreza Owners Club Friday December 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Bay Area Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Bay Area Impreza Club Forum -- BAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-03-2002, 03:10 AM   #1
veloLexus
Scooby Specialist
 
Member#: 4920
Join Date: Mar 2001
Location: WAAAAYYYY too close to tdriedger :lol:
Vehicle:
2002 WRX Sedan
Plain old blue!

Default Any WRX folks have a coolant leak?

Coming back from Yosemite I smelled (the fact that I could smell anything with the controlled burns they were doing was amazing) the sweet scent of coolant when I stopped to take a picture. I thought it was the car parked next to me but when I stopped to take another pic the smell was still there.

I investigated and found a few drops of coolant pooled in the splash plate but couldn't for the life of me figure out where it was comming from. The temp gauge was running about a needle and a half width higher than it normally does (which is about half way, it normally runs a little lower than that). I did lose about a centimeter of coolant but it didn't decrease with further driving and the temp gauge was consistent (I was watching it like a hawk the whole way home). I also noticed that the fans sometimes seem to get in some sort of oscillation. Normally they come on, stay on for a while (what seems like more than a minute) and then shut off for a while. Now the fans will sometimes go on and off every 15 seconds (that behavior doesn't last that long though).

Upon inspection this morning I noticed crusty coolant along the inside seam of the radiator. I guess my radiator is going south. I have an appointment with Santa Cruz bright and early tomorrow morning to get it taken care of before something catastrophic happens.

Stratos, Lorry tells me you have the same... "Mystery Crust"???

I'll let ya know what Bruce says tomorrow.

Cheers, Joe
* Registered users of the site do not see these ads.
veloLexus is offline   Reply With Quote
Old 10-03-2002, 10:44 AM   #2
DeliciouSpeed
Scooby Specialist
 
Member#: 3389
Join Date: Dec 2000
Location: ContraCosta, Ca
Vehicle:
07 STImpreza
Satin

Default

Many have had the radiator core and end tank seperate slightly and leak. Usually happens when there is a high pressure cap on the car.

K3
DeliciouSpeed is offline   Reply With Quote
Old 10-03-2002, 02:29 PM   #3
veloLexus
Scooby Specialist
 
Member#: 4920
Join Date: Mar 2001
Location: WAAAAYYYY too close to tdriedger :lol:
Vehicle:
2002 WRX Sedan
Plain old blue!

Default

Quote:
Originally posted by DeliciouSpeed
Many have had the radiator core and end tank seperate slightly and leak. Usually happens when there is a high pressure cap on the car.

K3
Interesting. I just have the stock cap on there, we'll see how it goes, it's there now. They gave me an Outback to toot about in (not some crappy tin can) without me even asking! Yet another reason to buy from Santa Cruz!

Cheers, Joe
veloLexus is offline   Reply With Quote
Old 10-03-2002, 03:50 PM   #4
wackie
Scooby Specialist
 
Member#: 14580
Join Date: Jan 2002
Location: Sacramento, CA
Vehicle:
2004 Forester XT
www.wrxhackers.com

Default

There was a service bulletin on this I believe. It's a hose clamp somewhere. . .

JD
wackie is offline   Reply With Quote
Old 10-03-2002, 04:16 PM   #5
veloLexus
Scooby Specialist
 
Member#: 4920
Join Date: Mar 2001
Location: WAAAAYYYY too close to tdriedger :lol:
Vehicle:
2002 WRX Sedan
Plain old blue!

Default

Quote:
Originally posted by wackie
There was a service bulletin on this I believe. It's a hose clamp somewhere. . .

JD
Bruce just called, the radiator is being replaced and they don't want me driving it until it's fixed. I'll be without my ride for a few days while the new radiator comes in but at least I'm not without a car (and what they gave me is nice as well... ).

Cheers, Joe
veloLexus is offline   Reply With Quote
Old 10-03-2002, 05:24 PM   #6
iloveturbos
Scooby Specialist
 
Member#: 22868
Join Date: Aug 2002
Vehicle:
2002 WRX
MBP

Default

this was all covered by warranty and bruce didnt try to get around fixing it and replaced it w/ a whole new radiator w/o hassel? dang, im glad i live 10 mins away!
iloveturbos is offline   Reply With Quote
Old 10-03-2002, 05:47 PM   #7
wackie
Scooby Specialist
 
Member#: 14580
Join Date: Jan 2002
Location: Sacramento, CA
Vehicle:
2004 Forester XT
www.wrxhackers.com

Default

Or I guess it could be more serious than a hose clamp. Now that's the kind of dealer service I expect.

JD
wackie is offline   Reply With Quote
Old 10-03-2002, 06:05 PM   #8
veloLexus
Scooby Specialist
 
Member#: 4920
Join Date: Mar 2001
Location: WAAAAYYYY too close to tdriedger :lol:
Vehicle:
2002 WRX Sedan
Plain old blue!

Default

Quote:
Originally posted by iloveturbos
this was all covered by warranty and bruce didnt try to get around fixing it and replaced it w/ a whole new radiator w/o hassel? dang, im glad i live 10 mins away!
1) Yes
2) "Get around" and "hassle" (at least for the customer) are words that are not in the vocabulary of Santa Cruz. They do it right.

If I wanted to get hassled I'd go to the evil SC on the east side of the hills.

Cheers, Joe
veloLexus is offline   Reply With Quote
Old 10-03-2002, 08:13 PM   #9
ChrisW
Scooby Specialist
 
Member#: 4181
Join Date: Feb 2001
Location: keeping santa cruz weird
Vehicle:
2003 Lancer Evo 8
It's Blue, ok?

Default

Joe,

My WRX is @ subaru of santa cruz for the same service. My radiator was leaking too.

I guess that was the blue subie I saw in service there today....

In my case, the leak was from where the plastic crappola (that's a technical term) on the radiator meets the aluminum core.
ChrisW is offline   Reply With Quote
Old 10-03-2002, 08:19 PM   #10
veloLexus
Scooby Specialist
 
Member#: 4920
Join Date: Mar 2001
Location: WAAAAYYYY too close to tdriedger :lol:
Vehicle:
2002 WRX Sedan
Plain old blue!

Default

Quote:
Originally posted by ChrisW
Joe,

My WRX is @ subaru of santa cruz for the same service. My radiator was leaking too.

I guess that was the blue subie I saw in service there today....

In my case, the leak was from where the plastic crappola (that's a technical term) on the radiator meets the aluminum core.
Yep, same spot on mine (top inside edge where those stamped metal tabs that hold down the plastic bit are).

Joe
veloLexus is offline   Reply With Quote
Old 10-03-2002, 09:24 PM   #11
suby_dude
NASIOC Vendor
 
Member#: 17397
Join Date: Apr 2002
Chapter/Region: BAIC
Location: Fremont, CA
Vehicle:
many '02 Rex,'13 FRS
WRB, White

Default

Quote:
Originally posted by veloLexus


Yep, same spot on mine (top inside edge where those stamped metal tabs that hold down the plastic bit are).

Joe
same here.
suby_dude is offline   Reply With Quote
Old 10-03-2002, 09:50 PM   #12
veloLexus
Scooby Specialist
 
Member#: 4920
Join Date: Mar 2001
Location: WAAAAYYYY too close to tdriedger :lol:
Vehicle:
2002 WRX Sedan
Plain old blue!

Default

Quote:
Originally posted by suby_dude


same here.
Just curious, when was your car manufactured? Mine was May of 2001.

Joe
veloLexus is offline   Reply With Quote
Old 10-03-2002, 09:52 PM   #13
suby_dude
NASIOC Vendor
 
Member#: 17397
Join Date: Apr 2002
Chapter/Region: BAIC
Location: Fremont, CA
Vehicle:
many '02 Rex,'13 FRS
WRB, White

Default

Quote:
Originally posted by veloLexus


Just curious, when was your car manufactured? Mine was May of 2001.

Joe
where do i find that?
suby_dude is offline   Reply With Quote
Old 10-03-2002, 10:26 PM   #14
Lorry
Scooby Newbie
 
Member#: 11725
Join Date: Oct 2001
Default

Hmmm, maybe I should check mine - definitely something to keep track of. Besides, I don't want to seem like the odd one out.
Lorry is offline   Reply With Quote
Old 10-03-2002, 10:52 PM   #15
Redleader
Scooby Newbie
 
Member#: 14430
Join Date: Jan 2002
Location: Tacoma, Wa. USA
Vehicle:
'02 WRX Wagon WRB
STi swap luvin it!!!

Default

I just had my radiator replaced last Fri on Subaru's dime. It split right next to the overflow container. Sorry to hear the same happened to you...

Redleader
Redleader is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
any wrx folk in wilmington nc jdizzy204 South East Region Forum 3 09-11-2005 12:14 AM
FL: Any WRX autocrossers have a 20mm rear anti-roll bar for sale? GRMPer South East Region Forum 2 08-04-2005 01:07 AM
02 WRX Upper Radiator Hose Coolant Leak! wrxmechman Service & Maintenance 3 03-13-2005 02:56 AM
I think I have a coolant leak jay2theb Service & Maintenance 8 08-19-2003 10:52 PM
Any Bay Area folks have issues with WRX Seat Bolster fabric wearing out? WagonMonster Bay Area Impreza Club Forum -- BAIC 8 08-15-2002 04:46 PM


All times are GMT -4. The time now is 04:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.