Welcome to the North American Subaru Impreza Owners Club Thursday December 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-14-2013, 05:47 PM   #1
UPPCOS
Scooby Newbie
 
Member#: 364680
Join Date: Aug 2013
Default $10 Antilag....

So you swapped to a large rotated mount turbo setup (possibly a UPP), and now you notice that the 2-step just isn't cutting it for launches. Maybe you've got some pesky Mustang owner who insists on "roll" races, but his N20 comes in a bit faster than your turbo lag....

Well here's your answer: ANTILAG & ROLLING ANTILAG!

Many people confuse anti-lag with 2-step. 2-step is just some form of launch control (or shift control) that limits the RPMs so you can launch at full throttle without worrying about destroying the engine, sometimes it builds boost. Antilag on the other hand only builds boost, but it will always build boost, even on big turbo setups. It's simply retarding the timing so the burn cycle doesn't happen inside the cylinder, but instead inside the manifold/turbo, causing a rapid expansion of gasses, spooling the turbo.

Up until now there's been nothing (that I could find anyway) on anti-lag for these cars (especially the 08+), but now there is, and I'm going to show you how!


But first, the disclaimer: I, UPP, or any of it's affiliates are not responsible for you, damage to your car, your turbo, your house, your dog, or anything that may get damaged as a result of you reading this post including but not limited to life and limb, your relationship with your wife, or the ego of mustang owners when you beat them.

Too much antilaging will damage your turbo and/or exhaust valves, so use it wisely! That is if you feel the urge to hit the button continuously, hold it for long periods of time, or just like showing off to all your friends, damage may occur. If used properly however, you should really never have any issues.


Now let's get started. It's going to cost about $10 (plus whatever donation you kindly send me. PayPal: ck@uppcos.com). You're going to need a button of some sort, a relay, and some wire.....that's it.

Locate your MAF, inside your MAF is the IAT sensor. 2 wires on the maf are for the IAT, and those are the wires that we're going to be after. The 2011 STi it's the yellow/blue wire, probably very similar on all the other year/models, but if you're in doubt, look it up.



Cut that wire and run it to pin 87a on your relay. Pin 30 goes to the other end that you cut off the pigtail. Pin 85 goes to an 12v+ ignition source, (anything that's +12v when the key is on; we used the 12v wire going to one of the injectors). Pin 86 goes to a button, and the other leg from the button to ground. (SEE ATTACHED DIAGRAM)



Now mount the button somewhere easily accessible. Generally you want it mounted on the steering wheel by your left thumb (aftermarket wheel), or by your shifter for your right hand. A few people have mounted them elsewhere, but once you start the race (dig or rolling) you generally need to be able to grab the next gear rather quickly, so mount it somewhere feasible.

Now essentially what we're doing here is setting the button so whenever you push it, it disconnects the IAT sensor completely (just like you unplug it). What this does to the ECU is tells it that it's -40deg, which honestly should really never happen (or you need to move!).

Now we go into the timing compensation A, and B, and edit those so the -40 deg column says something way retarded for timing. This you'll have to play with as -17BDC (17ADC) is the sweet spot for anti-lag, but since the ECU is adding timing to whatever it sees on the timing map, and the timing map is constantly changing, it makes it a bit more difficult to dial in. We ended up with -27 in this column (and the -22deg column as well for good measure). Play with it and see what works best, too low an it may take to long to spool. Too much and your boost may be uncontrollable.

Next you're going to need to edit the IAT Activation map. This is a % of what it should apply on the other map. Again you'll have to screw with this to find out what works best. Keep in mind though this map is also in use when antilag is not. (or you can also zero out the other compensation columns so no changes will be made, preboost IAT's are relatively useless anyways, just make sure your tune is safe for hotter IATs) So don't go too crazy with it like we did in the pic on here. The nice thing about this map is you can actually control what RPM's it's active. This will allow you to put it slightly above your 2-step activation point for just a little boost, or below your 2-step activation point for alot of boost. Also you're going to want to disable the IAT codes, this way the ECU doesn't pick up a failure every time you try to use it.

That's it! Now go data log. Your car should run just like normal, hit the button and you should see the IAT drop instantly to -40deg and the IGN Timing down to a negative value. Remember -17 is the sweet-spot for anti lag, so as close as you can get it to there....



Enjoy, don't get hurt, and if you found this writeup helpful and useful shoot me over a little something (paypal: ck@uppcos.com), especially for the shops using this on customers vehicles.


CK
* Registered users of the site do not see these ads.
UPPCOS is offline   Reply With Quote
Old 08-14-2013, 05:58 PM   #2
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
1994 5.8T Cobra
565rwhp @ 10psi

Default

hey, I know it won't be me but... who is going to be the first to do this and try to blow up a engine
Black94Snake is offline   Reply With Quote
Old 08-14-2013, 06:05 PM   #3
Paidfor
Scooby Specialist
 
Member#: 267815
Join Date: Dec 2010
Location: Workn on my LSX swap
Vehicle:
Be in awe
dont hate .)

Default

Thatd be me!!!!


.)
Paidfor is offline   Reply With Quote
Old 08-14-2013, 06:13 PM   #4
GulfCoastMotorworks
Former Vendor
 
Member#: 358317
Join Date: Jun 2013
Chapter/Region: South East
Location: Bonita Springs, FL
Vehicle:
6266 Built Bugeye
GulfCoastMotorWorks.com

Default

Ill do it next week.

**** it she's built. Lol


UPPCOS you guys are legit!
GulfCoastMotorworks is offline   Reply With Quote
Old 08-14-2013, 08:03 PM   #5
Paidfor
Scooby Specialist
 
Member#: 267815
Join Date: Dec 2010
Location: Workn on my LSX swap
Vehicle:
Be in awe
dont hate .)

Default

Well...im almost there. Doin the mod to my 04 STi. problem is, I only have one table to view regarding IAT timing comps. No A or B of this map for me. I don't have a IAT activation map visible on my rom. I do have a IAT enable at a particular load map tho. How do I go about this using the tables I have? Or is this possible for my rom?
Paidfor is offline   Reply With Quote
Old 08-14-2013, 11:45 PM   #6
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
1994 5.8T Cobra
565rwhp @ 10psi

Default

You should be using your timing compensation table. It "should" work if you just set those two -20 and -40 cells... Ya know, theoretically.

then of course, the CEL disables



*edit*

UPPCOS:This is going to make me sound needy as ****.

Can you post a datalog, and possibly a screen shot of your boost table. Im trying to get a warm and fuzzy (short and chubby) for what the car will actually be doing during this process.

Last edited by Black94Snake; 08-14-2013 at 11:52 PM.
Black94Snake is offline   Reply With Quote
Old 08-15-2013, 05:34 AM   #7
idipskoalmint
Scooby Specialist
 
Member#: 169716
Join Date: Jan 2008
Chapter/Region: Tri-State
Location: Albany, NY
Vehicle:
2005 WRX STi
WTF Tuned

Default

Quote:
Originally Posted by Paidfor
Thatd be me!!!!


.)
Money was so tight last month, you couldn't afford a $15 donation for someone's work in creating ECU definitions...

Quote:
Originally Posted by Paidfor View Post
but where I am.....in todays economy......I don't have even $15 to offer.
Glad the economy has totally picked up for you.
idipskoalmint is offline   Reply With Quote
Old 08-15-2013, 07:25 AM   #8
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
1994 5.8T Cobra
565rwhp @ 10psi

Default

Quote:
Originally Posted by idipskoalmint View Post

Money was so tight last month, you couldn't afford a $15 donation for someone's work in creating ECU definitions...

Glad the economy has totally picked up for you.
Why don't we keep the bashing in the new thread to a minimum. This actually has the opportunity to be a nice "hack" for a desired feature.
Black94Snake is offline   Reply With Quote
Old 08-15-2013, 08:03 AM   #9
RubbleDTD
Scooby Newbie
 
Member#: 155997
Join Date: Aug 2007
Chapter/Region: Tri-State
Location: Philadelphia, PA
Vehicle:
2004 PSM WRX wagon
18Gxt

Default

Very Clever! I'm all over this. Will report back in a week or two with results.

Also, when tuning my 18g I noticed that really low timing (and rich) would trigger fbkc. Is this a concern here? I always thought that if timing was too delayed there was risk of preigniting the intake charge on the next cycle. Any thoughts?

Last edited by RubbleDTD; 08-15-2013 at 08:13 AM.
RubbleDTD is offline   Reply With Quote
Old 08-15-2013, 08:33 AM   #10
Zackbo
Scooby Specialist
 
Member#: 43151
Join Date: Sep 2003
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
04 STI
Kinda Silver-ish

Default

Interesting. Gonna give it a shot. Could this be used just for faster spool?
Zackbo is offline   Reply With Quote
Old 08-15-2013, 08:46 AM   #11
ride5000
Scooby Guru
 
Member#: 32792
Join Date: Feb 2003
Chapter/Region: NESIC
Location: lincoln, ri
Vehicle:
2003 GGA MBP
12.9 / 105+

Default

how are you getting around the fact that antilag requires large volumes of air, via a throttle kick or diverter valve?
ride5000 is offline   Reply With Quote
Old 08-15-2013, 09:05 AM   #12
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
1994 5.8T Cobra
565rwhp @ 10psi

Default

Quote:
Originally Posted by ride5000 View Post
how are you getting around the fact that antilag requires large volumes of air, via a throttle kick or diverter valve?
Been doing some reading in this subject, and if I'm understanding it correctly, its just like the BOTL feature that Cobb has been working on for the GTR.

Delay the combustion so it happens in the exhaust instead of in the cylinder. Less pressure moving the piston, but an expansion of pressure in the exhaust to spin the turbine.

I can see the theory behind it. I just don't see it being overly safe for regular use on a "street" car.
Black94Snake is offline   Reply With Quote
Old 08-15-2013, 10:25 AM   #13
Paidfor
Scooby Specialist
 
Member#: 267815
Join Date: Dec 2010
Location: Workn on my LSX swap
Vehicle:
Be in awe
dont hate .)

Default

Seems to be working quite well on mine so far.....ive only hit the button a few times so i cant say anything as far as long term obviously. I cant target specific rpm activation tho. Rollin anti may be an issue . I just dont have those tables visible so far. Timing is fairly steady during boost build up and my knock increments are waaayyyyy less than just building boost with the standard 2 step. Now if i can just figure a way to activate IAT with specific RPM :/ Actually pushin the idea around in my head a little.....there may be a way to have several retarded timing settings with the turn of a knob rather than the push of a button. That way i could preset timing retard to watever fits the timing cell when i engage antilag. Nothing more than a resistor box wired into the IAT input with specific resistors set to display values such as -40, -30,-20...etc...Then i could nail it the retard perfecly for a few different timing load scenarios.
Paidfor is offline   Reply With Quote
Old 08-15-2013, 10:37 AM   #14
wgr73
Scooby Specialist
 
Member#: 232458
Join Date: Dec 2009
Chapter/Region: SWIC
Location: Las Cruces, El Paso
Vehicle:
2008 STi (OBP)
CAMTuning ftw

Default

Quote:
Originally Posted by Black94Snake View Post
Been doing some reading in this subject, and if I'm understanding it correctly, its just like the BOTL feature that Cobb has been working on for the GTR.

Delay the combustion so it happens in the exhaust instead of in the cylinder. Less pressure moving the piston, but an expansion of pressure in the exhaust to spin the turbine.

I can see the theory behind it. I just don't see it being overly safe for regular use on a "street" car.
I agree. Please post up your EGT's ....whoever gets around to doing this. I foresee people using this in parking lots vs. the track.
wgr73 is offline   Reply With Quote
Old 08-15-2013, 10:46 AM   #15
ride5000
Scooby Guru
 
Member#: 32792
Join Date: Feb 2003
Chapter/Region: NESIC
Location: lincoln, ri
Vehicle:
2003 GGA MBP
12.9 / 105+

Default

with carberry sd rom i already massively retard timing during LC and FFS (15* atdc).

i can tell you that it works better than "traditional" timing. way better.

however it is done with the throttle wide open. this CAN be done with software/programming, but only in a throttle by wire car. otherwise there is insufficient charge air to spin up the hot side, and you need some way of providing that air past the butterfly.
ride5000 is offline   Reply With Quote
Old 08-15-2013, 10:50 AM   #16
Zackbo
Scooby Specialist
 
Member#: 43151
Join Date: Sep 2003
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
04 STI
Kinda Silver-ish

Default

Quote:
Originally Posted by Paidfor View Post
Seems to be working quite well on mine so far.....ive only hit the button a few times so i cant say anything as far as long term obviously. I cant target specific rpm activation tho. Rollin anti may be an issue . I just dont have those tables visible so far. Timing is fairly steady during boost build up and my knock increments are waaayyyyy less than just building boost with the standard 2 step. Now if i can just figure a way to activate IAT with specific RPM :/ Actually pushin the idea around in my head a little.....there may be a way to have several retarded timing settings with the turn of a knob rather than the push of a button. That way i could preset timing retard to watever fits the timing cell when i engage antilag. Nothing more than a resistor box wired into the IAT input with specific resistors set to display values such as -40, -30,-20...etc...Then i could nail it the retard perfecly for a few different timing load scenarios.
Do you think it could be used to build boost sooner under load/WOT? Let's say 4k rpm instead of 4.5k with normal timing (GT35R)? If so, I could use a cheap PLC to activate it based on TPS/Manifold Pressure or whatever.
Zackbo is offline   Reply With Quote
Old 08-15-2013, 10:55 AM   #17
Paidfor
Scooby Specialist
 
Member#: 267815
Join Date: Dec 2010
Location: Workn on my LSX swap
Vehicle:
Be in awe
dont hate .)

Default

Possibly.........we bout to find out as soon as i get a break from work.


Freakin Hondas are breakin today...thank god lol
Paidfor is offline   Reply With Quote
Old 08-15-2013, 01:05 PM   #18
UPPCOS
Scooby Newbie
 
Member#: 364680
Join Date: Aug 2013
Default

Oh wow.....lot's on here.

Yes, if you don't have the A/B timing maps, you should still have at least 1 map that controls IAT vs Timing. Just disconnect the IAT and play with the -40 columns and check your data log to see if it's working.

Yes, this can be used to spool the turbo sooner, but probably not how you're thinking. It isn't going to make the car drive like normal and spool the turbo sooner. When you're anti-laging, the car isn't really doing anything as far as acceleration. It will feel like it has zero power, but it will be "charging" up the turbo. When you release the button, it will give you all the stored energy at once. So yes, you could spool your turbo at 4000 instead of 4500, but during the spool time you won't be accelerating. Put it this way, Anti-lag is something you use BEFORE the race, not during. If you use it during the race, you will loose.

EGT's get high, really high (my 3KGT see's 1600+). But that's what it was actually designed to do. If you use it in short spurts you're fine. If you drive down the street holding it cause you think it sounds cool, you're going to burn s*** up!

And you don't need a bypass or anything to feed the turbo air. If you're using anti-lag the pedal needs to be floored, period! This isn't some magic button the spools the turbo while the car is off and stores boost for a later date....

CK
UPPCOS is offline   Reply With Quote
Old 08-15-2013, 01:15 PM   #19
ride5000
Scooby Guru
 
Member#: 32792
Join Date: Feb 2003
Chapter/Region: NESIC
Location: lincoln, ri
Vehicle:
2003 GGA MBP
12.9 / 105+

Default

Quote:
Originally Posted by UPPCOS View Post
And you don't need a bypass or anything to feed the turbo air. If you're using anti-lag the pedal needs to be floored, period!
anti-lag is something that happens when your foot is off the accelerator.

https://en.wikipedia.org/wiki/Antilag_system
ride5000 is offline   Reply With Quote
Old 08-15-2013, 01:17 PM   #20
wgr73
Scooby Specialist
 
Member#: 232458
Join Date: Dec 2009
Chapter/Region: SWIC
Location: Las Cruces, El Paso
Vehicle:
2008 STi (OBP)
CAMTuning ftw

Default

Just a question:

Why can't you tap into your clutch switch and use that as the Antilag button? You could wire in a dipswitch in series so it wouldn't always activate as you staged or drove around, but as soon as you want antilag just flip the switch and let your clutch pedal do the work! You could run the clutch to the relay the same as you'd run the physical switch by itself, just put them in series.
wgr73 is offline   Reply With Quote
Old 08-15-2013, 01:52 PM   #21
UPPCOS
Scooby Newbie
 
Member#: 364680
Join Date: Aug 2013
Default

Quote:
Originally Posted by ride5000 View Post
anti-lag is something that happens when your foot is off the accelerator.

https://en.wikipedia.org/wiki/Antilag_system

Not always. That's a rally style anti-lag system, this is setup much like AEM's anti lag, or Tephra's for the Evo, or Ceddy for the DSM, or Hondata for honda, or....do I need to continue? Anti-lag is what we're doing, but there are multiple ways of achieving it. With this one you floor the throttle, push a button, it's pretty simple.
UPPCOS is offline   Reply With Quote
Old 08-15-2013, 01:54 PM   #22
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
1994 5.8T Cobra
565rwhp @ 10psi

Default

Quote:
Originally Posted by wgr73 View Post
Just a question:

Why can't you tap into your clutch switch and use that as the Antilag button? You could wire in a dipswitch in series so it wouldn't always activate as you staged or drove around, but as soon as you want antilag just flip the switch and let your clutch pedal do the work! You could run the clutch to the relay the same as you'd run the physical switch by itself, just put them in series.
Good question, odd thought for execution.

You would want a 3 pole switch (a on or b on), a relay tied to the clutch switch, and a relay tied to the button.

It would be setup very similar to the msd 2 step that I had in my cobra.

Both buttons would need to be activated, and the switch set for launch anti-lag. When you let off the clutch OR the button, the anti-lag would be disabled.

I can diagram this better later.
Black94Snake is offline   Reply With Quote
Old 08-15-2013, 01:56 PM   #23
UPPCOS
Scooby Newbie
 
Member#: 364680
Join Date: Aug 2013
Default

Quote:
Originally Posted by wgr73 View Post
Just a question:

Why can't you tap into your clutch switch and use that as the Antilag button? You could wire in a dipswitch in series so it wouldn't always activate as you staged or drove around, but as soon as you want antilag just flip the switch and let your clutch pedal do the work! You could run the clutch to the relay the same as you'd run the physical switch by itself, just put them in series.
Yes/No. You can, but then you'll loose rolling antilag. For rolling antilag it needs to be in gear, clutch out, under load. It's not something that you push in the clutch and do, you use it while moving. Also you'd have to have access to the RPM/IAT map (like the one I posted) so you could deactivate it at lower RPM's so it won't retard the timing while idling at a stop light. That little timing would just kill the car, and it would become quite annoying. You could do it, infact that's originally what we were looking into, but because of those reasons we decided against it.

CK
UPPCOS is offline   Reply With Quote
Old 08-15-2013, 01:58 PM   #24
UPPCOS
Scooby Newbie
 
Member#: 364680
Join Date: Aug 2013
Default

Quote:
Originally Posted by Black94Snake View Post
Good question, odd thought for execution.

You would want a 3 pole switch (a on or b on), a relay tied to the clutch switch, and a relay tied to the button.

It would be setup very similar to the msd 2 step that I had in my cobra.

Both buttons would need to be activated, and the switch set for launch anti-lag. When you let off the clutch OR the button, the anti-lag would be disabled.

I can diagram this better later.
With this you would loose rolling anti-lag, and it's a bit overkill. When using it for launching you can just let go of the button.

CK
UPPCOS is offline   Reply With Quote
Old 08-15-2013, 02:04 PM   #25
UPPCOS
Scooby Newbie
 
Member#: 364680
Join Date: Aug 2013
Default

I just realized I didn't post the video in this thread, only in the last one.

This may help to clear up some confusion.

https://www.youtube.com/watch?v=pxuUVlMXqpo
UPPCOS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.