Welcome to the North American Subaru Impreza Owners Club Friday July 29, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-26-2016, 09:36 AM   #1
ChkOutMySubaru
Scooby Newbie
 
Member#: 440939
Join Date: Feb 2016
Default Boost fluctuation with GM BCS

I have an 03 WRX and last month I flashed to XPT stage 2 with GM BCS.
Since day 1 with this map the car has had inconsistent boost. Sometimes it will run 17psi and then minutes later it will only hit 15psi. Last night at 10pm, 60f outside temp, I did two 3rd gear pulls from 3500-5000 which yielded 17psi. A couple miles down the road I did two more third gears pulls just the same, and sure enough only 15psi both times. I pulled a RR LTV and there was no knock events in that time frame.

Mods include;
K&N panel filter
Snorkus delete
AVO turbo inlet
GM bcs
Catless up pipe
Catless tbe
ACT street light flywheel

Has anybody else experienced anything similar to this?
* Registered users of the site do not see these ads.

Last edited by ChkOutMySubaru; 03-26-2016 at 09:44 AM. Reason: Forgot to ad mods list
ChkOutMySubaru is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-26-2016, 09:45 AM   #2
wrxlaunch
Scooby Specialist
 
Member#: 181298
Join Date: May 2008
Chapter/Region: MAIC
Location: MAIC
Vehicle:
2015 WRX Limited
Lightning Red

Default

Boost does not = HP.


Is boost fluctuating?
wrxlaunch is offline   Reply With Quote
Old 03-26-2016, 10:50 AM   #3
quazimoto
Scooby Guru
 
Member#: 70395
Join Date: Sep 2004
Chapter/Region: MAIC
Location: Da-boonies,Va
Default

Actually do a "good" 3rd gear log and post it. 2500rpm- as close to redline as you can.
quazimoto is offline   Reply With Quote
Old 03-26-2016, 07:34 PM   #4
ChkOutMySubaru
Scooby Newbie
 
Member#: 440939
Join Date: Feb 2016
Default

Well, I drove about 100 miles this morning. Temp was 49f. I was hitting 17psi steady, and my afr was 11.2-11.3 all the way to redline, so I decided to do some datalogs. After the first log my IAM dropped from 16 to 0.I logged 1 min of idling followed by several minutes of normal driving. Afterwards, my IAM went to 16 but my boost was wacky. Spiking to 18psi and then bouncing between 16-18psi. I did a datalog and my IAM dropped back to 0 and my AF learning was high.
A=7.7%
B=3.8%
C=5.08%
D=-0.2%

I did more normal driving and checked again,
IAM went to 3 and AF learning went up
A=9.38%
B=4.30%
C=7.42%
D=-.20%

I pulled over to check to check my vac lines and search for post MAF leaks and found nothing. Suddenly, I heard a noise coming from the passenger side of the intake manifold. It sounded like a bad a/c compressor that made a single knock. Sort of a plastic/aluminum like knock. It made the noise once more and now it hasn't done it since. I'm beginning to wonder if that knock sound is what tripped my IAM to 0. If so, what on earth could it be?

Last edited by ChkOutMySubaru; 03-27-2016 at 02:10 AM.
ChkOutMySubaru is offline   Reply With Quote
Old 03-26-2016, 07:36 PM   #5
ChkOutMySubaru
Scooby Newbie
 
Member#: 440939
Join Date: Feb 2016
Default

Quote:
Originally Posted by wrxlaunch View Post
Boost does not = HP.


Is boost fluctuating?
I don't believe I ever made that statement.

And yes, boost fluctuates per temp as typical, but also regardless of temp it seems to change when there has been no recorded knock or change in IAM.
ChkOutMySubaru is offline   Reply With Quote
Old 03-26-2016, 07:39 PM   #6
ChkOutMySubaru
Scooby Newbie
 
Member#: 440939
Join Date: Feb 2016
Default

Quote:
Originally Posted by quazimoto View Post
Actually do a "good" 3rd gear log and post it. 2500rpm- as close to redline as you can.
Is it okay for me to post a log from an XPT map?

Last I checked that was a no no, but Braden must be busy because he is not responding other than once a week and hasn't granted me access to osecuroms.com.
ChkOutMySubaru is offline   Reply With Quote
Old 03-26-2016, 10:26 PM   #7
ChkOutMySubaru
Scooby Newbie
 
Member#: 440939
Join Date: Feb 2016
Default

Alright, I've posted the logs and shots to dropbox. Everything from today is in order from first to last. The first LTV was taken before I starting logging today. Thanks guys!

https://www.dropbox.com/sh/r486mbqf4...jxIRQWBZa?dl=0

Last edited by ChkOutMySubaru; 03-26-2016 at 10:46 PM.
ChkOutMySubaru is offline   Reply With Quote
Old 03-27-2016, 12:12 PM   #8
ChkOutMySubaru
Scooby Newbie
 
Member#: 440939
Join Date: Feb 2016
Default

I lowered my target boost from 17.2 to 16.5psi and did two logs back to back. LTV beforehand and also after each log. Seems I keep getting knock in the same rpm/load range despite having the timing pulled there by several degrees from the original setting.

https://www.dropbox.com/sh/9sqfqdae8...jpoUhvGJa?dl=0
ChkOutMySubaru is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 01:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.