Welcome to the North American Subaru Impreza Owners Club Thursday January 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-15-2013, 09:34 AM   #1
1FastREX
Scooby Newbie
 
Member#: 40482
Join Date: Jul 2003
Chapter/Region: TXIC
Location: League City, TX
Vehicle:
2002 WRX Sedan
WR Blue

Default My car is "fat"

Took the car in for routine checks and minor work and the tech said my CEL is saying car is running rich. Anyway to lean it out without remapping? I don't have the AP. No cat in the up pipe, downpipe, and only a high flow in the mid pipe. Basic mods, full exhaust and cold air intake. Any suggestions?
* Registered users of the site do not see these ads.
1FastREX is offline   Reply With Quote
Old 08-15-2013, 11:43 AM   #2
cowboy_Rob
Scooby Specialist
 
Member#: 194062
Join Date: Nov 2008
Chapter/Region: MAIC
Location: Camp Hill PA
Vehicle:
2003 Impreza WRX
PSM

Default

Has it been tuned for the intake? If it hasn't you need to rescale the maf ASAP and that will probably take care of your problem
cowboy_Rob is offline   Reply With Quote
Old 08-15-2013, 01:46 PM   #3
Andrewxxcarlson
Scooby Specialist
 
Member#: 316415
Join Date: Apr 2012
Location: Elk Grove, CA
Vehicle:
2006 WRX
WRB

Default

Your mods aren't efficient without a tune. Bugeye catless is one thing, once you tune it it's whole different feeling. 120 dollar etune from Eric @ TP. Do it today.
Andrewxxcarlson is offline   Reply With Quote
Old 08-15-2013, 01:58 PM   #4
dux10
NASIOC Supporter
 
Member#: 235338
Join Date: Jan 2010
Chapter/Region: South East
Location: Georgia
Vehicle:
2002 Faggin Wagon
srp

Default

Could be a number of things from O2 sensor to maf sensor. More than likely its the intake with no tune causing the issue. What kind of intaek is it?

Steve @ Pullz-On Tuning
dux10 is offline   Reply With Quote
Old 08-15-2013, 02:00 PM   #5
1FastREX
Scooby Newbie
 
Member#: 40482
Join Date: Jul 2003
Chapter/Region: TXIC
Location: League City, TX
Vehicle:
2002 WRX Sedan
WR Blue

Default

Quote:
Originally Posted by dux10 View Post
Could be a number of things from O2 sensor to maf sensor. More than likely its the intake with no tune causing the issue. What kind of intaek is it?

Steve @ Pullz-On Tuning
Injen
1FastREX is offline   Reply With Quote
Old 08-15-2013, 03:41 PM   #6
dux10
NASIOC Supporter
 
Member#: 235338
Join Date: Jan 2010
Chapter/Region: South East
Location: Georgia
Vehicle:
2002 Faggin Wagon
srp

Default

Not one that I've seen cause lots of issues in my experience. Try cleaning the MAF with maf cleaner (any autoparts store will have it). If that doesn't work, I'd replace the front O2 sensor.

Steve @ Pullz-On Tuning
dux10 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 04:39 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.