Welcome to the North American Subaru Impreza Owners Club Tuesday September 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-03-2002, 09:19 AM   #1
Canuck
Scooby Newbie
 
Member#: 17257
Join Date: Apr 2002
Angry Vishnu Up pipe O2 sensor falling out

It seems that my O2 sensor is coming loose and falling out of my Vishnu up-pipe avery month or so. It was fine for about half a year until recently. Now I have nothing but problems.
It seems that maybe someone did not tap the o2 sensor bung with the appropriate tolerances?
I've tried e-mailing Vishnu, but no luck.

I'm pissed!

Any suggestions would be much appreciated.
* Registered users of the site do not see these ads.
Canuck is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-03-2002, 09:57 AM   #2
8Complex

Moderator
 
Member#: 922
Join Date: Feb 2000
Chapter/Region: MWSOC
Location: Schaumburg, IL
Vehicle:
16 WRX (white)
04 FXT (red)

Default

Vishnu uppipe... for the WRX?
8Complex is offline   Reply With Quote
Old 10-03-2002, 10:00 AM   #3
Canuck
Scooby Newbie
 
Member#: 17257
Join Date: Apr 2002
Default

Yup, for a WRX. I know this issue has been raised before, but I can't find it anywhere.
Canuck is offline   Reply With Quote
Old 10-03-2002, 11:52 AM   #4
stimpy
Homicidal Maniac
Moderator
 
Member#: 1612
Join Date: Jun 2000
Location: Austin, TX
Vehicle:
2008 STI

Default

O2 sensor or EGT sensor? I have not heard of this for the O2 sensor since it's an additional bung not typically used. I have experienced the problem with the EGT sensor however. The stock up-pipe has a bottom in the hole, the Vishnu pipe does not have anything to stop. They offer some little inserts to resolve this problem if you can get in contact with them. I had this problem until I bought a flare nut wrench and gave the sensor a good tightening. It's been about 4k miles and no problem yet.

PS: This needs to be moved.

-Jon
www.nothingserious.net
stimpy is offline   Reply With Quote
Old 10-03-2002, 11:57 AM   #5
Canuck
Scooby Newbie
 
Member#: 17257
Join Date: Apr 2002
Default

Isn't the EGT sensor the one on the manifold not the up-pipe? After tightening the sensor by hand, it really doesn't go much further with a wrench, and I don't want to reaf on it.

I've been trying to contact them, but no luck. I think that their website and e-mail is down, and I have no ph. numbers.

Thanks for the reply
Canuck is offline   Reply With Quote
Old 10-03-2002, 12:02 PM   #6
stimpy
Homicidal Maniac
Moderator
 
Member#: 1612
Join Date: Jun 2000
Location: Austin, TX
Vehicle:
2008 STI

Default

Front O2 sensor goes into the passenger side exhaust manifold. The up-pipe contains a bung for the factory EGT sensor (long metal rod) and an extra O2 sensor bung (which is used for aftermarket O2 sensors).

Are you using the right website? www.vishnutuning.com

-Jon
www.nothingserious.net
stimpy is offline   Reply With Quote
Old 10-03-2002, 04:43 PM   #7
H8YNERS
Scooby Specialist
 
Member#: 4995
Join Date: Mar 2001
Location: Seattle, WA USA
Vehicle:
2002 WRX wagon
Silver

Default

On the Vishnu uppipe, it's the stock EGT probe that goes in the bung. I know, mine kept falling out. I finally did the bolt & resistor mod to fix. I got up and close and personal w/my EFT probe (wow..that sounds bad! ) as it fell out at least 3x's!

Stephen
H8YNERS is offline   Reply With Quote
Old 10-03-2002, 07:40 PM   #8
WRX216
Scooby Newbie
 
Member#: 8027
Join Date: Jul 2001
Chapter/Region: MWSOC
Location: Blue Eye, Mo.
Vehicle:
2002 WRX sedan
Midnight Black

Default

loctite makes a hi temp threadlocker that will fix your problem. Just don't use too much or you will never get the egt probe out again. Hope this helps
Chris
WRX216 is offline   Reply With Quote
Old 10-03-2002, 08:30 PM   #9
Yungimoto
Scooby Specialist
 
Member#: 14940
Join Date: Feb 2002
Chapter/Region: SWIC
Location: Wildwood, MO
Vehicle:
2002 WRX

Default

Call them and they'll send out these little inserts right away. I got mine in 2 days. It is the egt sensor you're talking about.
Yungimoto is offline   Reply With Quote
Old 10-04-2002, 09:59 AM   #10
nhluhr
John Wayne Toilet Paper
Moderator
 
Member#: 7327
Join Date: Jun 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2008 Mazdaspeed3
2006 Wrangler Sport

Default Re: Vishnu Up pipe O2 sensor falling out

Quote:
Originally posted by Canuck
It seems that my O2 sensor is coming loose and falling out of my Vishnu up-pipe avery month or so. It was fine for about half a year until recently. Now I have nothing but problems.
It seems that maybe someone did not tap the o2 sensor bung with the appropriate tolerances?
I've tried e-mailing Vishnu, but no luck.

I'm pissed!

Any suggestions would be much appreciated.
The O2 sensor is in the manifold and the EGT sensor is in the uppipe.

Best recommendation: Replace the EGT with a 12x1.25 bolt and a 2.2 kohm resistor. If you prefer to keep the EGT probe, get a medium-sized hoseclamp and cut a hole in the side of the metal band so that the probe can fit through it. Then just put the hoseclamp around the uppipe and it'll clamp your EGT probe down tight and permanent. If you do this and your probe comes out on its own again, I'll paypal you $10. That's how sure I am of this fix. If you need pictures to understand how to do it, I can get you some pictures.
nhluhr is offline   Reply With Quote
Old 10-04-2002, 12:34 PM   #11
H8YNERS
Scooby Specialist
 
Member#: 4995
Join Date: Mar 2001
Location: Seattle, WA USA
Vehicle:
2002 WRX wagon
Silver

Default

Quote:
Best recommendation: Replace the EGT with a 12x1.25 bolt and a 2.2 kohm resistor.
This is what I did after my EGT probe fell 3x's. So far, so good.
The EGT probe is there to monitor the temp to protect the pre-cat which is no longer there after the new uppipe install anyhow.

Stephen
H8YNERS is offline   Reply With Quote
Old 10-04-2002, 03:46 PM   #12
twinz
Scooby Newbie
 
Member#: 13423
Join Date: Dec 2001
Location: Florida
Vehicle:
2002 WRX
Silver

Default

locktite isnt a decent solution because even their hitemp stuff is only rated to 450 derees..that locaton is seeing over 1500 drgrees. Permatex makes a hitemp muffler and tailpipe sealer that is good to 2k degrees...I had same issue with egt probe in my Perrin up-pipe and it has worked just great. Permatex part # 80335 ..you will probably have to order it as I was unable to find it in any local autoparts stores.
twinz is offline   Reply With Quote
Old 11-01-2002, 06:14 PM   #13
metoo
Scooby Guru
 
Member#: 4764
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston
Vehicle:
2004 STi sold :(
forizzle

Default

Shoot.....I just used JB Weld. After trying a couple other products, this is the only one to hold so far. It's been in place about 4 or 5 months now.
metoo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vishnu Up pipe (BRAND NEW) and used Vishnu DP (SAN DIEGO) sdnativesurfer SCIC Private Classifieds 2 06-02-2009 01:12 AM
Vishnu up-pipe WRX Sti w/EGT sensor FusionMotorSwaps Engine/Power/Exhaust 4 02-20-2009 11:56 AM
up-pipe o2 sensor pearljam11 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 9 05-22-2008 03:59 PM
Up pipe / O2 sensor question armowrx Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 20 04-09-2008 05:21 PM
more stuff for sale Samco hoses, Vishnu up-pipe vishnu pulley and more.. titsataki Bay Area Impreza Club Forum -- BAIC 12 05-04-2004 09:17 PM


All times are GMT -4. The time now is 11:57 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.