Welcome to the North American Subaru Impreza Owners Club Wednesday October 26, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 10-16-2013, 06:36 AM   #1
Scooby Newbie
Member#: 149523
Join Date: May 2007
Default Speedo lighting issue help please

This morning on my way to work the speedo needle, right side of the speedo gauge and the left side of the tach gauge went dark on my 2007 Impreza wagon. I assume there must be a single bulb that has burned out that covers these areas?

Any help or part breakdown with this would be greatly appreciated. Thanks
* Registered users of the site do not see these ads.
rickr01 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 01:46 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.