Welcome to the North American Subaru Impreza Owners Club Thursday October 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-27-2013, 05:36 PM   #1
93GC8Dub
Scooby Newbie
 
Member#: 217150
Join Date: Jul 2009
Chapter/Region: W. Canada
Location: Edmonton
Vehicle:
1993 Wrx rhd gc8
Silver

Default Legacy Down After Twin To Single Swap, Help Me Out

Hey guys, so i have a BD5 94 legacy RS Sport not the GTB but the sport.

A couple months back i decided to do the single turbo swap off the "dirty ol legacy" webpage, I have now successfully got everything back in and went to turn it over to have it not turn on, it cranks, and sounds like one cylinder gets ignition but it does not fire up completely.

i went over the grounds and whatnot and everything looks to be hooked up. i have a couple questions of my own but need the genius' of NASIOC to help me out.

First, on your injectors there is a black and grey harness for each side, which one goes to which cylinders(my understanding is that grey is the front cylinder and black is the back, same as the coils).

Second, the fuel lines coming out of the firewall (3 of them) from top to bottom which goes where? top to vent, middle to return and bottom to fuel filter(feed)? or how does that go?

Third, what ECU goes with the 440cc injectors? and will an RA and regular one work for the same injectors?

Forth, are there any sensors that would inhibit the car from starting? i have most of them on but the O2 is not and the original exhaust cat sensor is removed as well.

Fifth, Is there more then one intake ground? i have the main one behind the alternator hooked up but i have seen talk of another but had no luck finding it. I was told it might be one related to the injectors, where is this ground they speak of?

Sixth, i did the parallel fuel rail mod, i dont know if this info will affect but im telling

Seventh, Electronic boost controllers, i swapped for a manual, is this gonna be an issue with removing the black box and then converting to MBC? should i source a EBC and put that in?

can any one else shed light on this? it would be greatly appreciated. or if there is any idea of what it could be or methods to track down the issue, it would all be helpful. Thanks, Paul!
* Registered users of the site do not see these ads.
93GC8Dub is offline   Reply With Quote
Old 09-03-2013, 03:28 PM   #2
Baja_Gernaut
Scooby Specialist
 
Member#: 229922
Join Date: Nov 2009
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 F-Inductd BAJA
rumble black

Default

what hot mess!
Baja_Gernaut is offline   Reply With Quote
Old 09-05-2013, 12:40 AM   #3
93GC8Dub
Scooby Newbie
 
Member#: 217150
Join Date: Jul 2009
Chapter/Region: W. Canada
Location: Edmonton
Vehicle:
1993 Wrx rhd gc8
Silver

Default

Ya well I'm down to just not having spark on the rear two cylinders, got fuel, and the cam gears are the same, timing belt for the third time,

How many grounds do the ingnition systems have?
93GC8Dub is offline   Reply With Quote
Old 09-05-2013, 10:08 PM   #4
wolfd123
Scooby Newbie
 
Member#: 365331
Join Date: Aug 2013
Default

i BELIEVE THERE ARE TWO GROUNDS TO THE IGNITION. At least there are two on my legacy 2.2
wolfd123 is offline   Reply With Quote
Old 09-06-2013, 10:10 AM   #5
93GC8Dub
Scooby Newbie
 
Member#: 217150
Join Date: Jul 2009
Chapter/Region: W. Canada
Location: Edmonton
Vehicle:
1993 Wrx rhd gc8
Silver

Default

are they both on the intake? or two to the ECU? will a EJ20K ECU run the 02WRX coilpack conversion coils(with no ignitor box, built in ignitor)??
93GC8Dub is offline   Reply With Quote
Old 09-06-2013, 08:09 PM   #6
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

I would suggest trying these questions in the Subaru Conversions forum, as there are way more folks there that have dealt with engine swaps. I realize this isn't an engine swap, but the issues you're dealing with are the sort of thing that people run into with swaps and conversions.
Patrick Olsen is offline   Reply With Quote
Old 04-15-2014, 12:08 PM   #7
93GC8Dub
Scooby Newbie
 
Member#: 217150
Join Date: Jul 2009
Chapter/Region: W. Canada
Location: Edmonton
Vehicle:
1993 Wrx rhd gc8
Silver

Default

93GC8Dub is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.