Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-25-2013, 08:51 PM   #1
robtothek
Scooby Newbie
 
Member#: 369320
Join Date: Sep 2013
Chapter/Region: E. Canada
Location: Soviet Quebekistan
Vehicle:
2004 Impreza
Red

Question 2004 Impreza Heater Core

Hey guys! Recently bought an 04 Impreza RS and shortly after I noticed there was a problem when going from cool to hot on my turn-dial.

Long story short, after months of not dealing with the problem (because it's stuck on cool) I took a peak under the dash.

Where my cable attaches to the heater core was holding onto a broken toggle switch and therefore I have no heat control.

Has anyone dealt with this before?

What are the options? If there are any...





PS, really would like to avoid having to change the entire heater unit is at all possible.

Let me know!

Thanks
* Registered users of the site do not see these ads.
robtothek is offline   Reply With Quote
Old 09-26-2013, 07:57 PM   #2
dawsonj
Scooby Newbie
 
Member#: 232573
Join Date: Dec 2009
Chapter/Region: W. Canada
Location: Medicine Hat, AB, Canada
Vehicle:
2006 WRX Sedan

Default

Bump since winter is approaching in Canada.
dawsonj is offline   Reply With Quote
Old 09-26-2013, 11:29 PM   #3
subygahhhhh
Scooby Newbie
 
Member#: 364807
Join Date: Aug 2013
Default

zip ties jk
subygahhhhh is offline   Reply With Quote
Old 09-28-2013, 10:39 AM   #4
robtothek
Scooby Newbie
 
Member#: 369320
Join Date: Sep 2013
Chapter/Region: E. Canada
Location: Soviet Quebekistan
Vehicle:
2004 Impreza
Red

Default

For any interested parties; It was the heat selector toggle.

One side of the black link arm is connected to the cable attached to your control console, and the other side is clipped to the heater assembly.

In order to fix this, it required; complete removal of dashboard, center console, front support frame, wiring harnesses, heater blower motor, air filter, coolant lines, a/c lines, and heater assembly... and a quick drive to the junkyard to get 30$ toggle flaps...
robtothek is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.