Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-14-2001, 09:59 PM   #1
AaronB
Worst Mod Ever
Moderator
 
Member#: 369
Join Date: Oct 1999
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
12 Vagon

Unhappy I am sube-less

I am making the trek up the hill to drop off the last few parts for the RS-T, driving my wife's SVX. All of the sudden the speedometer stops working and the check engine light came on I was going about 55. Hmm not good.

As I was getting near Robert's I continued on my way pacing myself with other traffic, while monitoring my idiot lights for further clues. The car drove fine still. I get to Robert's and we decide to investigate the smokey engine bay and burnt oil fragrance. We check the ATF, whew looks fine. The front differential on the other hand was almost empty.

It was leaking pretty good at this point. The diff got so hot that it had melted the plastic speed sensor. The were plastic fragments mixed in with the little remaining oil.

The speedometer doesn't work and the tranny doesn't know when to shift now, but the tranny and gears appear to have survived without damage. Fixing the seals on the diff, refilling, and replacing the speed sensor are on the menu for the SVX now. While he has it I am going to get the front CV boots replaced since they are both cracked. Ahh the SVX my second money pit.

So I made the trip back down the hill subeless, but both should be ready to roll this weekend, hopefully.

Aaron http://www.azscooby.com

[This message has been edited by AaronB (edited January 14, 2001).]
* Registered users of the site do not see these ads.
AaronB is offline   Reply With Quote
Old 01-14-2001, 10:08 PM   #2
kastle
Frank Army
 
Member#: 1457
Join Date: May 2000
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
1999 Outback Sport
Steel Blue Mica

Post

ha ha.... errr..... I mean that stinks.... Atleast I heard this prior to it making it to the board.


kastle
<a href="http://www.azscooby.com" target="new">azscooby.com</a>
kastle is offline   Reply With Quote
Old 01-14-2001, 10:32 PM   #3
Red-Imp
Scooby Specialist
 
Member#: 1742
Join Date: Jun 2000
Chapter/Region: SWIC
Location: Gilbert, AZ, USA
Vehicle:
2000 Imp 2.5 RS, SRP
& a fast red car ;)

Thumbs down

Ooo... bad luck. Hope Robert can fix it right as rain quickly (and cheeply).

-Red
Red-Imp is offline   Reply With Quote
Old 01-15-2001, 10:27 AM   #4
Eric SS
Sooby Guru
 
Member#: 1914
Join Date: Jul 2000
Chapter/Region: SWIC
Location: 2013 335i, 2011 G37 coupe
Vehicle:
2000 2.5RS w/ EJ22T
swap and N20. gone. : (

Post

At least you didn't drag race it How much is that going to set you back?

Eric
Eric SS is offline   Reply With Quote
Old 01-15-2001, 03:02 PM   #5
Turbo4me
Scooby Specialist
 
Member#: 2200
Join Date: Aug 2000
Chapter/Region: NWIC
Location: Hillsboro, OR
Vehicle:
2011 WRB WRX
08 Maz 3, 96 Landcruiser

Unhappy

Dude,
Sorry to hear about that. Maybe it is time to put some money down on a new WRX? You are going to have to post numbers on your car when you get it back. Bummed for you on the SVX, happy for you on the turbo Imp. Good luck with all.

Curt
Turbo4me is offline   Reply With Quote
Old 01-15-2001, 03:33 PM   #6
kastle
Frank Army
 
Member#: 1457
Join Date: May 2000
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
1999 Outback Sport
Steel Blue Mica

Post

Curt, how's your Imp doing?
kastle is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS/FT : COBB Intake, less than 300 miles Project Blackhawk Engine/Power/Exhaust 0 06-01-2010 06:03 PM
SubEd for early AM OT mod! SkirtBoy Off-Topic 16 02-22-2005 10:07 AM
I am Subaru-less, buy my car at CarMax rao Mid West Subaru Owners Club Forum -- MWSOC 6 07-19-2004 08:08 PM
I am going nuts with no Sube!! blitzpb Southern California Impreza Club Forum -- SCIC 9 01-12-2002 02:42 AM
i am thinking of buying a sube...have some questions... Subecowboy General Forum Archive 1 03-07-2001 09:51 AM


All times are GMT -4. The time now is 07:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.