Welcome to the North American Subaru Impreza Owners Club Sunday December 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-14-2013, 09:48 AM   #1
Coolwhip
Scooby Newbie
 
Member#: 266588
Join Date: Dec 2010
Location: DFW/HOUSTON
Default

I just recently installed a Prosport boost gauge and did all the hosing under the hood. Everything is correct but now my bov makes a fluttering noise? Anyone have any ideas? Any help is much appreciated!
* Registered users of the site do not see these ads.

Last edited by Coolwhip; 09-14-2013 at 09:54 AM.
Coolwhip is offline   Reply With Quote
Old 09-14-2013, 01:36 PM   #2
Brother EddieJ.
Scooby Specialist
 
Member#: 181617
Join Date: Jun 2008
Chapter/Region: MAIC
Location: frederick, md
Vehicle:
2004 wrx
6speed/ 330whp/ 300wtq

Default

Is it compressor surge? Does it sound like a ch-ch-ch-ch sound? If so that's normal for off throttle partial boost release.
Brother EddieJ. is offline   Reply With Quote
Old 09-14-2013, 04:06 PM   #3
Coolwhip
Scooby Newbie
 
Member#: 266588
Join Date: Dec 2010
Location: DFW/HOUSTON
Default

Quote:
Originally Posted by Brother EddieJ. View Post
Is it compressor surge? Does it sound like a ch-ch-ch-ch sound? If so that's normal for off throttle partial boost release.
Yeah that ch-ch-ch sound. Lol.
Coolwhip is offline   Reply With Quote
Old 09-14-2013, 06:00 PM   #4
Brother EddieJ.
Scooby Specialist
 
Member#: 181617
Join Date: Jun 2008
Chapter/Region: MAIC
Location: frederick, md
Vehicle:
2004 wrx
6speed/ 330whp/ 300wtq

Default

It's normal. Don't worry about it.
Brother EddieJ. is offline   Reply With Quote
Old 09-16-2013, 09:06 PM   #5
appjoe2004
Scooby Newbie
 
Member#: 287455
Join Date: Jul 2011
Chapter/Region: Tri-State
Location: Pittsburgh, PA
Vehicle:
2010 wrx m7960 tomei
obp

Default

not sure how the cobb bov works but i had to put a lighter spring in my tial. that got rid of the issue
appjoe2004 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.