Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-17-2013, 01:02 AM   #1
Scoobie_Black
Scooby Newbie
 
Member#: 368541
Join Date: Sep 2013
Chapter/Region: BAIC
Location: Sacramento
Vehicle:
09 wrx
black

Default clutch and flywheel probs..

I just had a new clutch and fly wheel installed and the next day my engine wouldnt turn over.. so i pop started it and now i have a loud ticking noise coming from the middle of the engine. What are the possibilities??
* Registered users of the site do not see these ads.
Scoobie_Black is offline   Reply With Quote
Old 09-17-2013, 01:09 AM   #2
Chicago AJ
Scooby Specialist
 
Member#: 353343
Join Date: Apr 2013
Chapter/Region: MWSOC
Location: Suburb of Chicago
Vehicle:
'13 WRX Sedan Stg 3
'13 Prius C 86mpg!

Default

Everything.
Chicago AJ is offline   Reply With Quote
Old 09-17-2013, 01:17 AM   #3
Brother EddieJ.
Scooby Specialist
 
Member#: 181617
Join Date: Jun 2008
Chapter/Region: MAIC
Location: frederick, md
Vehicle:
2004 wrx
6speed/ 330whp/ 300wtq

Default

Oh wow. The possibilities are endless. Good luck
Brother EddieJ. is offline   Reply With Quote
Old 09-17-2013, 01:22 AM   #4
Scoobie_Black
Scooby Newbie
 
Member#: 368541
Join Date: Sep 2013
Chapter/Region: BAIC
Location: Sacramento
Vehicle:
09 wrx
black

Default

Haha im scared to even begin looking into this.
Scoobie_Black is offline   Reply With Quote
Old 09-17-2013, 01:46 AM   #5
dead_eye
Scooby Newbie
 
Member#: 308265
Join Date: Jan 2012
Location: PHL
Vehicle:
2008 WRX

Default

Pretty sure the manual says not to start it like that
dead_eye is offline   Reply With Quote
Old 09-17-2013, 08:04 AM   #6
Unabomber
Big Ron
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

We also don't know if you are talking about a 71 or 72 Dodge as well....
Unabomber is offline   Reply With Quote
Old 09-17-2013, 09:39 AM   #7
Jack
Add Lightness
Moderator
 
Member#: 13699
Join Date: Dec 2001
Chapter/Region: NESIC
Location: Hopkinton, MA
Vehicle:
2007 Lotus Elise
(From General)

Default

The slant 6 on a 71 Plymouth Valient can have this happen occationally. I know personally of the only 71 that spun a bearing. Is yours a beige 4 door with a welded torsion bar on the passenger side?
Jack is offline   Reply With Quote
Old 09-17-2013, 09:42 AM   #8
SpamBot
Scooby Specialist
 
Member#: 287534
Join Date: Jul 2011
Default

Several things can cause this. The majority of them are bad.
SpamBot is offline   Reply With Quote
Old 09-17-2013, 09:55 AM   #9
D-rock240
Scooby Specialist
 
Member#: 284221
Join Date: May 2011
Chapter/Region: MAIC
Location: West of Baltimore, MD
Vehicle:
2011 WRX GV SSM
2001 Legacy BH 5MT DD

Default

Quote:
Originally Posted by dead_eye View Post
Pretty sure the manual says not to start it like that
Where does it say that? I am curious. I just looked through section 7 (starting and operating) and there is no mention.

Not saying it was a good idea after just installing a clutch and flywheel. However, for something like having a dead battery I'd rather do that than be stranded.
D-rock240 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.