Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-28-2013, 10:28 AM   #1
bluecrush832002
Scooby Newbie
 
Member#: 369146
Join Date: Sep 2013
Default cooling problems and questions.

First off I like to introduce my self my names Danny. I am new to the subbie world and have done my first build and now having cooling issuses. Hear is what I drive and whats done.

03 wrx
2.0 with forged internals as whole block is done but sleaved.
Damn near stock heads.
Aem fuel pump and fpr
E85
2000cc injects
Stain braid fuel lines bye aeromotive.
Just put new radiator and fans from misho.
Also did stand alone thermal switch and fan over ride.
Greddy oil water seprator
Brand new coolant hoses.
Gt35r rotated kit on 30pld
On aem ems tune.

The problem.
Ive been threw alot blowen heads before I went with building the block, so I know the signs and car is not showing any. Vacum test and leak downs are good.
Water temp I cant seam keep it under 200 and some times gets to the 3rd line.
The temp is fine when running(185-195) but will start heat up when on it and then it will stay at 195-206.

Now my question is what coolant is best to run and is their anything to add to it to keep it cool and should I invest in the radiator shrouds?

Next question is by me buying a stand alone oil cooler will that help cooling?

Do I need re pull my motor and re torque the heads down?

Should I spend extra and get the cobb thermostat?

Motor now has 3600 on it. And please keep in mind I keep my fans on when I know I am going run. But other than that I let the switch do its job. I just want know how I can get my temp back to normal after I do a few runs. I also do let the car cool down before I drive it again. One thing I did notice is my top coolant tank seams to be empty when I check it.

I am open to any and all help and suggestions.
* Registered users of the site do not see these ads.
bluecrush832002 is offline   Reply With Quote
Old 09-28-2013, 11:09 AM   #2
rdieder
Scooby Specialist
 
Member#: 257818
Join Date: Sep 2010
Chapter/Region: SWIC
Location: ABQ, NM
Vehicle:
2007 STi
CGM

Default

Quote:
Originally Posted by bluecrush832002 View Post
The temp is fine when running(185-195) but will start heat up when on it and then it will stay at 195-206.

.
Looks good , wheres the problem?
rdieder is offline   Reply With Quote
Old 09-28-2013, 12:04 PM   #3
bluecrush832002
Scooby Newbie
 
Member#: 369146
Join Date: Sep 2013
Default

Quote:
Originally Posted by rdieder View Post

Looks good , wheres the problem?
The cooling will stay at the 200 range the rest day most time..
bluecrush832002 is offline   Reply With Quote
Old 09-28-2013, 06:36 PM   #4
jaxscuby
Sammo Hung
Moderator
 
Member#: 10613
Join Date: Sep 2001
Chapter/Region: South East
Location: S Ga / Hell Rock
Vehicle:
2002 USDM WRX
WRB

Default

how old is water pump?
jaxscuby is offline   Reply With Quote
Old 09-28-2013, 08:20 PM   #5
Andrewxxcarlson
Scooby Specialist
 
Member#: 316415
Join Date: Apr 2012
Location: Elk Grove, CA
Vehicle:
2006 WRX
WRB

Default

Our cars can be a bitch to burp the coolant system. I'd make sure you have no air in the system. Back feed it through the block, pull off the line off the top resevoir that runs towards the turbo and fill coolant in there til full. Reconnect and burp the top resevoir as normal. My phone and I are retarded. We can't spell resevoir apparently hahah
Andrewxxcarlson is offline   Reply With Quote
Old 09-29-2013, 11:21 AM   #6
bluecrush832002
Scooby Newbie
 
Member#: 369146
Join Date: Sep 2013
Default

Water pump is new I did that with new belts and same with oil pump is new. .

And I will try that when I get a chance Thanks. .

Also what coolant is every one running
bluecrush832002 is offline   Reply With Quote
Old 09-29-2013, 12:31 PM   #7
rdieder
Scooby Specialist
 
Member#: 257818
Join Date: Sep 2010
Chapter/Region: SWIC
Location: ABQ, NM
Vehicle:
2007 STi
CGM

Default

whats normal operating temp supposed to be?, ive read several threads it seems to be as high as 210 is normal
rdieder is offline   Reply With Quote
Old 09-29-2013, 12:48 PM   #8
2011WRXMT
Scooby Specialist
 
Member#: 270426
Join Date: Jan 2011
Chapter/Region: NWIC
Location: Belgrade Montana
Vehicle:
2011 WRX Premium
Satin Pearl White

Default

Quote:
Originally Posted by bluecrush832002 View Post
Water pump is new I did that with new belts and same with oil pump is new. .

And I will try that when I get a chance Thanks. .

Also what coolant is every one running
As far as coolant in my 11 its the Subaru super blue stuff and in my 02 just normal green both cars are mixed at a 50/50 ratio and are good to go in the winters here.
2011WRXMT is offline   Reply With Quote
Old 09-29-2013, 11:38 PM   #9
bluecrush832002
Scooby Newbie
 
Member#: 369146
Join Date: Sep 2013
Default

Quote:
Originally Posted by rdieder View Post
whats normal operating temp supposed to be?, ive read several threads it seems to be as high as 210 is normal
Normall for me is 185 under normal abd if I run and then normal d4ive about 195.
210 and thats 3rd line for me
bluecrush832002 is offline   Reply With Quote
Old 09-29-2013, 11:38 PM   #10
bluecrush832002
Scooby Newbie
 
Member#: 369146
Join Date: Sep 2013
Default

Quote:
Originally Posted by 2011WRXMT View Post

As far as coolant in my 11 its the Subaru super blue stuff and in my 02 just normal green both cars are mixed at a 50/50 ratio and are good to go in the winters here.
Thanks
bluecrush832002 is offline   Reply With Quote
Old 10-01-2013, 05:47 PM   #11
dakyn
Scooby Newbie
 
Member#: 299512
Join Date: Oct 2011
Chapter/Region: RMIC
Location: Fort Collins, CO
Vehicle:
2003 WRX
Aspen White

Default

I had some overheating issues in my 03 wrx recently. It would overheat and then cool down soon after. Ended up replacing the thermometer and that fixed it.
dakyn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:47 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.