Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-11-2013, 06:54 AM   #1
ronaldremedy
Scooby Newbie
 
Member#: 352353
Join Date: Apr 2013
Chapter/Region: NESIC
Vehicle:
2007 wrx
Matte blue

Default help!

So I ran over like a small animal running across the high way,( like a rabbit) and right after it happened my clutch doesn't work.. it like gets stuck to the floor, and when I put it in gear the pulsates on my foot and makes a loud squeeking noise, and can't drive
* Registered users of the site do not see these ads.
ronaldremedy is offline   Reply With Quote
Old 10-11-2013, 07:41 AM   #2
HinshawWRX
Medium Frank
Moderator
 
Member#: 140114
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Common Sense, VA
Vehicle:
2014 Porsche
GT3 (Currently on Fire)

Default

Take it to a shop. Or stick your head under.
HinshawWRX is offline   Reply With Quote
Old 10-11-2013, 07:47 AM   #3
trev762
Scooby Specialist
 
Member#: 280572
Join Date: Apr 2011
Chapter/Region: E. Canada
Location: southern ontario canada
Vehicle:
2011 sti sedan
plasma blue pearl

Default

Should have posted in "transmission & driveline" for a quicker and better response.

Have u looked over the car and could be just coincidence as I cant see how a small animal could cause this.
trev762 is offline   Reply With Quote
Old 10-11-2013, 08:23 AM   #4
bluemax189
Scooby Specialist
 
Member#: 137405
Join Date: Jan 2007
Chapter/Region: MAIC
Location: Baltimore
Vehicle:
2011 WRX
20g

Default

the only way I see something happening after hitting an animal would be if he somehow knicked the hydraulic line somehow. needless to say its highly unlikely given where this is but its something to check for. Check under the hood and make sure you have fluid in there.
bluemax189 is offline   Reply With Quote
Old 10-11-2013, 09:15 AM   #5
JonnyV2889
Scooby Specialist
 
Member#: 197384
Join Date: Dec 2008
Chapter/Region: NESIC
Location: MWV NH
Vehicle:
2006 WRX Ltd
OBP

Default

Don't make duplicate threads! I posted in your other one.
JonnyV2889 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.