Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-28-2013, 07:26 PM   #1
myschims
Scooby Newbie
 
Member#: 355688
Join Date: May 2013
Default Weird clunking from front end, Rack and pinion?

I've read through multiple other threads on the subject and can't seem to find anything that relates to what my problem is. While driving, I can hear a clunking noise coming from the front left area of my car and feel it under my foot when its down by the clutch pedal. It tends to only happen on bumpy roads. Turning has no effect on it as well.

I jacked it up and tried pushing the top and bottom of the tire but that causes no noise, but when pushing on the left and right sides back and forth it makes the clunking noise. I laid underneath the car and can tell its coming from around a boot on the rack and pinion of the car.

Im just trying to figure out if I need to get the whole thing replaced or maybe just the boot part of it. If anyone has any experience with this or any recommendations id love to hear it. Thanks
* Registered users of the site do not see these ads.
myschims is offline   Reply With Quote
Old 10-29-2013, 07:23 AM   #2
Aaron'z 2.5RS
Scooby Guru
 
Member#: 1026
Join Date: Mar 2000
Chapter/Region: MWSOC
Location: Hickigan
Vehicle:
'00 RS/WRX Stg5
'98 RS Stock

Default

Could be inner tie rod end or lower ball joint
Aaron'z 2.5RS is offline   Reply With Quote
Old 11-02-2013, 04:38 PM   #3
homer_atl
Scooby Newbie
 
Member#: 210965
Join Date: May 2009
Vehicle:
2009 WRX

Default

i think i have a similar noise. metal clunk sound during suspension movement and/or turning. i haven't investigated much though. myschims did you ever resolve your issue?

is there an easy way to see if the tie rod ends are messed up? Is there a torn boot or just the rod is loose when you grab on it? thanks.
homer_atl is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:06 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.